0

Запись, проведение и отмена проведения документа 1С

#Все конфигурации#1С Предприятие 8#Документ


Программная запись/проведение/отмена проведения документа осуществляется при помощи метода Записать(<РежимЗаписи>, <РежимПроведения>) ДокументаОбъекта.

В параметр РежимЗаписи передается одно из значений системного перечисления РежимЗаписиДокумента :

  • Запись (Write)
  • ОтменаПроведения (UndoPosting)
  • Проведение (Posting)

Переданное значение и определяет какое действие производить с выбранным документом. Также при помощи параметра РежимПроведения можно указать оперативное или неоперативное проведение мы используем.

Пример №1. Программная запись документа

СсылкаНаДокумент = Документы.АвансовыйОтчет.НайтиПоНомеру("00000000001");

Если НЕ СсылкаНаДокумент = Неопределено Тогда
    ДокументОбъект = СсылкаНаДокумент.ПолучитьОбъект();

    ДокументОбъект.Дата = ТекущаяДата();
    ДокументОбъект.Записать(РежимЗаписиДокумента.Запись);
КонецЕсли;

Пример №2 Программное проведение документа

Запрос = Новый Запрос;

Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(ТекущаяДата()));
Запрос.УстановитьПараметр("КонецПериода" , КонецМесяца(ТекущаяДата()));

Запрос.Текст = "ВЫБРАТЬ
               |    ВозвратТоваровОтПокупателя.Ссылка
               |ИЗ
               |    Документ.ВозвратТоваровОтПокупателя КАК ВозвратТоваровОтПокупателя
               |ГДЕ
               |    ВозвратТоваровОтПокупателя.Дата МЕЖДУ &НачалоПериода И &КонецПериода";

Результат = Запрос.Выполнить().Выгрузить();

Для Каждого ЭлементРезультата из Результат Цикл
    ДокументОбъект = ЭлементРезультата.Ссылка.ПолучитьОбъект();

    ДокументОбъект.Записать(РежимЗаписиДокумента.Проведение);
КонецЦикла;

Пример №3 Программная отмена проведения документа

Запрос = Новый Запрос;

Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(ТекущаяДата()));
Запрос.УстановитьПараметр("КонецПериода" , КонецМесяца(ТекущаяДата()));
Запрос.УстановитьПараметр("Счет90"       , ПланыСчетов.Хозрасчетный.НайтиПоКоду("90"));

Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
               |    ХозрасчетныйОбороты.Регистратор
               |ИЗ
               |    РегистрБухгалтерии.Хозрасчетный.Обороты(&НачалоПериода, &КонецПериода, Регистратор, Счет В ИЕРАРХИИ (&Счет90), , , , ) КАК ХозрасчетныйОбороты";

Результат = Запрос.Выполнить().Выгрузить();

Для Каждого ЭлементРезультата из Результат Цикл
    ДокументОбъект = ЭлементРезультата.Регистратор.ПолучитьОбъект();

    ДокументОбъект.Записать(РежимЗаписиДокумента.ОтменаПроведения);
КонецЦикла;
0 12951 0
ДобавленоVital795 дней назад
Отредактировано652 дня назад


Добавить комментарий

Добавить статью!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Проводки и хозяйственные операции документа: Запись книги учета доходов и расходов (ИП)

СчетДт СчетКт Содержание Меню Вид операции документа Закладка документа Регист...

Программное создание документа в 1С 8

Для того что бы программно создать документ необходимо воспользоваться методом С...

Создание обработки заполнения табличной части 1С 8

1. Постановка задачи В этой статье рассмотрим процесс написания простейшей внеш...

Создание внешнего отчета в 1с 8

Рассмотрим создание внешнего отчета в 1с 8 без использования системы компоновки ...

Как изменить справочник из документа 1С

Помогите,пожалуйста!!! Мне необходимо, чтобы, когда в табличной части документа ...

Новое

Swiss replica calidad superior mikrogirder relojes en línea .

[b][url=http://es.tagheuerwatches.me/]TAG Heuer relojes lista de precios[/url][/...

Blancpain Replilca relojes suizos

[b][url=http://www.fakewatchesuk.cc/es/]réplicas de relojes suizos aaa +[/url][/...

Vestidos baratos de la boda, vestidos de partido en línea, los mejores vestidos de boda, vestidos de diseñador Online

[b][url=http://es.weddingsales.cn/]Comprar Vestidos de novia[/url][/b] [b]Compra...

Crear cuenta : Profesional réplicas de relojes tienda, buywatch.top

omega relojes a la venta relojes Omega réplica [b][url=http://www.buywatch.top/e...