0

В каких подписках на событие 1С участвует документ или справочник?

#1С Предприятие 8#Документ#Справочники 1С


Это можно сделать при помощи простой процедуры. Пусть у нас во внешней обработке есть реквизит Тип с типом данных ОписаниеТипов. Тогда поиск подписок будет выглядеть так:

Процедура НайтиПодпискиНаСобытияОбъектаМетаданных()
     ТекстДок = Новый ТекстовыйДокумент;

     ТекущийТип = Тип.Типы();

     Для Каждого Подписка Из Метаданные.ПодпискиНаСобытия Цикл
     ИмяОбъектаМетаданных = Метаданные.НайтиПоТипу(ТекущийТип[0]).ПолноеИмя();

     ИмяТипа = СтрЗаменить(ИмяОбъектаМетаданных,".","Объект.");

     Если Подписка.Источник.СодержитТип(Тип(ИмяТипа)) Тогда
         ТекстДок.ДобавитьСтроку(Подписка.Имя);
     КонецЕсли;
      КонецЦикла;

      ТекстДок.Показать("Подписки на события");
КонецПроцедуры
0 2407 0
ДобавленоVital698 дней назад
Отредактировано646 дней назад


Добавить комментарий

Добавить статью!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Создание обработки заполнения табличной части 1С 8

1. Постановка задачи В этой статье рассмотрим процесс написания простейшей внеш...

Создание внешнего отчета в 1с 8

Рассмотрим создание внешнего отчета в 1с 8 без использования системы компоновки ...

Загрузка файла dbf в таблицу значений

1) Для начала надо выбрать файл с диска. Это можно сделать при помощи такой функ...

Открытие дополнительного отчета в 1С программно

В данной статье будет рассмотрен процесс открытия(и формирования) внешнего отчет...

Создание печатной формы для управляемого приложения в 1с 8.3

1. Задача Рассмотрим написание простейшей печатной формы в 1с 8.2 - 8.3 для упр...

Новое

Moncler Frauen 2014 Moncler Outlet Australien zum Verkauf

[b]moncler Jacken[/b] [b]moncler Jacken[/b] Günstige Moncler Jacken Outlet Onlin...

Brautkleider , A- Linie Brautkleider

Hochzeitskleider Online besten Brautkleider Designs [b][url=http://www.weddingdr...

Montblanc

[b]Montblanc[/b][b][url=http://www.montblanc146.co/de/]Montblanc Kugelschreiber[...

Moncler 2014: UK Moncler Outlet - Offizielle Moncler Sale UK Online

[b][url=http://www.mymonclernews.net/de/]moncler Verkauf[/url][/b] [b][url=http:...

Replica Breguet Uhren , Imitation Breguet Replica Watches, Fake- Breguet

[b][url=http://de.watchesvipstore.org/]qualitativ hochwertigen Uhren Replika[/ur...