0

В каких подписках на событие 1С участвует документ или справочник?

#1С Предприятие 8#Документ#Справочники 1С


Это можно сделать при помощи простой процедуры. Пусть у нас во внешней обработке есть реквизит Тип с типом данных ОписаниеТипов. Тогда поиск подписок будет выглядеть так:

Процедура НайтиПодпискиНаСобытияОбъектаМетаданных()
     ТекстДок = Новый ТекстовыйДокумент;

     ТекущийТип = Тип.Типы();

     Для Каждого Подписка Из Метаданные.ПодпискиНаСобытия Цикл
     ИмяОбъектаМетаданных = Метаданные.НайтиПоТипу(ТекущийТип[0]).ПолноеИмя();

     ИмяТипа = СтрЗаменить(ИмяОбъектаМетаданных,".","Объект.");

     Если Подписка.Источник.СодержитТип(Тип(ИмяТипа)) Тогда
         ТекстДок.ДобавитьСтроку(Подписка.Имя);
     КонецЕсли;
      КонецЦикла;

      ТекстДок.Показать("Подписки на события");
КонецПроцедуры
0 3944 0
ДобавленоVital869 дней назад
Отредактировано817 дней назад


Добавить комментарий

Добавить статью!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Создание обработки заполнения табличной части 1С 8

1. Постановка задачи В этой статье рассмотрим процесс написания простейшей внеш...

Создание внешнего отчета в 1с 8

Рассмотрим создание внешнего отчета в 1с 8 без использования системы компоновки ...

Загрузка файла dbf в таблицу значений

1) Для начала надо выбрать файл с диска. Это можно сделать при помощи такой функ...

Открытие дополнительного отчета в 1С программно

В данной статье будет рассмотрен процесс открытия(и формирования) внешнего отчет...

Создание печатной формы для управляемого приложения в 1с 8.3

1. Задача Рассмотрим написание простейшей печатной формы в 1с 8.2 - 8.3 для упр...

Новое

Загрузка адресного классификатора (КЛАДР) в 1С 8.2

Сразу после создания новой базы 1С рекомендуется загрузить в нее адресный класси...

Регистрация на сайте users.v8.1c.ru по пинкоду

После того как вы приобрели программу, вы можете скачивать обновления для нее с ...

Сравнение данных разных баз 1С 8 и/или SQL

Обработка Консоль сравнения данных из разных источников предназначена для сравне...

Скачать печатные формы документа "Реализация товаров и услуг" 1С 8.2

Печатные формы из релиза 1C:Бухгалтерия 2.0.64.5 Скачать бесплатно печатную фор...

Как снять и поставить конфигурацию 1С на поддержку

В этой статье я расскажу как снять конфигурацию 1С 8 частично или полностью с по...