0

Создание Документа Акт разделки в 1С 8.2

#1С 8.2#Обычное приложение#Документ


Здравствуйте! Мне нужна помощь.Я только новичок,не судите строго. Я создаю новый документ “Акт Разделки” . Мне необходимо, чтобы в шапке, при выборе Товара, сразу отображался Документ Поступления. И чтобы остальные реквизиты шапки подтягивались из Документа Поступления. Подскажите кто может, как это сделать… И если можно какой-нибудь пример. Буду очень сильно признательна. Спасибо

0 1276 7
ДобавленоАнастасия1992563 дня назад
Отредактировано549 дней назад


Добавить комментарий

Кирилл написал:562 дня назад0

Добрый день!

Вам нужно брать последнее поступление по этой туше?

Примерная последовательность действий:

  1. Создаете обработчик “при изменении” на поле “товар”

  2. Находите запросом ближайшее поступление по этому товару

  3. Вытаскиваете из поступления все нужные реквизиты и заполняете их в документе. Можно даже попробовать подобную функцию:

    ЗаполнитьЗначениеСвойств(ЭтотОбъект, СсылкаНаНайденныйДокумент);

Система сама заполнит все возможные реквизиты, которые сопоставит по имени.

Ответить

Анастасия1992 написал:562 дня назад0

Спасибо большое, а можно какой-нибудь пример по этому поводу, все-таки наглядно увидеть. Буду очень благодарна.

Ответить

Кирилл написал:561 день назад0

Пример не смогу дать - потому что нет вашей конфигурации.

Примерно так:

Процедура ПриИзмененииТовара(...)

Запрос = Новый Запрос;
Запрос.Текст = "... получаем последний документ из регистра накоплений по данному товару"
Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Следующий() Тогда
    ЗаполнитьЗначениеСвойств(ЭтотОбъект, Выборка.СсылкаНаНайденныйДокумент);
Иначе
    Сообщить("Не найден документ");
КонецЕсли;

КонецПроцедуры;

Ответить

Анастасия1992 написал:561 день назад0

Спасибо получилось. Вот только, каким образом можно сделать, чтобы я могла, изменив количество в Документе “Акт разделки”, у меня пересчитались все суммы. И самое главное, чтобы количество в “Акт разделки” не было больше Количества в “Поступлении ТМЦ ”? Можно на примере. Буду благодарна.

Ответить

Кирилл написал:560 дней назад0

Пересчет сумм - вешаете на каждое поле обработчики, где пересчитываете нужные поля. Тут простая арифметика…

Вы уже знаете как получать последний документ поступления ТМЦ)) Получится что то вроде:

Если Количество > ДокументПоступление.КоличествоПоступило Тогда
Сообщить("Мяса не хватает, дружище!");
КонецЕсли;

Ответить

Анастасия1992 написал:555 дней назад0

Спасибо=)

Ответить

Кирилл написал:554 дня назад0

Всегда пожалуйста))

Ответить

Добавить комментарий

Добавить статью!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Программное создание документа в 1С 8

Для того что бы программно создать документ необходимо воспользоваться методом С...

Создание обработки заполнения табличной части 1С 8

1. Постановка задачи В этой статье рассмотрим процесс написания простейшей внеш...

Настройка двухстороннего обмена данными между конфигурациями "Управление торговлей 10.3" и "Бухгалтерия предприятия 2.0" в 1С 8

В этой статье мы рассмотрим как настроить двухсторонний обмен данными между конф...

Документ "Банковская Выписка"

Здравствуйте! Мне необходимо доработать документ “Банковская выписку” 1С 8.2 Бух...

Как изменить справочник из документа 1С

Помогите,пожалуйста!!! Мне необходимо, чтобы, когда в табличной части документа ...

Новое

Загрузка адресного классификатора (КЛАДР) в 1С 8.2

Сразу после создания новой базы 1С рекомендуется загрузить в нее адресный класси...

Регистрация на сайте users.v8.1c.ru по пинкоду

После того как вы приобрели программу, вы можете скачивать обновления для нее с ...

Сравнение данных разных баз 1С 8 и/или SQL

Обработка Консоль сравнения данных из разных источников предназначена для сравне...

Скачать печатные формы документа "Реализация товаров и услуг" 1С 8.2

Печатные формы из релиза 1C:Бухгалтерия 2.0.64.5 Скачать бесплатно печатную фор...

Как снять и поставить конфигурацию 1С на поддержку

В этой статье я расскажу как снять конфигурацию 1С 8 частично или полностью с по...