Рассмотрим задачу: необходимо рассылать всем пользователям 1С сообщения с какой либо информацией. Предлагаю для этого следующее решение:

1. В модуль обычного приложения в процедуру ПриНачалеРаботыСистемы добавляем следующий код:

ФормаОбработки = Обработки.ОповещенияПользователя.ПолучитьФорму("Форма");
ФормаОбработки .Открыть();

2. Создаем Общий модуль, называем его “опМодуль”, в модуль вставляем такой код:

Функция ВывестиОповещение(ИмяОтчета);
     ИмяФайла = ПолучитьИмяВременногоФайла();
     Отчет = Справочники.ВнешниеОбработки.НайтиПоНаименованию(ИмяОтчета);
     ДвоичныеДанные = Отчет.ХранилищеВнешнейОбработки.Получить();
     ДвоичныеДанные.Записать(ИмяФайла);
     опФорма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
     опФорма.Открыть();
     УдалитьФайлы(ИмяФайла);
КонецФункции

Процедура ПроверкаНовыхОповещений() Экспорт

     ОтборПользователей = Новый Структура("Пользователь");
     ОтборПользователей.Пользователь = ПараметрыСеанса.ТекущийПользователь;
     Оповещения = РегистрыСведений.ОповещениеПользователей.Выбрать(ОтборПользователей);
     КолОп = 0;
     Пока Оповещения.Следующий() Цикл
        Если Оповещения.Просмотрено Тогда
        Продолжить;
        КонецЕсли;
        КолОп = КолОп + 1;
    КонецЦикла;
     Если (КолОп>0) Тогда
       ВывестиОповещение("Оповещения пользователя");
     КонецЕсли;
   КонецПроцедуры

   Процедура ЗадатьИнтервал(Интервал) Экспорт
      ПодключитьОбработчикОжидания("ПроверкаНовыхОповещений",Интервал,5);
   КонецПроцедуры

   Процедура ОчиститьИнтервал() Экспорт
      ОтключитьОбработчикОжидания("ПроверкаНовыхОповещений");
   КонецПроцедуры

3. Создаем регистр сведений “ОповещениеПользователей”

Добавляем измерения: “Пользователь” Тип:“СправочникСсылка.Пользователи”, “Дата” Тип:“Дата” состав даты “Дата и время”, “Владелец"  Тип:"СправочникСсылка.Пользователи”,

Ресурсы: “Просмотрено” Тип: “Булево”, “Оповещение” Тип: “Строка”

4. Добавляем в конфигурацию обработки из файла и пользуемся

Принцип Работы:

При запуске 1с с правой стороны в трее открывается оповещение пользователей. Открываем обработку “Оповестить”, пишем текст сообщения и отметив получателей отправляем.

Когда сообщение приходит получателю, у него открывается форма оповещения. Что бы сообщение считалось прочитанным, его необходимо открыть двойным щелчком правой клавиши мыши. В дальнейшем эти сообщения можно будет просматривать во вкладке “Просмотреные”.

0 4588 1
Добавлено829 дней назад
Последняя активность37 дней назад


Добавить комментарий

Аноним написал:37 дней назад0

Интересная статья. А как выводить сообщения сразу минуя Форму - сразу на ФормуЭлемента?

Ответить

Добавить статью!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Создание обработки заполнения табличной части 1С 8

1. Постановка задачи В этой статье рассмотрим процесс написания простейшей внеш...

Создание печатной формы в 1с 8

1. Задача Рассмотрим написание простейшей печатной формы в 1с 8.1 - 8.2 на прим...

Создание внешнего отчета в 1с 8

Рассмотрим создание внешнего отчета в 1с 8 без использования системы компоновки ...

Создание печатной формы для управляемого приложения в 1с 8.3

1. Задача Рассмотрим написание простейшей печатной формы в 1с 8.2 - 8.3 для упр...

Загрузка в 1C из Excel

В этой статье я расскажу как с помощью универсальной обработки “Загрузка данных ...

Новое

Скачать печатные формы документа "Реализация товаров и услуг" 1С 8.2

Печатные формы из релиза 1C:Бухгалтерия 2.0.64.5 Скачать бесплатно печатную фор...

Как снять и поставить конфигурацию 1С на поддержку

В этой статье я расскажу как снять конфигурацию 1С 8 частично или полностью с по...

Как сделать резервную копию 1С

Чтобы обезопасить себя от частичной или полной потери данных, перед тем как прои...

Настройка двухстороннего обмена данными между конфигурациями "Управление торговлей 10.3" и "Бухгалтерия предприятия 2.0" в 1С 8

В этой статье мы рассмотрим как настроить двухсторонний обмен данными между конф...

Тестирование и исправление информационной базы 1С 8

Тестирование и исправление информационной базы 1С 8 необходимо выполнять в случа...