0

Программное переименование заголовков полей в СКД

#1С Предприятие 8#Система компоновки данных 1С (СКД)


При написании отчета использующего СКД бывает необходимо программно задавать заголовки полей отчета. Сделать это можно, например в процедуре ПриКомпоновкеРезультата расположенной в модуле объекта отчета.

Для начала получим текущие настройки СКД.

Настройки = КомпоновщикНастроек.ПолучитьНастройки();

Далее при помощи цикла обойдем все поля выбранные в отчет.

Для Каждого ЭлементВыбора Из Настройки.Выбор.Элементы Цикл
КонецЦикла;

Присваиваем полям нужный заголовок.

ЭлементВыбора.Заголовок = "Мой заголовок";

после чего загружаем измененные настройки обратно в схему компоновки.

КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);

Рассмотрим небольшой пример:

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)

    НастройкиКД = КомпоновщикНастроек.ПолучитьНастройки();
    Дата =  КомпоновкаДанныхКлиентСервер.ПолучитьПараметр(КомпоновщикНастроек,"Месяц").Значение;
    СтрокаФормата = "ДФ = МММгггг";
    Для Каждого ЭлементВыбора Из НастройкиКД.Выбор.Элементы Цикл

        Если ЭлементВыбора.Поле =  Новый ПолеКомпоновкиДанных("СреднемесячныеПродажиМинус1СУчетомТекущегоГода") Тогда
            ЭлементВыбора.Заголовок =    "Среднемесяные продажи " + Формат(ДобавитьМесяц(Дата,-1),СтрокаФормата) + " с учетом текущего года";
        Конецесли;

        Если ЭлементВыбора.Поле =  Новый ПолеКомпоновкиДанных("СреднемесячныеПродажиМесяцаМинус1") Тогда
            ЭлементВыбора.Заголовок =    "Среднемесяные продажи " + Формат(ДобавитьМесяц(Дата,-1),СтрокаФормата);
        Конецесли;

        Если ЭлементВыбора.Поле =  Новый ПолеКомпоновкиДанных("СреднемесячныеПродажиМесяцаМинус2") Тогда
            ЭлементВыбора.Заголовок =    "Среднемесяные продажи " + Формат(ДобавитьМесяц(Дата,-2),СтрокаФормата);
        Конецесли;

    КонецЦикла;

    КомпоновщикНастроек.ЗагрузитьНастройки(НастройкиКД);
КонецПроцедуры
0 4003 0
ДобавленоVital828 дней назад
Отредактировано625 дней назад


Добавить комментарий

Добавить статью!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Создание обработки заполнения табличной части 1С 8

1. Постановка задачи В этой статье рассмотрим процесс написания простейшей внеш...

Создание простого отчета на 1С

Рассмотрим процесс написание простого отчета с использованием Системы компоновки...

Создание внешнего отчета в 1с 8

Рассмотрим создание внешнего отчета в 1с 8 без использования системы компоновки ...

Загрузка файла dbf в таблицу значений

1) Для начала надо выбрать файл с диска. Это можно сделать при помощи такой функ...

Открытие дополнительного отчета в 1С программно

В данной статье будет рассмотрен процесс открытия(и формирования) внешнего отчет...

Новое

Сравнение данных разных баз 1С 8 и/или SQL

Обработка Консоль сравнения данных из разных источников предназначена для сравне...

Скачать печатные формы документа "Реализация товаров и услуг" 1С 8.2

Печатные формы из релиза 1C:Бухгалтерия 2.0.64.5 Скачать бесплатно печатную фор...

Как снять и поставить конфигурацию 1С на поддержку

В этой статье я расскажу как снять конфигурацию 1С 8 частично или полностью с по...

Как сделать резервную копию 1С

Чтобы обезопасить себя от частичной или полной потери данных, перед тем как прои...

Настройка двухстороннего обмена данными между конфигурациями "Управление торговлей 10.3" и "Бухгалтерия предприятия 2.0" в 1С 8

В этой статье мы рассмотрим как настроить двухсторонний обмен данными между конф...