0

Как программно передать параметры в СКД 1С

#1С 8.2#1С 8.3#1С Бухгалтерия 2.0#Система компоновки данных 1С (СКД)


Если вы используете конфигурацию 1С:Бухгалтерия 2.0, то можно воспользоваться процедурой из модуля ТиповыеОтчеты.

Пример:

ТиповыеОтчеты.УстановитьПараметр(КомпоновщикНастроек, "НачалоПериода", НачалоДня(ДатаНачала));

Выглядит она так:

// Устанавливает параметр данных компоновщика настроек
Функция УстановитьПараметр(КомпоновщикНастроекКоллекцияЗначений, ИмяПараметра, Значение, Использование = Истина) Экспорт

    Если ТипЗнч(КомпоновщикНастроекКоллекцияЗначений) = Тип("КомпоновщикНастроекКомпоновкиДанных") Тогда
    ЗначениеПараметра = КомпоновщикНастроекКоллекцияЗначений.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных(ИмяПараметра));
    ИначеЕсли ТипЗнч(КомпоновщикНастроекКоллекцияЗначений) = Тип("КоллекцияЗначенийПараметровКомпоновкиДанных") Тогда
    ЗначениеПараметра = КомпоновщикНастроекКоллекцияЗначений.Найти(ИмяПараметра);
    ИначеЕсли ТипЗнч(КомпоновщикНастроекКоллекцияЗначений) = Тип("ОформлениеКомпоновкиДанных") Тогда
    ЗначениеПараметра = КомпоновщикНастроекКоллекцияЗначений.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных(ИмяПараметра));
    КонецЕсли;

    Если ЗначениеПараметра = Неопределено Тогда
    Возврат Неопределено;
    Иначе
    ЗначениеПараметра.Использование = Использование;
    ЗначениеПараметра.Значение      = Значение;
    Возврат ЗначениеПараметра;
    КонецЕсли;

КонецФункции

При необходимости можно скопировать ее в свой модуль.

Передавать параметры в систему компоновки данных можно, например, в процедуре формирования отчета:

Процедура СформироватьОтчет(Результат = Неопределено, ДанныеРасшифровки = Неопределено, ВыводВФормуОтчета = Истина, ВнешниеНаборыДанных = Неопределено) Экспорт

    Результат.Очистить();

    Настройки = КомпоновщикНастроек.ПолучитьНастройки();

    ТиповыеОтчеты.УстановитьПараметр(КомпоновщикНастроек, "НачалоПериода", НачалоДня(ДатаНачала));
    ТиповыеОтчеты.УстановитьПараметр(КомпоновщикНастроек, "КонецПериода",  КонецДня(ДатаОкончания));

    СтандартныеОтчеты.ВывестиОтчет(ЭтотОбъект, Результат, ДанныеРасшифровки, ВыводВФормуОтчета, ВнешниеНаборыДанных, Истина);
    КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);

    Результат.ОтображатьЗаголовки = Истина;
    // Выполним дополнительную обработку Результата отчета
    СтандартныеОтчеты.ОбработкаРезультатаОтчета(ЭтотОбъект, Результат);

КонецПроцедуры
0 8213 0
ДобавленоVital806 дней назад
Отредактировано650 дней назад


Добавить комментарий

Добавить статью!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Создание обработки заполнения табличной части 1С 8

1. Постановка задачи В этой статье рассмотрим процесс написания простейшей внеш...

Открытие дополнительного отчета в 1С программно

В данной статье будет рассмотрен процесс открытия(и формирования) внешнего отчет...

Как сформировнать отчет в 1С СКД программно

Процедура формирования отчета на СКД для 1С:Бухгалтерии 2.0. Процедура Сформиро...

Вывод результата отчета на СКД в таблицу значений 1С

Процедура реализующая вывод результата СКД в Таблицу значений. Процедура Сформи...

Создание печатной формы для управляемого приложения в 1с 8.3

1. Задача Рассмотрим написание простейшей печатной формы в 1с 8.2 - 8.3 для упр...

Новое

Сравнение данных разных баз 1С 8 и/или SQL

Обработка Консоль сравнения данных из разных источников предназначена для сравне...

Скачать печатные формы документа "Реализация товаров и услуг" 1С 8.2

Печатные формы из релиза 1C:Бухгалтерия 2.0.64.5 Скачать бесплатно печатную фор...

Как снять и поставить конфигурацию 1С на поддержку

В этой статье я расскажу как снять конфигурацию 1С 8 частично или полностью с по...

Как сделать резервную копию 1С

Чтобы обезопасить себя от частичной или полной потери данных, перед тем как прои...

Настройка двухстороннего обмена данными между конфигурациями "Управление торговлей 10.3" и "Бухгалтерия предприятия 2.0" в 1С 8

В этой статье мы рассмотрим как настроить двухсторонний обмен данными между конф...