0

Как изменить справочник из документа 1С

#1С 8.2#1С Предприятие 8#Обычное приложение#Документ


Помогите,пожалуйста!!! Мне необходимо, чтобы, когда в табличной части документа я изменю “Коэффициент сортности”, и в шапке документа нажму на галочку “Записать коэффициенты сортности”, то измененные “Коэффициенты Сортности” запишутся в справочник “Нормы выхода”. Вот мой код:

Процедура ФлагЗаписиКоэффСортностиПриИзменении(Элемент)

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|   АктРазделкиРазделка.Ссылка
|ПОМЕСТИТЬ ВТДок
|ИЗ
|   Документ.АктРазделки.Разделка КАК АктРазделкиРазделка
|ГДЕ
|   АктРазделкиРазделка.Ссылка = &Ссылка
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
|   НормыВыхода.Ссылка,
|   НормыВыхода.КоэффициентСортности
|ИЗ
|   Справочник.НормыВыхода КАК НормыВыхода
|ГДЕ
|   НормыВыхода.Ссылка В
|           (ВЫБРАТЬ
|               ВТДок.Ссылка
|           ИЗ
|               ВТДок КАК ВТДок)";

Запрос.УстановитьПараметр("Ссылка", Ссылка);
Результат = Запрос.Выполнить().Выбрать();
Пока Результат.Следующий() Цикл
///???????????????? а тут не могу понять как правильно сделать!!!!!
КонецЦикла;

КонецПроцедуры

Может есть какой-то способ по проще, то буду благодарна. Спасибо

0 984 9
ДобавленоАнастасия1992382 дня назад
Последняя активность381 день назад


Добавить комментарий

Кирилл написал:382 дня назад0

Доброго дня!

Я так понимаю что нужно в первом подзапросе еще и затянуть коэффицент из табличной части… :

ВЫБРАТЬ АктРазделкиРазделка.Ссылка, АктРазделкиРазделка.<НазваниеКоэффицента>

В цикле так:

ТекОб = Результат.Ссылка.ПолучитьОбъект();
ТекОб.КоэффициентСортности = Результат.<НазваниеКоэффицентаИзТабличной части>;
ТекОб.Записать();

Ответить

Анастасия1992 написал:382 дня назад0

Я правильно понимаю???

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
    |   АктРазделкиРазделка.Ссылка,
    |   АктРазделкиРазделка.КоэффициентСортности
    |ПОМЕСТИТЬ ВТДок
    |ИЗ
    |   Документ.АктРазделки.Разделка КАК АктРазделкиРазделка
    |ГДЕ
    |   АктРазделкиРазделка.Ссылка = &Ссылка
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ
    |   НормыВыхода.Ссылка,
    |   НормыВыхода.КоэффициентСортности
    |ИЗ
    |   Справочник.НормыВыхода КАК НормыВыхода
    |ГДЕ
    |   НормыВыхода.Ссылка В
    |           (ВЫБРАТЬ
    |               ВТДок.Ссылка
    |           ИЗ
    |               ВТДок КАК ВТДок)";

    Запрос.УстановитьПараметр("Ссылка", Ссылка); 
    Результат = Запрос.Выполнить().Выбрать();
    Пока Результат.Следующий() Цикл
        ТекОбъект = Результат.Ссылка.ПолучитьОбъект();
        ТекОбъект.КоэффициентСортности = Результат.КоэффициентСортности;
        Текобъект.Записать();
    КонецЦикла;
     Сообщить("готово!!!");
 КонецПроцедуры

В таком случае он цикл просто проходит мимо((((

Ответить

Кирилл написал:382 дня назад0

Упс, я тупанул, не много не так….

А в табличной части есть вообще на справочник с нормами ссылка? )

КоэффициентСортности - это число?

Ответить

Анастасия92 написал:382 дня назад0

Да, вы правы

Ответить

Анастасия92 написал:382 дня назад0

Да, у меня есть норма выхода в табличной части, но есть одно но в его заполнении!!! У меня в шапке есть поле Схема. Когда мы выбираем, необходимую схему и когда нажимаем на кнопку “Использовать схему”, то табличная часть автоматически заполняется данными выбранной схемы. Чтобы не было вопроса зачем же справочник “Нормы Выхода”, сразу скажу. Сама схема (как будет разделываться товар) заносится в справочник “Нормы выхода”. Там и вносится мой коэффициент сортности. Т.е. Справочник “Схема” является владельцем справочники “Нормы выхода”.

Вот код, когда я выбрала схему и нажимаю на кнопку “Использовать схему”…

Процедура ИспользоватьСхемуНажатие(Элемент)

Режим = РежимДиалогаВопрос.ДаНет; Текст = “ru = ”“Использовать схему разделки?”“”;

Ответ = Вопрос(НСтр(Текст), Режим, 0); Если Ответ = КодВозвратаДиалога.Нет Тогда Возврат; Иначе Если обПустоеЗначение(СхемаРазделки) Тогда Предупреждение(“Заполните схему разделки”); КонецЕсли; Разделка.Очистить(); Выборка = Справочники.НормыВыхода.Выбрать(,СхемаРазделки); КоличествоНетто = Количество; Пока Выборка.Следующий() Цикл НоваяСтрока = Разделка.Добавить(); НоваяСтрока.ТМЦ = Выборка.Полуфабрикат; НоваяСтрока.КоэффициентСортности = Выборка.КоэффициентСортности; НоваяСтрока.НормаВыхода = Выборка.НормаВыхода; НоваяСтрока.КоличествоПФ = КоличествоНетто * Выборка.НормаВыхода/100; НоваяСтрока.КоличествоПоНорме = НоваяСтрока.КоличествоПФ; НоваяСтрока.СчетДебет = СчетКредит; НоваяСтрока.ЕдиницаИзмерения = Выборка.Полуфабрикат.БазоваяЕдиница; Если ФлагИндивидТоргНадбавки = Истина Тогда НоваяСтрока.ТоргНадбавкаСтр = ТоргНадбавка; КонецЕсли; КонецЦикла; КонецЕсли; КонецПроцедуры

Ответить

Анастасия92 написал:382 дня назад0

Вот, когда я только нажимаю на выбор необходимой схемы, мне открывается справочник “Схемы”, а когда нажимаю перейти видно справочник “Норма выхода” , где и храниться сама схема и мои коэффициенты

Ответить

Анастасия1992 написал:381 день назад0

Спасибо, разобралась=)

Ответить

Кирилл написал:381 день назад0

Вы молодец!)

Ответить

Добавить комментарий

Добавить статью!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Запись, проведение и отмена проведения документа 1С

Программная запись/проведение/отмена проведения документа осуществляется при пом...

Программное создание документа в 1С 8

Для того что бы программно создать документ необходимо воспользоваться методом С...

Создание обработки заполнения табличной части 1С 8

1. Постановка задачи В этой статье рассмотрим процесс написания простейшей внеш...

Создание внешнего отчета в 1с 8

Рассмотрим создание внешнего отчета в 1с 8 без использования системы компоновки ...

Настройка двухстороннего обмена данными между конфигурациями "Управление торговлей 10.3" и "Бухгалтерия предприятия 2.0" в 1С 8

В этой статье мы рассмотрим как настроить двухсторонний обмен данными между конф...

Новое

Timberland 6 дюймов Премиум Сапоги мужские гуммигут [Timberland_SL26103136] - $105.00 : Timberland outlet, timberlandoutlet.cn

Timberland 6 дюймов Timberland Дети сапоги на выходе [b][url=http://www.timberla...

Lady-Datejust

Rolex Submariner Rolex Submariner [b][url=http://www.rolexdaytona.top/ru/]swiss ...

Колумбийский спортивная одежда outletstoreTERTIARY_SECTIONcolumbiaoutdooroutletstore.top

Колумбия куртки Колумбия куртки [b][url=http://www.columbiaoutdooroutletstore.to...