0

Запрос, возрат поиск документа

#1С 8.2#1С ЗУП 2.5#Windows

Добрый день ребята. Такой вопрос, мне нужно написать запрос. Который бы брал из документа информацию. Проблема в том что он ее берет из планы видов счетов и записывает в документ. Потерялся в коде, не могу найти куда уходит значение в какой риквезит записывается.

Мой

функция АрендаАТ(Сотрудник1) Запрос=Новый Запрос; Запрос= “ВЫБРАТЬ | РегистрацияРазовыхНачисленийРаботниковОрганизаций.Ссылка, | РегистрацияРазовыхНачисленийРаботниковОрганизаций.ДополнительныеНачисления.( | ВидРасчета.КатегорияРасчета.Ссылка | ) |ИЗ | Документ.РегистрацияРазовыхНачисленийРаботниковОрганизаций КАК РегистрацияРазовыхНачисленийРаботниковОрганизаций |ГДЕ | РегистрацияРазовыхНачисленийРаботниковОрганизаций.ДополнительныеНачисления.Сотрудник = &Сотрудник | И РегистрацияРазовыхНачисленийРаботниковОрганизаций.ДополнительныеНачисления.Сотрудник.ДатаНачала = &ДатаНачала | И РегистрацияРазовыхНачисленийРаботниковОрганизаций.ДополнительныеНачисления.Сотрудник.ДатаОкончания = &ДатаОкончания”

КонецФункции код

не правильный код бравший значения из справочника

//Функция АрендаАТ(Сотрудник1) //Сообщить(“ГРАФА 13”); // Значения = РегистрыСведений.ЗначенияСвойствОбъектов.СоздатьНаборЗаписей(); // Значения.Отбор.Объект.Установить(Сотрудник1); // Значения.Отбор.Свойство.Установить(ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоКоду(“0009”)); //АрендаАТкомпенсация // Значения.Прочитать(); // Если Значения.Количество() > 0 Тогда //Сообщить(Значения[0].Значение); // Возврат(Значения[0].Значение); // Иначе //Сообщить(0); // Возврат(0); // КонецЕсли; //КонецФункции

 65 0
ДобавленоAkbar19 дней назад
Отредактировано19 дней назад


Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Как получить значение реквизита формы и передать его в запрос 1С

Задача: при открытии элемента справочника нужно получить значение поля Код этого...

Выбрать значение табличной части документа

Нужно выбрать из всех документов “РеализацияТоваровУслуг” документы по параметра...

Передача реквизита формы в запрос

Дамы и Господа помогите ! Опыт небольшой . Совсем запутался . Хочу передать рекв...

Запрос к бухгалтерским итогам по месяцам

Привет Всем Столкнулся с такой задачей, нужно было составить запрос к бухгалтерс...

Достать значение с табличного поля

Доброго дня! Платформа 8.3 Толстый клиент. УТ 10.3 Подскажите в каком направлени...

Новое

Ошибка при выгрузке информационной базы

При выгрузке ИБ в конфигураторе возникает ошибка (Запись дампа и “Программа "1cv...

Vendita UGG, Ugg economici Pantofole Stivali Online

ugg boots per le donne ugg boots. [b][url=http://www.uggsmen.top/it/]ugg vendita...

Gioielli Pandora Uscita, Pandora gioielli a buon mercato a Pandora Jewelly deposito

Pandora Bracciali e collane per le donne Bracciali Pandora fai da te con charms ...

Donna Canada Goose Goose Parka Dawson Summit Rosa - €295.74 : orologi replica Omega, canadagooseonsale.top

canada - 2016il canada goosecanada - vest [b][url=http://www.canadagooseonsale.t...