0

Запрос, возрат поиск документа

#1С 8.2#1С ЗУП 2.5#Windows

Добрый день ребята. Такой вопрос, мне нужно написать запрос. Который бы брал из документа информацию. Проблема в том что он ее берет из планы видов счетов и записывает в документ. Потерялся в коде, не могу найти куда уходит значение в какой риквезит записывается.

Мой

функция АрендаАТ(Сотрудник1) Запрос=Новый Запрос; Запрос= “ВЫБРАТЬ | РегистрацияРазовыхНачисленийРаботниковОрганизаций.Ссылка, | РегистрацияРазовыхНачисленийРаботниковОрганизаций.ДополнительныеНачисления.( | ВидРасчета.КатегорияРасчета.Ссылка | ) |ИЗ | Документ.РегистрацияРазовыхНачисленийРаботниковОрганизаций КАК РегистрацияРазовыхНачисленийРаботниковОрганизаций |ГДЕ | РегистрацияРазовыхНачисленийРаботниковОрганизаций.ДополнительныеНачисления.Сотрудник = &Сотрудник | И РегистрацияРазовыхНачисленийРаботниковОрганизаций.ДополнительныеНачисления.Сотрудник.ДатаНачала = &ДатаНачала | И РегистрацияРазовыхНачисленийРаботниковОрганизаций.ДополнительныеНачисления.Сотрудник.ДатаОкончания = &ДатаОкончания”

КонецФункции код

не правильный код бравший значения из справочника

//Функция АрендаАТ(Сотрудник1) //Сообщить(“ГРАФА 13”); // Значения = РегистрыСведений.ЗначенияСвойствОбъектов.СоздатьНаборЗаписей(); // Значения.Отбор.Объект.Установить(Сотрудник1); // Значения.Отбор.Свойство.Установить(ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоКоду(“0009”)); //АрендаАТкомпенсация // Значения.Прочитать(); // Если Значения.Количество() > 0 Тогда //Сообщить(Значения[0].Значение); // Возврат(Значения[0].Значение); // Иначе //Сообщить(0); // Возврат(0); // КонецЕсли; //КонецФункции

 306 0
ДобавленоAkbar163 дня назад
Отредактировано163 дня назад


Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Как получить значение реквизита формы и передать его в запрос 1С

Задача: при открытии элемента справочника нужно получить значение поля Код этого...

Выбрать значение табличной части документа

Нужно выбрать из всех документов “РеализацияТоваровУслуг” документы по параметра...

Передача реквизита формы в запрос

Дамы и Господа помогите ! Опыт небольшой . Совсем запутался . Хочу передать рекв...

Запрос к бухгалтерским итогам по месяцам

Привет Всем Столкнулся с такой задачей, нужно было составить запрос к бухгалтерс...

Достать значение с табличного поля

Доброго дня! Платформа 8.3 Толстый клиент. УТ 10.3 Подскажите в каком направлени...

Новое

Как добавить услугу в 1С Розница 2.2

В магазине одежды, помимо товара, есть услуга по подшивке одежды. Можно ли как т...

настройка печатной формы отчета Расчет по страховым взносам

Добрый день, подскажите пожалуйста , из-за чего на титульном листе отчета не печ...

не могу обновить 1с 8.2

Здравствуйте! подскажите как можно решить проблему с обновлением 1 с 8.2 базовая...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Справочник

Здравствуйте, подскажите пожалуйста, хочу сделать, чтобы при выборе в справочник...