0

Запрос к бухгалтерским итогам по месяцам

#1С 7.7

Привет Всем Столкнулся с такой задачей, нужно было составить запрос к бухгалтерским итогам по Сотрудникам, вот код:

  • Code Налог = глПолучитьНалог(“ПФизЗП”); Таб = СоздатьОбъект(“Таблица”); Таб.ИсходнаяТаблица(“Таблица”); Таб.ВывестиСекцию(“Шапка”); Би = СоздатьОбъект(“БухгалтерскиеИтоги”);

    Би.ИспользоватьСубконто(ВидыСубконто.Сотрудники); Би.ВыполнитьЗапрос(НачДата,КонДата,Налог.Счет,глПолучитьНалог(“ПФизЗП”).Счет,,3,7); Би.ВыбратьСубконто(); Номер = 0; ИтогПлат = 0; ИтогДоход = 0;

    Пока Би.ПолучитьСубконто() = 1 Цикл Фамилия = “”; Имя = “”; Отчество = “”;

    ФИО(Би.Субконто(),Фамилия,Имя,Отчество);
    
    Номер = Номер+1;
    Если Би.ПолучитьКорСчет(,глПолучитьНалог("ПодНал").Счет) = 1 Тогда
        ОбПлат = Би.КорКО();
    Иначе
        ОбПлат = 0;
    КонецЕсли;
    ДобрПлат = Би.КО();
    
    Таб.ВывестиСекцию("Строка");
    
    ИтогПлат = ИтогПлат+Би.КО();
    
    ИтогДоход = ИтогДоход+Доход;
    

    КонецЦикла;

    Таб.ВывестиСекцию(“Подвал”); Таб.ПовторятьПриПечатиСтроки(8,8); Таб.Опции(0,0,0,0); Таб.Показать(“Реестр ИНПС”); КонецПроцедуры

все работает как надо и в таблице в колонке с формулой ДобрПлат выгружаются суммированные итоги по месяцам, возникла необходимость выгружать в соседнюю колонку этиже данные только за один текущий месяц, как это можно реализовать подскажите пожалуйста с Уважением Дамир

 380 0
Добавленоid3337668279 дней назад


Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Запрос по регистрам бухгалтерии

Здравствуйте. Помогите пожалуйста с запросом, мучаюсь уже не первую неделю. Треб...

СКД. Вывод отгрузок по месяцам.

Здравствуйте! Нужна очень нужна помощь. Я делаю отчет на СКД. Мне необходимо вид...

Передача реквизита формы в запрос

Дамы и Господа помогите ! Опыт небольшой . Совсем запутался . Хочу передать рекв...

Помогите пожалуйста составить правильный запрос

в 1с есть таблица: номер цвет 1 красный 2 null 3 null 4 синий 5 null 6 белый 7 n...

помогите пожалуйста реализовать решение

Добрый день! помогите пожалуйста реализовать решение: Редакция 3.0 (3.0.43.252),...

Новое

настройка печатной формы отчета Расчет по страховым взносам

Добрый день, подскажите пожалуйста , из-за чего на титульном листе отчета не печ...

реплики Longines часы, longinesladieswatchesuk.top

[b][url=http://www.longinesladieswatchesuk.top/ru/]часы Longines в великобритани...

не могу обновить 1с 8.2

Здравствуйте! подскажите как можно решить проблему с обновлением 1 с 8.2 базовая...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Справочник

Здравствуйте, подскажите пожалуйста, хочу сделать, чтобы при выборе в справочник...