0

Заполнение табличной части на тонком клиенте

#Таблица значений#Документ

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом всеми документами, у которых такие же дата и контрагент, заполнить табличную часть. Создал событие “Обработка выбора”

&НаКлиенте Процедура ДоставкаСФабрикПоступлелиеТоваровУслугОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка) ТаблицаВыгрузки = ДоставкаСФабрикПоступлелиеТоваровУслугОбработкаВыбораНаСервере(ВыбранноеЗначение); Элементы. Для каждого СтрокаРезультата из ТаблицаВыгрузки цикл СтрокаПТУ = Объект.ДоставкаСФабрик.Добавить(); СтрокаПТУ.ПоступлениеТоваровУслуг = СтрокаРезультата.ПоступлениеТоваровУслуг; СтрокаПТУ.Поставщик = СтрокаРезультата.Поставщик; СтрокаПТУ.Сумма = СтрокаРезультата.Сумма; КонецЦикла; КонецПроцедуры

&НаСервере Функция ДоставкаСФабрикПоступлелиеТоваровУслугОбработкаВыбораНаСервере(ВыбранноеЗначение) Запрос = Новый Запрос; Запрос.Текст = “ВЫБРАТЬ | ПоступлениеТоваровУслуг.Ссылка КАК ПоступлениеТоваровУслуг, | ПоступлениеТоваровУслуг.ЗаказПоставщику.НомерПоДаннымПоставщика КАК НомерЗаказа, | ПоступлениеТоваровУслуг.Партнер КАК Поставщик, | ПоступлениеТоваровУслуг.СуммаДокумента КАК Сумма |ИЗ | Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг |ГДЕ | ПоступлениеТоваровУслуг.Дата = &ВыбраннаяДата | И ПоступлениеТоваровУслуг.Партнер = &Партнер”;

Запрос.УстановитьПараметр("ВыбраннаяДата", ВыбранноеЗначение.Дата);
Запрос.УстановитьПараметр("Партнер", ВыбранноеЗначение.Партнер);

РезультатЗапроса = Запрос.Выполнить();
РезультатТз = РезультатЗапроса.Выгрузить();
Если Не РезультатЗапроса.Пустой() Тогда
Возврат  РезультатТз
КонецЕсли;

КонецФункции

 591 0
ДобавленоАлексейК236 дней назад
Отредактировано236 дней назад


Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Заполнение табличной части документа в 1С на управляемых формах

Всем привет! Помогите, плиз, разобраться. Пишу заполнение табличной части на упр...

Выбрать значение табличной части документа

Нужно выбрать из всех документов “РеализацияТоваровУслуг” документы по параметра...

1С 8.2: Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"

Всем привет. Помогите пожалуйста!!!!!!!!!!!!!!! Выдает ошибку. Была пропущена т...

Групповое заполнение строк табличной части.

обрый день. Уважаемые форумчане помогите с кодом не могу доделать редактирование...

Обработка формы списка регистра сведений и заполнение значений в документ

Здравствуйте! Столкнулась с такой проблемой: имеется документ “Запись на занятия...

Новое

счет-фактура на возврат денег поставщиком

по оплате от поставщика мы приняли к зачету ндс по сч-фактуре. теперь деньги нам...

Расчет районного коэффициента в больничном листе

Добрый день! Очень нужна помощь! При расчете б/л не верно считает положительную ...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Возврат по картам по зарплате, в случае изменения реквизитов банка

По карте была перечислена зарплата, но платеж вернулся (изменились реквизиты бан...

Составление отчета

Здравствуйте!! Нужна помощь !!! что означает Ошибка получения информации набора ...