0

Заполнение табличной части на тонком клиенте

#Таблица значений#Документ

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом всеми документами, у которых такие же дата и контрагент, заполнить табличную часть. Создал событие “Обработка выбора”

&НаКлиенте Процедура ДоставкаСФабрикПоступлелиеТоваровУслугОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка) ТаблицаВыгрузки = ДоставкаСФабрикПоступлелиеТоваровУслугОбработкаВыбораНаСервере(ВыбранноеЗначение); Элементы. Для каждого СтрокаРезультата из ТаблицаВыгрузки цикл СтрокаПТУ = Объект.ДоставкаСФабрик.Добавить(); СтрокаПТУ.ПоступлениеТоваровУслуг = СтрокаРезультата.ПоступлениеТоваровУслуг; СтрокаПТУ.Поставщик = СтрокаРезультата.Поставщик; СтрокаПТУ.Сумма = СтрокаРезультата.Сумма; КонецЦикла; КонецПроцедуры

&НаСервере Функция ДоставкаСФабрикПоступлелиеТоваровУслугОбработкаВыбораНаСервере(ВыбранноеЗначение) Запрос = Новый Запрос; Запрос.Текст = “ВЫБРАТЬ | ПоступлениеТоваровУслуг.Ссылка КАК ПоступлениеТоваровУслуг, | ПоступлениеТоваровУслуг.ЗаказПоставщику.НомерПоДаннымПоставщика КАК НомерЗаказа, | ПоступлениеТоваровУслуг.Партнер КАК Поставщик, | ПоступлениеТоваровУслуг.СуммаДокумента КАК Сумма |ИЗ | Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг |ГДЕ | ПоступлениеТоваровУслуг.Дата = &ВыбраннаяДата | И ПоступлениеТоваровУслуг.Партнер = &Партнер”;

Запрос.УстановитьПараметр("ВыбраннаяДата", ВыбранноеЗначение.Дата);
Запрос.УстановитьПараметр("Партнер", ВыбранноеЗначение.Партнер);

РезультатЗапроса = Запрос.Выполнить();
РезультатТз = РезультатЗапроса.Выгрузить();
Если Не РезультатЗапроса.Пустой() Тогда
Возврат  РезультатТз
КонецЕсли;

КонецФункции

 672 0
ДобавленоАлексейК272 дня назад
Отредактировано272 дня назад


Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Заполнение табличной части документа в 1С на управляемых формах

Всем привет! Помогите, плиз, разобраться. Пишу заполнение табличной части на упр...

Выбрать значение табличной части документа

Нужно выбрать из всех документов “РеализацияТоваровУслуг” документы по параметра...

1С 8.2: Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"

Всем привет. Помогите пожалуйста!!!!!!!!!!!!!!! Выдает ошибку. Была пропущена т...

Групповое заполнение строк табличной части.

обрый день. Уважаемые форумчане помогите с кодом не могу доделать редактирование...

Обработка формы списка регистра сведений и заполнение значений в документ

Здравствуйте! Столкнулась с такой проблемой: имеется документ “Запись на занятия...

Новое

Как добавить услугу в 1С Розница 2.2

В магазине одежды, помимо товара, есть услуга по подшивке одежды. Можно ли как т...

настройка печатной формы отчета Расчет по страховым взносам

Добрый день, подскажите пожалуйста , из-за чего на титульном листе отчета не печ...

реплики Longines часы, longinesladieswatchesuk.top

[b][url=http://www.longinesladieswatchesuk.top/ru/]часы Longines в великобритани...

не могу обновить 1с 8.2

Здравствуйте! подскажите как можно решить проблему с обновлением 1 с 8.2 базовая...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...