0

Заполнение табличной части на тонком клиенте

#Таблица значений#Документ

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом всеми документами, у которых такие же дата и контрагент, заполнить табличную часть. Создал событие “Обработка выбора”

&НаКлиенте Процедура ДоставкаСФабрикПоступлелиеТоваровУслугОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка) ТаблицаВыгрузки = ДоставкаСФабрикПоступлелиеТоваровУслугОбработкаВыбораНаСервере(ВыбранноеЗначение); Элементы. Для каждого СтрокаРезультата из ТаблицаВыгрузки цикл СтрокаПТУ = Объект.ДоставкаСФабрик.Добавить(); СтрокаПТУ.ПоступлениеТоваровУслуг = СтрокаРезультата.ПоступлениеТоваровУслуг; СтрокаПТУ.Поставщик = СтрокаРезультата.Поставщик; СтрокаПТУ.Сумма = СтрокаРезультата.Сумма; КонецЦикла; КонецПроцедуры

&НаСервере Функция ДоставкаСФабрикПоступлелиеТоваровУслугОбработкаВыбораНаСервере(ВыбранноеЗначение) Запрос = Новый Запрос; Запрос.Текст = “ВЫБРАТЬ | ПоступлениеТоваровУслуг.Ссылка КАК ПоступлениеТоваровУслуг, | ПоступлениеТоваровУслуг.ЗаказПоставщику.НомерПоДаннымПоставщика КАК НомерЗаказа, | ПоступлениеТоваровУслуг.Партнер КАК Поставщик, | ПоступлениеТоваровУслуг.СуммаДокумента КАК Сумма |ИЗ | Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг |ГДЕ | ПоступлениеТоваровУслуг.Дата = &ВыбраннаяДата | И ПоступлениеТоваровУслуг.Партнер = &Партнер”;

Запрос.УстановитьПараметр("ВыбраннаяДата", ВыбранноеЗначение.Дата);
Запрос.УстановитьПараметр("Партнер", ВыбранноеЗначение.Партнер);

РезультатЗапроса = Запрос.Выполнить();
РезультатТз = РезультатЗапроса.Выгрузить();
Если Не РезультатЗапроса.Пустой() Тогда
Возврат  РезультатТз
КонецЕсли;

КонецФункции

 514 0
ДобавленоАлексейК206 дней назад
Отредактировано206 дней назад


Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Заполнение табличной части документа в 1С на управляемых формах

Всем привет! Помогите, плиз, разобраться. Пишу заполнение табличной части на упр...

Выбрать значение табличной части документа

Нужно выбрать из всех документов “РеализацияТоваровУслуг” документы по параметра...

1С 8.2: Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"

Всем привет. Помогите пожалуйста!!!!!!!!!!!!!!! Выдает ошибку. Была пропущена т...

Групповое заполнение строк табличной части.

обрый день. Уважаемые форумчане помогите с кодом не могу доделать редактирование...

Обработка формы списка регистра сведений и заполнение значений в документ

Здравствуйте! Столкнулась с такой проблемой: имеется документ “Запись на занятия...

Новое

2 НДФЛ и 6 НДФЛ

Добрый день! Получили процентный займ от учредителя, который не является работни...

Слияние двух баз 1 С8.3

Уважаемые партнеры, коллеги. У меня возникла необходимость в слиянии двух баз, в...

Ищем разработчика 1С на ЗУП 3.0 (Москва)

За подробностями Вы можете писать на почту alina.stogina@hays.ru!...

Перенос БГУ 1.0->БГУ 2.0 Счет 303 учет по ИФО

Всем привет! После переноса данных из 1.0 в 2.0 формирую общие оборотки и вижу, ...

Помогите сделать внешнюю печатную форму ТОРГ-13

Пытаюсь программировать в 1с недавно, опыта нет. По полученным из интернета инс...