3

Заполнение табличной части документа в 1С на управляемых формах

#1С 8.3#1С Управление торговлей 11.1#Управляемые формы

Всем привет! Помогите, плиз, разобраться. Пишу заполнение табличной части на управляемых формах для УТ 11.1 и уперся в то, что не знаю как перенести данные в документ.

 7091 5
ДобавленоДанил831 день назад
Последняя активность300 дней назад


Добавить комментарий

Den написал:831 день назад0

А у твоей обработки заполнения т.ч. есть своя форма?

Ответить

Данил написал:831 день назад0

Да

Ответить

Den написал:831 день назад0

Тогда для кнопки, по которой ты хочешь заполнять таб. часть создаешь команду, для команды процедуру на клиенте, и там пишешь такой код:

    Элемент = ЭтаФорма.ОбъектыНазначения;
    КлючПоиска = Новый Структура("Ключ", Элемент);
    Окна = ПолучитьОкна();
    Для каждого Окно из Окна Цикл
        Если НЕ Окно.Основное
            И Найти(Окно.Заголовок, Элемент) Тогда
            ТекФорма = Окно.ПолучитьСодержимое();     
            ОбъектФормы = Неопределено;

            Попытка
                ОбъектФормы = ТекФорма.Объект;

                Если ОбъектФормы <> Неопределено 
                    И ОбъектФормы.Ссылка = Элемент Тогда

         //Вот тут заполняешь ОбъектФормы нужными данными

                    ТекФорма.Записать();
                    ТекФорма.Прочитать();
                КонецЕсли;
            Исключение
                Сообщить(ОписаниеОшибки());
            КонецПопытки;
            ЭтаФорма.Закрыть();
        КонецЕсли;
    КонецЦикла;

Мудреный алгоритм, но без него в управляемых формах твоя заполнялка не заработает.

Ответить

Данил написал:831 день назад0

О, круто! Спасибо, все получилось!

Ответить

Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Печать табличной части документа 1С

Помогите решить проблему. Через контекстное меню табличной части документа польз...

Выбрать значение табличной части документа

Нужно выбрать из всех документов “РеализацияТоваровУслуг” документы по параметра...

Групповое заполнение строк табличной части.

обрый день. Уважаемые форумчане помогите с кодом не могу доделать редактирование...

Обработка формы списка регистра сведений и заполнение значений в документ

Здравствуйте! Столкнулась с такой проблемой: имеется документ “Запись на занятия...

Заполнение табличной части на тонком клиенте

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом ...

Новое

Prada Сумки 1786 Абрикос [2614] [Prada Totes-648] - $366.00 : Spyder куртки , pradamen.top

PradaPrada сумкиPrada сумки[b][url=http://www.pradamen.top/ru/]Prada[/url][/b] [...

Серия Hublot Big Bang

Hublot женские часы Hublot часы продажа [b][url=http://www.hublotmenswatches.top...

Spyder лыжные очки

Spyder свитер куртка Spyder куртка для женщин [b][url=http://www.spydersale.top/...

Pandora Happy Holidays

пандораПандора прелестиПандора браслет [b][url=http://www.pandoraclips.top/ru/]п...

Nike Air Max 2014 Древесный уголь Серый Зеленый - $121.00 : Найк магазины выходные, nikerunning.top

Выход Найк Air Max 1 Найк [b][url=http://www.nikerunning.top/ru/]макс воздуха 90...