3

Заполнение табличной части документа в 1С на управляемых формах

#1С 8.3#1С Управление торговлей 11.1#Управляемые формы

Всем привет! Помогите, плиз, разобраться. Пишу заполнение табличной части на управляемых формах для УТ 11.1 и уперся в то, что не знаю как перенести данные в документ.

 7530 5
ДобавленоДанил876 дней назад
Последняя активность346 дней назад


Добавить комментарий

Den написал:876 дней назад0

А у твоей обработки заполнения т.ч. есть своя форма?

Ответить

Данил написал:876 дней назад0

Да

Ответить

Den написал:876 дней назад0

Тогда для кнопки, по которой ты хочешь заполнять таб. часть создаешь команду, для команды процедуру на клиенте, и там пишешь такой код:

    Элемент = ЭтаФорма.ОбъектыНазначения;
    КлючПоиска = Новый Структура("Ключ", Элемент);
    Окна = ПолучитьОкна();
    Для каждого Окно из Окна Цикл
        Если НЕ Окно.Основное
            И Найти(Окно.Заголовок, Элемент) Тогда
            ТекФорма = Окно.ПолучитьСодержимое();     
            ОбъектФормы = Неопределено;

            Попытка
                ОбъектФормы = ТекФорма.Объект;

                Если ОбъектФормы <> Неопределено 
                    И ОбъектФормы.Ссылка = Элемент Тогда

         //Вот тут заполняешь ОбъектФормы нужными данными

                    ТекФорма.Записать();
                    ТекФорма.Прочитать();
                КонецЕсли;
            Исключение
                Сообщить(ОписаниеОшибки());
            КонецПопытки;
            ЭтаФорма.Закрыть();
        КонецЕсли;
    КонецЦикла;

Мудреный алгоритм, но без него в управляемых формах твоя заполнялка не заработает.

Ответить

Данил написал:876 дней назад0

О, круто! Спасибо, все получилось!

Ответить

Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Печать табличной части документа 1С

Помогите решить проблему. Через контекстное меню табличной части документа польз...

Выбрать значение табличной части документа

Нужно выбрать из всех документов “РеализацияТоваровУслуг” документы по параметра...

Групповое заполнение строк табличной части.

обрый день. Уважаемые форумчане помогите с кодом не могу доделать редактирование...

Обработка формы списка регистра сведений и заполнение значений в документ

Здравствуйте! Столкнулась с такой проблемой: имеется документ “Запись на занятия...

Заполнение табличной части на тонком клиенте

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом ...

Новое

Внешний отчет

здравствуйте, подскажите, как создать внешний отчет, для того чтобы вывести инфо...

ручные проводки в НУ

Добрый день, Организация на ОСНО с 2016 года в январе 2016 года поступили на р/с...

Главное меню

Подскажите пожалуйста, у меня в главном меню куда исчезло меню Отчеты ( не значк...

Ищем программиста 1С в штат г.Москва

Доработка конфигурации 1С 8 Континент страхование на базе Бухгалтерии КОРП Созда...

Остатки товаров: настройка отчета

Добрый день! Подскажите пожалуйста по настройкам отчета: когда-то давно работала...