3

Заполнение табличной части документа в 1С на управляемых формах

#1С 8.3#1С Управление торговлей 11.1#Управляемые формы

Всем привет! Помогите, плиз, разобраться. Пишу заполнение табличной части на управляемых формах для УТ 11.1 и уперся в то, что не знаю как перенести данные в документ.

 8479 5
ДобавленоДанил967 дней назад
Последняя активность437 дней назад


Добавить комментарий

Den написал:967 дней назад0

А у твоей обработки заполнения т.ч. есть своя форма?

Ответить

Данил написал:967 дней назад0

Да

Ответить

Den написал:967 дней назад0

Тогда для кнопки, по которой ты хочешь заполнять таб. часть создаешь команду, для команды процедуру на клиенте, и там пишешь такой код:

    Элемент = ЭтаФорма.ОбъектыНазначения;
    КлючПоиска = Новый Структура("Ключ", Элемент);
    Окна = ПолучитьОкна();
    Для каждого Окно из Окна Цикл
        Если НЕ Окно.Основное
            И Найти(Окно.Заголовок, Элемент) Тогда
            ТекФорма = Окно.ПолучитьСодержимое();     
            ОбъектФормы = Неопределено;

            Попытка
                ОбъектФормы = ТекФорма.Объект;

                Если ОбъектФормы <> Неопределено 
                    И ОбъектФормы.Ссылка = Элемент Тогда

         //Вот тут заполняешь ОбъектФормы нужными данными

                    ТекФорма.Записать();
                    ТекФорма.Прочитать();
                КонецЕсли;
            Исключение
                Сообщить(ОписаниеОшибки());
            КонецПопытки;
            ЭтаФорма.Закрыть();
        КонецЕсли;
    КонецЦикла;

Мудреный алгоритм, но без него в управляемых формах твоя заполнялка не заработает.

Ответить

Данил написал:967 дней назад0

О, круто! Спасибо, все получилось!

Ответить

Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Печать табличной части документа 1С

Помогите решить проблему. Через контекстное меню табличной части документа польз...

Выбрать значение табличной части документа

Нужно выбрать из всех документов “РеализацияТоваровУслуг” документы по параметра...

Групповое заполнение строк табличной части.

обрый день. Уважаемые форумчане помогите с кодом не могу доделать редактирование...

Обработка формы списка регистра сведений и заполнение значений в документ

Здравствуйте! Столкнулась с такой проблемой: имеется документ “Запись на занятия...

Заполнение табличной части на тонком клиенте

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом ...

Новое

реплики Longines часы, longinesladieswatchesuk.top

[b][url=http://www.longinesladieswatchesuk.top/ru/]часы Longines в великобритани...

не могу обновить 1с 8.2

Здравствуйте! подскажите как можно решить проблему с обновлением 1 с 8.2 базовая...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Справочник

Здравствуйте, подскажите пожалуйста, хочу сделать, чтобы при выборе в справочник...

Большой видеоархив по платформам 1С 8.2 и 8.3. Пользователям и разработчикам

Всем привет! Добротный канал для обучения с регулярным добавлением видеокурсов: ...