на компьютере все сохраняет и нормально фотки отправляет на мобильное устройство, а на мобильной платформе открывает файловый менеджер но не сохраняет файлы и он не отоброжаеться в окошке фото

вот код помогите исправить ошибку пожалуйста

код

&НаКлиенте + Code Процедура ДобавитьКартинку(Команда) ИмяФайла = “”; ПутьФайла = “”; //Вызываем Диалоговое окно и помещаем файл Картинки из локальной файловой системы во временное хранилище

Если ПоместитьФайл(ПутьФайла, , ИмяФайла, Истина) = Истина Тогда //в строковый реквизит ФОТО нашей формы сохраняем ссылку на Картинку во временном хранилище

Фото = ПутьФайла; //для создания нового элемента в Справочнике Файлы и записи Картинки в его реквизит Файл

//переходим на сервер с помощью вызова серверной процедуры УстановитьКартинку(); КонецЕсли; //условие ЕСЛИ нужно для того, чтобы если пользователь отказался от выбора файла

//мы не вызывали серверную процедуру УстановитьКартинку()

#Если МобильноеПриложениеКлиент Тогда

НовВз = Новый ЗапускПриложенияМобильногоУстройства();
НовВз.Действие = "android.intent.action.GET_CONTENT";

//Указываем тип искомых файлов, нас интересует только фото

НовВз.Тип = "image/*";//"file/*"; //"*/*"

//Говорим что интересуют только локальные данные, а не облачные НовВз.ДополнительныеДанные.Добавить(“android.intent.extra.LOCAL_ONLY”,Истина); РезультатРаботы = НовВз.Запустить(Истина); Если НЕ РезультатРаботы Тогда Сообщить(“Файл не выбран!”); Возврат КонецЕсли; ПутьКФайлу = НовВз.Данные; Если ПоместитьФайл(“что вписать сюда?”, , Истина) = Истина Тогда Фото = “что вписать сюда?”; УстановитьКартинку(); КонецЕсли; #КонецЕсли

КонецПроцедуры

&НаСервере Процедура УстановитьКартинку() //создаем новый элемент в Справочнике Файлы

НовыйФайлКартинки = Справочники.Файлы.СоздатьЭлемент(); //в реквизит СправочникаФайлы Файл помещаем выбранную ранее Картинку

НовыйФайлКартинки.Файл = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(Фото)); Фото = ПоместитьВоВременноеХранилище(НовыйФайлКартинки.Файл.Получить()); //записываем новый элемент справочника Файлы

НовыйФайлКартинки.Записать();

//устанавливаем значение реквизита Картинка Справочника Сотрудники

Объект.Картинка = НовыйФайлКартинки.Ссылка; КонецПроцедуры

&НаСервере Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) //отображение картинки при открытии формы справочника

Фото = ПолучитьНавигационнуюСсылку(Объект.Картинка, “Файл”);

//устанавливаем автомасштаб для картинки

Элементы.Фото.РазмерКартинки = РазмерКартинки.АвтоРазмер; КонецПроцедуры

 1021 0
Добавленоenot_tut493 дня назад
Отредактировано493 дня назад


Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Что будет если прервать выгрузку базы в dt файл

Файловая база, занимает 800 Мб на жестком диске, а размер выгружаемого dt файла ...

Почтовый менеджер, заполнение текста письма по шаблону

Используем 1С CRM 2.0. В почтовом менеджере при создании (ответе и пересылке) пи...

Не могу программно сформировать типовой отчет

Пытаюсь из внешней обработки программно сформировать типовой отчет и вывести рез...

ФОТО к характеристикам (к каждой отдельно)

Здравствуйте!!! Подскажите пожалуйста! Есть один товар, но разных цветов и разм...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

1С: Бухгалтерию 8.2 дёшево

Программа 1С: Бухгалетрия 8.2 По поводу приобретения программы обращайтесь на по...

Курсы

Добрый день! Осталось 2 ключа для активации курса “Профессиональный учёт в 1С:З...

"Наряд на хозтранспорт и спецтехнику" Путевые листы

Здравствуйте, Форумчане, прошу вашего совета. В организации такая ситуация: ест...

Создание обработки

Помогите с задачей. Суть такова - нужно создать внешнею обработку которая будет ...

Заполнение раздела 3 Расчет налоговой базы Книги доходов и расходов

Добрый день! Меня зовут Наталья. Про заполнение Кудир в КА очень все хорошо пишу...