1

Вывод сообщения на сервере в 1С 8.3

#1С 8.3

Доброго времени суток.Имеется справочник, где хранятся инструкции. И регистр сведений, в котором хранится информация о просмотренных пользователем инструкциях.Нужно обработка, которая при входе пользователя в систему определяла есть ли у него не просмотренные инструкции и если есть, сообщала ему об этом. я составил запрос, исключающий инструкции, которых нет в регистре.

Запрос = Новый Запрос;

Запрос.Текст =

“ВЫБРАТЬ

| Инструкции.Ссылка

|ИЗ

| Справочник.Инструкции КАК Инструкции

|ГДЕ

| НЕ Инструкции.Ссылка В

| (ВЫБРАТЬ

| ИнструкцииСрезПоследних.Инструкция

| ИЗ

| РегистрСведений.Инструкции.СрезПоследних КАК ИнструкцииСрезПоследних

| ГДЕ

| ИнструкцииСрезПоследних.ИмяПользователя = &ИмяПользователя)”;

Запрос.УстановитьПараметр(“ИмяПользователя”, ПараметрыСеанса.ТекущийПользователь );

Как мне дальше сделать, что б выводилось сообщение пользователю о том, что у него есть не просмотренные инструкции?

 3220 4
ДобавленоАлексейБел520 дней назад
Отредактировано519 дней назад


Добавить комментарий

Кирилл написал:520 дней назад0

Доброго !

Всё достаточно просто. Примерно так:

Если НЕ Запрос.Выполнить().Пустой() Тогда
Сообщить("У вас есть не просмотренные инструкции!");
КонецЕсли;

Ответить

АлексейБел написал:519 дней назад0

Спасибо. Код запроса исполняется на сервере. А сообщение нужно вывести на клиенте. Как мне это реализовать?

Ответить

Кирилл написал:519 дней назад0

Вы вызываете эту функцию с клиента? Просто передавайте обратно на клиент “истина” или “ложь” и выводите сообщение.

Мини пример:

&НаКлиенте
Процедура ПроверитьИнструкции() 

Если ЕстьНовыеИнструкции() Тогда
Сообщить("Есть новые инструкции!");
КонецЕсли;

КонецПроцедуры;

&НаСервере
Функция ЕстьНовыеИнструкции() 

Запрос = Новый Запрос;
//.....
Возрат НЕ Запрос.Выполнить().Пустой();

КонецФункции;

Ответить

АлексейБел написал:519 дней назад0

Спасибо. Буду пробовать.

Ответить

Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Вывод сообщения пользователю с возможностью расшифровки (аналог "подробнее")

1С 8.3 Тонкий клиент. Есть ли стандартная возможность в окно сообщений вывести к...

Обработка, запрос

Здравствуйте. Подскажите как реализовать: Нужно создать обработку на ней два пол...

Новый регистр сведений 1С 8.2 или добавить в существующий

Всем добрый день! Нужна помощь, совет, в общем все! Появилась необходимость со...

Простой запрос к справочнику 1С 8.2

Привет Всем Начал изучать построение запросов в восьмерке, решил создать простой...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

ручные проводки в НУ

Добрый день, Организация на ОСНО с 2016 года в январе 2016 года поступили на р/с...

Главное меню

Подскажите пожалуйста, у меня в главном меню куда исчезло меню Отчеты ( не значк...

Ищем программиста 1С в штат г.Москва

Доработка конфигурации 1С 8 Континент страхование на базе Бухгалтерии КОРП Созда...

Остатки товаров: настройка отчета

Добрый день! Подскажите пожалуйста по настройкам отчета: когда-то давно работала...

Ищем программиста 1С 8.2 в штат ( г. Киев)

Доброе утро, форумчане! Очень нужен грамотный программист 1С в штат, будем серье...