1

Вывод сообщения на сервере в 1С 8.3

#1С 8.3

Доброго времени суток.Имеется справочник, где хранятся инструкции. И регистр сведений, в котором хранится информация о просмотренных пользователем инструкциях.Нужно обработка, которая при входе пользователя в систему определяла есть ли у него не просмотренные инструкции и если есть, сообщала ему об этом. я составил запрос, исключающий инструкции, которых нет в регистре.

Запрос = Новый Запрос;

Запрос.Текст =

“ВЫБРАТЬ

| Инструкции.Ссылка

|ИЗ

| Справочник.Инструкции КАК Инструкции

|ГДЕ

| НЕ Инструкции.Ссылка В

| (ВЫБРАТЬ

| ИнструкцииСрезПоследних.Инструкция

| ИЗ

| РегистрСведений.Инструкции.СрезПоследних КАК ИнструкцииСрезПоследних

| ГДЕ

| ИнструкцииСрезПоследних.ИмяПользователя = &ИмяПользователя)”;

Запрос.УстановитьПараметр(“ИмяПользователя”, ПараметрыСеанса.ТекущийПользователь );

Как мне дальше сделать, что б выводилось сообщение пользователю о том, что у него есть не просмотренные инструкции?

 3934 4
ДобавленоАлексейБел611 дней назад
Отредактировано610 дней назад


Добавить комментарий

Кирилл написал:611 дней назад0

Доброго !

Всё достаточно просто. Примерно так:

Если НЕ Запрос.Выполнить().Пустой() Тогда
Сообщить("У вас есть не просмотренные инструкции!");
КонецЕсли;

Ответить

АлексейБел написал:611 дней назад0

Спасибо. Код запроса исполняется на сервере. А сообщение нужно вывести на клиенте. Как мне это реализовать?

Ответить

Кирилл написал:611 дней назад0

Вы вызываете эту функцию с клиента? Просто передавайте обратно на клиент “истина” или “ложь” и выводите сообщение.

Мини пример:

&НаКлиенте
Процедура ПроверитьИнструкции() 

Если ЕстьНовыеИнструкции() Тогда
Сообщить("Есть новые инструкции!");
КонецЕсли;

КонецПроцедуры;

&НаСервере
Функция ЕстьНовыеИнструкции() 

Запрос = Новый Запрос;
//.....
Возрат НЕ Запрос.Выполнить().Пустой();

КонецФункции;

Ответить

АлексейБел написал:611 дней назад0

Спасибо. Буду пробовать.

Ответить

Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Вывод сообщения пользователю с возможностью расшифровки (аналог "подробнее")

1С 8.3 Тонкий клиент. Есть ли стандартная возможность в окно сообщений вывести к...

Обработка, запрос

Здравствуйте. Подскажите как реализовать: Нужно создать обработку на ней два пол...

Новый регистр сведений 1С 8.2 или добавить в существующий

Всем добрый день! Нужна помощь, совет, в общем все! Появилась необходимость со...

Простой запрос к справочнику 1С 8.2

Привет Всем Начал изучать построение запросов в восьмерке, решил создать простой...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

не могу обновить 1с 8.2

Здравствуйте! подскажите как можно решить проблему с обновлением 1 с 8.2 базовая...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Справочник

Здравствуйте, подскажите пожалуйста, хочу сделать, чтобы при выборе в справочник...

Большой видеоархив по платформам 1С 8.2 и 8.3. Пользователям и разработчикам

Всем привет! Добротный канал для обучения с регулярным добавлением видеокурсов: ...

Перенос остатков по складам из БП 3.0 в УТ 11.3

Добрый день. Есть заявка о том, что нужно один раз перенести из БП в пустую УТ д...