1

Вывод сообщения на сервере в 1С 8.3

#1С 8.3

Доброго времени суток.Имеется справочник, где хранятся инструкции. И регистр сведений, в котором хранится информация о просмотренных пользователем инструкциях.Нужно обработка, которая при входе пользователя в систему определяла есть ли у него не просмотренные инструкции и если есть, сообщала ему об этом. я составил запрос, исключающий инструкции, которых нет в регистре.

Запрос = Новый Запрос;

Запрос.Текст =

“ВЫБРАТЬ

| Инструкции.Ссылка

|ИЗ

| Справочник.Инструкции КАК Инструкции

|ГДЕ

| НЕ Инструкции.Ссылка В

| (ВЫБРАТЬ

| ИнструкцииСрезПоследних.Инструкция

| ИЗ

| РегистрСведений.Инструкции.СрезПоследних КАК ИнструкцииСрезПоследних

| ГДЕ

| ИнструкцииСрезПоследних.ИмяПользователя = &ИмяПользователя)”;

Запрос.УстановитьПараметр(“ИмяПользователя”, ПараметрыСеанса.ТекущийПользователь );

Как мне дальше сделать, что б выводилось сообщение пользователю о том, что у него есть не просмотренные инструкции?

 3529 4
ДобавленоАлексейБел553 дня назад
Отредактировано552 дня назад


Добавить комментарий

Кирилл написал:553 дня назад0

Доброго !

Всё достаточно просто. Примерно так:

Если НЕ Запрос.Выполнить().Пустой() Тогда
Сообщить("У вас есть не просмотренные инструкции!");
КонецЕсли;

Ответить

АлексейБел написал:553 дня назад0

Спасибо. Код запроса исполняется на сервере. А сообщение нужно вывести на клиенте. Как мне это реализовать?

Ответить

Кирилл написал:553 дня назад0

Вы вызываете эту функцию с клиента? Просто передавайте обратно на клиент “истина” или “ложь” и выводите сообщение.

Мини пример:

&НаКлиенте
Процедура ПроверитьИнструкции() 

Если ЕстьНовыеИнструкции() Тогда
Сообщить("Есть новые инструкции!");
КонецЕсли;

КонецПроцедуры;

&НаСервере
Функция ЕстьНовыеИнструкции() 

Запрос = Новый Запрос;
//.....
Возрат НЕ Запрос.Выполнить().Пустой();

КонецФункции;

Ответить

АлексейБел написал:553 дня назад0

Спасибо. Буду пробовать.

Ответить

Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Вывод сообщения пользователю с возможностью расшифровки (аналог "подробнее")

1С 8.3 Тонкий клиент. Есть ли стандартная возможность в окно сообщений вывести к...

Обработка, запрос

Здравствуйте. Подскажите как реализовать: Нужно создать обработку на ней два пол...

Новый регистр сведений 1С 8.2 или добавить в существующий

Всем добрый день! Нужна помощь, совет, в общем все! Появилась необходимость со...

Простой запрос к справочнику 1С 8.2

Привет Всем Начал изучать построение запросов в восьмерке, решил создать простой...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

2 НДФЛ и 6 НДФЛ

Добрый день! Получили процентный займ от учредителя, который не является работни...

Слияние двух баз 1 С8.3

Уважаемые партнеры, коллеги. У меня возникла необходимость в слиянии двух баз, в...

Ищем разработчика 1С на ЗУП 3.0 (Москва)

За подробностями Вы можете писать на почту alina.stogina@hays.ru!...

Перенос БГУ 1.0->БГУ 2.0 Счет 303 учет по ИФО

Всем привет! После переноса данных из 1.0 в 2.0 формирую общие оборотки и вижу, ...

Помогите сделать внешнюю печатную форму ТОРГ-13

Пытаюсь программировать в 1с недавно, опыта нет. По полученным из интернета инс...