0

Вывод печатной формы в 1С 8.3

#1С 8.3#1С Бухгалтерия#1С Бухгалтерия 2.0

Добрый день сделал ВПФ для ПКО в БГУ2.0 но есть одна проблема ни пойму как сделать так что бы полные счета выводились по каждой строчке из табличной части документа(т.е на каждую строчку из расшифровки платежа в ПФ должна вывестись своя) примеры как у меня и как должно быть прикрепил , я так понимаю нужен цикл для каждой строчки из табличной части документа, просто данные берутся из запроса вот и не могу понять, вод код

Запрос.УстановитьПараметр(“МассивОбъектов”,СсылкаНаОбъект); Шапка = Запрос.Выполнить().Выбрать(); ВалютаРегламентированногоУчета = Константы.ВалютаРегламентированногоУчета.Получить();

ПервыйДокумент = Истина;

Пока Шапка.Следующий() Цикл

    Если Не ПервыйДокумент Тогда
        ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЕсли;

    ПервыйДокумент = Ложь;

    НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;

    ОбластьШапка = Макет.ПолучитьОбласть("Шапка");

    ЗаполнитьЗначенияСвойств(ОбластьШапка.Параметры, Шапка);
    СтруктураОбластьШапка = Новый Структура("Сумма,СуммаРубКоп,СуммаПрописью,ВТомЧисле,КодДебета,СубСчет,ФИОГлавногоБухгалтера,ФИОКассира,НомерДокумента,ДатаДокументаКв");
    СтруктураОбластьШапка.Сумма = Формат(Шапка.Сумма, "ЧЦ=15; ЧДЦ=2; ЧРД=-; ЧГ=0");
    СтруктураОбластьШапка.Вставить("СуммаСНазваниемВалюты", Формат(Шапка.Сумма, "ЧЦ=15; ЧДЦ=2; ЧРД=-; ЧГ=0") + ?(Шапка.ВалютаДокумента = ВалютаРегламентированногоУчета, "", " " + Шапка.ВалютаДокумента));
    СтруктураОбластьШапка.СуммаРубКоп = РубКоп(Шапка.Сумма, Шапка.ВалютаДокумента);
    СтруктураОбластьШапка.СуммаПрописью=ОбщегоНазначенияБГУ.СформироватьСуммуПрописью(Шапка.Сумма, Шапка.ВалютаДокумента);
    Если НЕ Шапка.Фондовый Тогда
        СтруктураОбластьШапка.ВТомЧисле = ?(Шапка.СуммаНДС > 0, " НДС(" + Шапка.СтавкаНДС + ")" + РубКоп(Шапка.СуммаНДС, Шапка.ВалютаДокумента), "без налога (НДС)");
    КонецЕсли;
    стр=Шапка.Ссылка1;

    СтруктураОбластьШапка.КодДебета = БухгалтерскийУчетПовтИсп.ПолучитьПредставлениеПолногоСчета(Шапка.Счет, Шапка.КФО ,шапка.КПСДт, Шапка.СчетКОСГУДт);
    СтруктураОбластьШапка.СубСчет = БухгалтерскийУчетПовтИсп.ПолучитьПредставлениеПолногоСчета(Шапка.КорСчет,Шапка.КФО,шапка.КПСКт, Шапка.корСчетКОСГУКт);
    СтруктураОбластьШапка.Вставить("КодЦелевогоНазначения",Шапка.КЭК);
    СтруктураОбластьШапка.ФИОГлавногоБухгалтера=Справочники.Контрагенты.ФамилияИО(Шапка.ГлБухгалтер, Истина, Шапка.ДатаДокумента);
    СтруктураОбластьШапка.ФИОКассира=Справочники.Контрагенты.ФамилияИО(Шапка.Кассир, Истина, Шапка.ДатаДокумента);
    СтруктураОбластьШапка.НомерДокумента = ОбщегоНазначенияБГУ.ПолучитьНомерДляПечатиПоНастройке(Шапка.Ссылка,Шапка.Номер);
    СтруктураОбластьШапка.ДатаДокументаКв = Формат(Шапка.ДатаДокумента,"ДЛФ=DD");
    ОбластьШапка.Параметры.Заполнить(СтруктураОбластьШапка);
    ТабличныйДокумент.Вывести(ОбластьШапка);
    Если Шапка.Фондовый Тогда
        ТабличныйДокумент.Область(2+НомерСтрокиНачало-1, 2, 2+НомерСтрокиНачало-1, 4).Объединить();
        Линия = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.Сплошная, 2);
        ТабличныйДокумент.Область(2+НомерСтрокиНачало-1, 2, 2+НомерСтрокиНачало-1, 4).Обвести(Линия, Линия, Линия, Линия);
        ТабличныйДокумент.Область(2+НомерСтрокиНачало-1, 2, 2+НомерСтрокиНачало-1, 4).Текст                   = "Ф О Н Д О В Ы Й";
        ЦветПечати                                              = Новый Цвет(83,114,187);
        ТабличныйДокумент.Область(2+НомерСтрокиНачало-1, 2, 2+НомерСтрокиНачало-1, 4).ЦветТекста              = ЦветПечати;
        ТабличныйДокумент.Область(2+НомерСтрокиНачало-1, 2, 2+НомерСтрокиНачало-1, 4).ЦветРамки               = ЦветПечати;
        ТабличныйДокумент.Область(2+НомерСтрокиНачало-1, 2, 2+НомерСтрокиНачало-1, 4).ГоризонтальноеПоложение = ГоризонтальноеПоложение.Центр;
        ТабличныйДокумент.Область(2+НомерСтрокиНачало-1, 2, 2+НомерСтрокиНачало-1, 4).ВертикальноеПоложение   = ВертикальноеПоложение.Центр;
        ЖирныйШрифт                                             = Новый Шрифт(ТабличныйДокумент.Область(2+НомерСтрокиНачало-1, 2, 2+НомерСтрокиНачало-1, 4).Шрифт,, 11, Истина);
        ТабличныйДокумент.Область(2+НомерСтрокиНачало-1, 2, 2+НомерСтрокиНачало-1, 4).Шрифт                   = ЖирныйШрифт;
    КонецЕсли;

    УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент,
                                                   НомерСтрокиНачало, ОбъектыПечати, Шапка.Ссылка);
КонецЦикла;

Возврат ТабличныйДокумент;

КонецФункции без запроса

 929 0
ДобавленоАлександр1906420 дней назад
Отредактировано375 дней назад


Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Проблема с выводом отчёта в 2 колонки

Добрый день! Необходимо выводить номенклатуру в отчёте в две колонки, столкнулас...

Групповое заполнение строк табличной части.

обрый день. Уважаемые форумчане помогите с кодом не могу доделать редактирование...

Заполнение табличной части на тонком клиенте

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом ...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

1С: Бухгалтерию 8.2 дёшево

Программа 1С: Бухгалетрия 8.2 По поводу приобретения программы обращайтесь на по...

Курсы

Добрый день! Осталось 2 ключа для активации курса “Профессиональный учёт в 1С:З...

"Наряд на хозтранспорт и спецтехнику" Путевые листы

Здравствуйте, Форумчане, прошу вашего совета. В организации такая ситуация: ест...

Создание обработки

Помогите с задачей. Суть такова - нужно создать внешнею обработку которая будет ...

Заполнение раздела 3 Расчет налоговой базы Книги доходов и расходов

Добрый день! Меня зовут Наталья. Про заполнение Кудир в КА очень все хорошо пишу...