0

Выбор сортировки при печати

#1С 8.3#1С: ЗУП 3.0

При печати приказа списком должна быть возможность выбора сортировки строк по подразделению или ФИО. Помогите пожалуйста, как реализовать данный механизм?

 651 5
ДобавленоНаташа288 дней назад
Последняя активность282 дня назад


Добавить комментарий

Кирилл написал:288 дней назад0

Сейчас точно не помню, но в ЗУП помоему можно отсортировать сроки в таблице документа.

И если разработчики 1С ЗУП ничего там не придумали в коде, то сортировка будет соответствовать документу.

Если такой вариант не устроит - написать свою внешнюю печатную форму с любыми настройками, подробно тут - http://programmist1s.ru/vneshnie-pechatnyie-formyi-v-1s/

Ответить

Наташа написал:286 дней назад0

Спасибо. Можно но только по ФИО. Разрешено изменять конфигурацию, поэтому дописала код без использования модальности, поэтому “заморочено” получилось. Свое решение выложила в комментарий.

Ответить

Наташа написал:286 дней назад0

Может кому-то пригодится, сделала так: 1)В документ добавила реквизит Сортировка 2) В процедуре печати 3) В модуле формы документа

// СтандартныеПодсистемы.Печать &НаКлиенте Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)

//УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект); //перенесла выполнение в Процедуру ПослеЗакрытияВопросаПроСортировку
ВыбратьЗначениеДляСортировки();

КонецПроцедуры // Конец СтандартныеПодсистемы.Печать

&НаКлиенте Процедура ВыбратьЗначениеДляСортировки() Экспорт

Кнопки = Новый СписокЗначений;
Кнопки.Добавить("Подразделение");
Кнопки.Добавить("ФИО");
Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияВопросаПроСортировку", ЭтотОбъект);
ПоказатьВопрос(Оповещение, "По какому полю выполнить сортировку?",Кнопки,100,,,);

КонецПроцедуры

&НаКлиенте Процедура ПослеЗакрытияВопросаПроСортировку(Результат, Параметры) Экспорт

    Объект.Сортировка = Результат; 
    ЭтотОбъект.Записать(); //обязательно записываем, иначе не запоминает значение для  реквизита
    Команда = ЭтаФорма.Команды.Найти("ФормаКоманднаяПанельКомандаПечати0");
    УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект);

КонецПроцедуры

4) В функцию где формируется запрос для печати, прописала перед запросом

ВыбранноеЗначение = (здесь “путь” к реквизиту “Сортировка”)

и в конец запроса:

|“ + ?(ВыбранноеЗначение = "ФИО”,“ УПОРЯДОЧИТЬ ПО Сотрудник”,“ УПОРЯДОЧИТЬ ПО Подразделение”);

Ответить

Кирилл написал:284 дня назад1

Вполне красиво получилось :)

Спасибо за то, что рассказали)

Ответить

Наташа написал:282 дня назад0

Спасибо, что оценили:)

Ответить

Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Сохранение настроек печати 1С

Всем привет! У меня такая проблема, написал печатную форму, у пользователя настр...

Ошибка сортировки данных отличается от системного

Вчера установила Windovs 10 Сегодня включаю свою бухгалтерию 1 С 7.7 пишет ошибк...

Помогите реализовать журнал посещений

Здравствуйте!!! мне необходимо реализовать табель посещаемости. Клиентов брал из...

помогите пожалуйста реализовать решение

Добрый день! помогите пожалуйста реализовать решение: Редакция 3.0 (3.0.43.252),...

Помогите пожалуйста с начислением ЗП

Начисляю зп за апрель, идентична марту. Делаю ведомость на выплату зп через касс...

Новое

1С: Бухгалтерию 8.2 дёшево

Программа 1С: Бухгалетрия 8.2 По поводу приобретения программы обращайтесь на по...

Курсы

Добрый день! Осталось 2 ключа для активации курса “Профессиональный учёт в 1С:З...

"Наряд на хозтранспорт и спецтехнику" Путевые листы

Здравствуйте, Форумчане, прошу вашего совета. В организации такая ситуация: ест...

Создание обработки

Помогите с задачей. Суть такова - нужно создать внешнею обработку которая будет ...

Заполнение раздела 3 Расчет налоговой базы Книги доходов и расходов

Добрый день! Меня зовут Наталья. Про заполнение Кудир в КА очень все хорошо пишу...