Здравствуйте! Подскажите, пожалуйста. В новом документе я делаю движение по регистру накопления, через конструктор, чтобы, когда я буду делать Документ “Перемещение”, я могла заполнить по остаткам или подбором выбрать необходимый товар. Проблема в том, что сейчас, когда я делаю перемещение, и когда я нажимаю на “Заполнить” или когда нажимаю “Подбор” я вижу, что у меня есть как бы остаток. и таблица заполняется, но когда я нажимаю провести, он пишет, что товара нет в остатках и соответственно документ не проводиться. В чем проблема и как её устранить? Помогите пожалуйста.

Процедура ДвижениеПоРегиструТМЦНаСкладахРозницаОбщепит(Отказ)

Движения.ТМЦНаСкладахРозницаОбщепит.Записывать = Истина; Для Каждого ТекСтрока Из Разделка Цикл Движение = Движения.ТМЦНаСкладахРозницаОбщепит.Добавить(); Движение.Период = Дата; Движение.Организация = Организация; Движение.Склад= Склад; Движение.Контрагент = СкладПолучатель; Движение.ВидТМЦ = ТекСтрока.ВидТМЦ; Движение.Количество = ТекСтрока.КоличествоПоНорме; Движение.ОтпускнаяЦена = ТекСтрока.ПерваяЦена; Движение.Партия = ТекСтрока.Партия; Движение.Сумма = ТекСтрока.ЦенаПФ; Движение.СчетУчетаТМЦ = ТекСтрока.СчетУчетаТМЦ; Движение.ТМЦ = ТекСтрока.ТМЦ; Движение.ХарактеристикаТМЦ = ТекСтрока.ХарактеристикаТМЦ; КонецЦикла;

КонецПроцедуры // ДвижениеПоРегиструТМЦНаСкладахРозницаОбщепит()

 1142 5
ДобавленоАнастасия1992524 дня назад
Последняя активность523 дня назад


Добавить комментарий

Кирилл написал:524 дня назад0

Такое бывает когда уже в проведенном документе пытаетесь проверить остатки)

Товары уже списаны данным документом, и их реально нет на складе. Но если отменить проведение - товар “вернется”.

То же самое часто бывает при перепроведении, если не очищать движения по этому документу :)

Ответить

Анастасия1992 написал:524 дня назад0

вот как я сейчас сделала и вот картинки 1. Это мой документ 2. регистр и как туда все записалось 3. когда делаю документ перемещение. (сбоку подбор там видна моя партия и количество, т.е получается на остатках все есть) 4. Это когда я провожу документ перемещение и сама ошибка.

Ответить

Анастасия1992 написал:524 дня назад0

код Движения.ТМЦНаСкладахРозницаОбщепит.Записывать = Истина;
Движения.ТМЦНаСкладахРозницаОбщепит.Очистить();
Для Каждого ТекСтрока Из Разделка Цикл
    Движение = Движения.ТМЦНаСкладахРозницаОбщепит.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
    Движение.Период = Дата;
    Движение.Организация = Организация;
    Движение.Склад= Склад;
    Движение.ВидТМЦ = ТекСтрока.ВидТМЦ;
    Движение.Количество = ТекСтрока.КоличествоПоНорме;
    Движение.ОтпускнаяЦена = ТекСтрока.ЦенаПФ;
    Движение.Партия = ТекСтрока.Партия;
    Движение.Сумма = ТекСтрока.СуммаПоНорме;
    Движение.СчетУчетаТМЦ = ТекСтрока.СчетУчетаТМЦ;
    Движение.ТМЦ = ТекСтрока.ТМЦ;
    Движение.ХарактеристикаТМЦ = ТекСтрока.ХарактеристикаТМЦ;
КонецЦикла;
Движения.Записать();  

Ответить

Кирилл написал:523 дня назад0

Анастасия, записи с виду верные.

Нужно смотреть в отладке, в отраслевых решений бывают глупые ошибки.

С ходу если - всё правильно сделано. Найдите в коде по выводимому сообщению нужную строчку и посмотрите как идёт проверка, по каким параметрам.

Ответить

Анастасия1992 написал:523 дня назад0

ладно буду искать, спасибо большое

Ответить

Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Как создать регистр накопления оборотов?

Привет, как правильно создать регистр накопления оборотов? Я добавил новый отчёт...

1С 8.2: Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"

Всем привет. Помогите пожалуйста!!!!!!!!!!!!!!! Выдает ошибку. Была пропущена т...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

помогите пожалуйста реализовать решение

Добрый день! помогите пожалуйста реализовать решение: Редакция 3.0 (3.0.43.252),...

Помогите пожалуйста с начислением ЗП

Начисляю зп за апрель, идентична марту. Делаю ведомость на выплату зп через касс...

Новое

Срочно! Нижний Новгород! Нужен опытный программист 1С

Крупная и развивающаяся кампания находится в поисках Программиста 1С (Финансовы...

Бюджетирование - статьи бюджета по произвольным данным

Помогите, пожалуйста! Создаю статью бюджета с произвольными данными. Загружаю с...

егаис

Добрый вечер. Прошу Вас помочь. Для получения накладных от производителя делаю з...

Концептуальная модель (инфологическая) распределенной БД

Очень нужна ваша помощь. Создала распределенную 1С БД( хоть она и не распределен...

Где находится анткетирование клиентов в УТ 11?

Подскажите где почитать про анкетирование в УТ. Нужно изучить как оно устроено....