0

Проблема с выводом отчёта в 2 колонки

#1С 8.3#1С Управление торговлей 10.3

Добрый день! Необходимо выводить номенклатуру в отчёте в две колонки, столкнулась с проблемой, что при разном количестве строк отчёт отображается неккоректно (на картинке). Что нужно дописать?

Функция Команда1НаСервере()

Макет = ПолучитьМакет("Макет1");

ТабДок = Новый ТабличныйДокумент;
ТабДок.Очистить();
ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьИмяГруппы = Макет.ПолучитьОбласть("ИмяГруппы");

ОписаниеПериода = "на " + Формат(Дата, "ДФ = ""дд.ММ.гггг""");
ОбластьЗаголовок.Параметры.Период = "Данные "+ ОписаниеПериода;

ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               |    ТоварыНаСкладахОстатки.Номенклатура,
               |    ТоварыНаСкладахОстатки.КоличествоОстаток,
               |    ТоварыНаСкладахОстатки.Номенклатура.Родитель КАК НоменклатураРодитель
               |ИЗ
               |    РегистрНакопления.ТоварыНаСкладах.Остатки(&Дата, ) КАК ТоварыНаСкладахОстатки
               |ГДЕ
               |    ТоварыНаСкладахОстатки.КоличествоОстаток <> 0
               |    И ТоварыНаСкладахОстатки.Номенклатура В ИЕРАРХИИ(&Номенклатура)
               |
               |СГРУППИРОВАТЬ ПО
               |    ТоварыНаСкладахОстатки.Номенклатура,
               |    ТоварыНаСкладахОстатки.КоличествоОстаток,
               |    ТоварыНаСкладахОстатки.Номенклатура.Родитель
               |ИТОГИ ПО
               |    НоменклатураРодитель";

Запрос.УстановитьПараметр("Дата", Дата);
Запрос.УстановитьПараметр("Номенклатура",Справочники.Номенклатура.НайтиПоКоду("00000001624"));
Выб = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
     Счетчик =1;
Пока Выб.Следующий() цикл
    ОбластьИмяГруппы.Параметры.ИмяГруппы1 = Выб.НоменклатураРодитель;
    ТабДок.Вывести(ОбластьИмяГруппы);
    Выборка=Выб.Выбрать();
    пока Выборка.Следующий() цикл
        СтрокаКолонка1  = Макет.ПолучитьОбласть("СтрокаТаблицы|Колонка1");
        СтрокаКолонка1.Параметры.Поле1 = Выборка.Номенклатура;
    Если Счетчик = 1 Тогда //первая колонка
        ТабДок.Вывести(СтрокаКолонка1);
        Счетчик = 2;
    Иначе
        СтрокаКолонка2  = Макет.ПолучитьОбласть("СтрокаТаблицы|Колонка2");
        СтрокаКолонка2.Параметры.Поле2 = Выборка.Номенклатура;
        ТабДок.Присоединить(СтрокаКолонка2);
       Счетчик = 1;
    КонецЕсли;
КонецЦикла;
КонецЦикла;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.ТолькоПросмотр = Истина;
Возврат ТабДок;

КонецФункции

 1138 2
ДобавленоЭльмира617 дней назад
Последняя активность616 дней назад


Добавить комментарий

Кирилл написал:616 дней назад0

Здравствуйте!

Если правильно понял: ошибка в том, что вы уже вывели первую область и выводите вторую область уже непосредственно к табличному документу (результирующему). А надо прикреплять к первой области.

Ответить

Эльмира написал:616 дней назад0

Не соображу как это сделать.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Не выводится внешний отчёт с управляемой формой.

Всем доброго дня! Подскажите, пожалуйста, пытаюсь добавить в Розницу 2.1 внешний...

Вывод печатной формы в 1С 8.3

Добрый день сделал ВПФ для ПКО в БГУ2.0 но есть одна проблема ни пойму как сдела...

1С 8.2: Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"

Всем привет. Помогите пожалуйста!!!!!!!!!!!!!!! Выдает ошибку. Была пропущена т...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Новое

настройка печатной формы отчета Расчет по страховым взносам

Добрый день, подскажите пожалуйста , из-за чего на титульном листе отчета не печ...

реплики Longines часы, longinesladieswatchesuk.top

[b][url=http://www.longinesladieswatchesuk.top/ru/]часы Longines в великобритани...

не могу обновить 1с 8.2

Здравствуйте! подскажите как можно решить проблему с обновлением 1 с 8.2 базовая...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Справочник

Здравствуйте, подскажите пожалуйста, хочу сделать, чтобы при выборе в справочник...