1

При попытке распечатать расходный кассовый ордер Выводится ошибка "Поле объекта не обнаружено (СуммаПрописьюПродолжение)"

#1С 8.2

Всем привет! Ребят спасайте! После обновления с 7 на 8,2 при попытке распечатать расходный кассовый ордер Выводится ошибка “Поле объекта не обнаружено (СуммаПрописьюПродолжение)”. Я в 1С полный профан. Вот вроде бы текст кода на печать расходника. Чуется что ошибка где то здесь.

Функция ПечатьРКО(МассивОбъектов, ОбъектыПечати)

Перем ПодразделениеОтветственныхЛиц;

УстановитьПривилегированныйРежим(Истина);

ВалютаРеглУчета = ОбщегоНазначенияБПВызовСервераПовтИсп.ПолучитьВалютуРегламентированногоУчета();

ТабличныйДокумент = Новый ТабличныйДокумент;
ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РасходныйКассовыйОрдер_КО2";

Запрос = Новый Запрос();
Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
Запрос.Текст = ТекстЗапросаПечатьРКО();

Шапка = Запрос.Выполнить().Выбрать();

ПервыйДокумент = Истина;

Пока Шапка.Следующий() Цикл

    Если НЕ ПервыйДокумент Тогда
        ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЕсли;

    ПервыйДокумент = Ложь;
    // Запомним номер строки, с которой начали выводить текущий документ.
    НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;

    Макет = УправлениеПечатью.МакетПечатнойФормы("ОбщийМакет.ПФ_MXL_КО2");
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");

    ЕстьРасчетыСКонтрагентами = УчетДенежныхСредствКлиентСервер.ЕстьРасчетыСКонтрагентами(Шапка.ВидОперации);
    ЕстьРасчетыПоКредитам     = УчетДенежныхСредствКлиентСервер.ЕстьРасчетыПоКредитам(Шапка.ВидОперации);
    СведенияОбОрганизации     = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Организация, Шапка.ДатаДокумента);
    Валютный                  = Шапка.Валюта <> ВалютаРеглУчета;

    // Выводим шапку
    ОбластьМакета.Параметры.Заполнить(Шапка);
    ОбластьМакета.Параметры.ПредставлениеОрганизации = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(
        СведенияОбОрганизации, "НаименованиеДляПечатныхФорм,");
    ОбластьМакета.Параметры.Сумма = Формат(Шапка.Сумма, "ЧЦ=15; ЧДЦ=2") + ?(Валютный, " " + СокрЛП(Шапка.Валюта), "");

    СуммаПрописью = ОбщегоНазначенияБПВызовСервера.СформироватьСуммуПрописью(Шапка.Сумма, Шапка.Валюта);
    СуммаПрописьюПродолжение = "";
    Если СтрДлина(СуммаПрописью) > 92 Тогда
        н = 92;
        Пока н > 0 И Сред(СуммаПрописью, н, 1) <> " " Цикл
            н = н-1;
        КонецЦикла;

        СуммаПрописьюПродолжение = Сред(СуммаПрописью, н + 1);
        СуммаПрописью = Лев(СуммаПрописью, н);
    КонецЕсли;

    ОбластьМакета.Параметры.СуммаПрописью         = СуммаПрописью;
    ОбластьМакета.Параметры.СуммаПрописьюПродолжение = СуммаПрописьюПродолжение;

    ОбластьМакета.Параметры.ОрганизацияПоОКПО     = СведенияОбОрганизации.КодПоОКПО;
    ОбластьМакета.Параметры.ДатаДокумента         = Формат(Шапка.ДатаДокумента, "ДФ=dd.MM.yyyy");
    ОбластьМакета.Параметры.НомерДокумента        = ПрефиксацияОбъектовКлиентСервер.ПолучитьНомерНаПечать(Шапка.Номер, Истина, Ложь);
    ОбластьМакета.Параметры.ДатаДокументаПрописью = Формат(Шапка.ДатаДокумента, "ДФ='dd MMMM yyyy ""г.""'");

    КодыСчетСубсчет = ОпределитьКодыСчетСубсчет(Шапка);

    ОбластьМакета.Параметры.ДебетСубСчет          = КодыСчетСубсчет.Дебет;
    ОбластьМакета.Параметры.КредитСубСчет         = КодыСчетСубсчет.Кредит;

    ПодразделениеОтветственныхЛиц = Шапка.ПодразделениеОрганизации;

    ОтветственныеЛица = ОтветственныеЛицаБП.ОтветственныеЛица(Шапка.Организация, Шапка.ДатаДокумента, ПодразделениеОтветственныхЛиц);

    ОбластьМакета.Параметры.ФИОРуководителя       = ОтветственныеЛица.РуководительПредставление;
    ОбластьМакета.Параметры.ДолжностьРуководителя = ОтветственныеЛица.РуководительДолжностьПредставление;

    ОбластьМакета.Параметры.ФИОГлавногоБухгалтера = ОтветственныеЛица.ГлавныйБухгалтерПредставление;
    ОбластьМакета.Параметры.ФИОКассира            = ОтветственныеЛица.КассирПредставление;

    ОбластьМакета.Параметры.Основание             = Шапка.Основание;
    ОбластьМакета.Параметры.Приложение            = Шапка.Приложение;

    ОбластьМакета.Параметры.ФИОПолучателя         = Шапка.Выдать;
    ОбластьМакета.Параметры.РеквизитыДокументаУдостоверяющегоЛичность = Шапка.ПоДокументу;

    ТабличныйДокумент.Вывести(ОбластьМакета);

    // В табличном документе зададим имя области, в которую был
    // выведен объект. Нужно для возможности печати покомплектно.
    УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент, НомерСтрокиНачало, ОбъектыПечати, Шапка.Ссылка);

КонецЦикла;

Возврат ТабличныйДокумент;

КонецФункции

 1969 6
ДобавленоЕвгений513 дней назад
Последняя активность486 дней назад


Добавить комментарий

Кирилл написал:512 дней назад0

Избавиться от ошибки очень просто: Удалите или закомментируйте строку :

ОбластьМакета.Параметры.СуммаПрописьюПродолжение = СуммаПрописьюПродолжение;

Другое дело, понять, почему на макете табличного документа нет параметра “СуммаПрописьюПродолжение”….

Ответить

Евгений написал:512 дней назад0

Спасибо, попробую, а последствия в виде других ошибок могут быть если удалить или закомментировать строку? И вот еще вопрос, как войти в режим изменения кода? Захожу в конфигуратор, открываю нужный код, но прописать в нем ничего не могу. Как сделать так, что бы появилась возможность его отредактировать?

Ответить

Кирилл написал:512 дней назад0

А… У вас конфигурация на поддержки. Вообще странно что “типовая” так глючит.

Про снятие с поддержки написано тут: http://forum1s.ru/read/kak-sniat-i-postavit-konfiguratsiiu-1s-na-podderzhku/

Ответить

Евгений написал:512 дней назад0

Кирилл, Спасибо Вам Большое!!! Сделал копию БД для эксперимента, загрузил ее, снял с нее поддержку, отредактировал синтаксис, действительно, форма начала печататься! Единственное что, на втором листе (которого не должно быть) посередине стала печататься мелким шрифтом надпись “прописью” как будто она убежала откуда то из подстрочного пространства формы, хотя на первом листе, вроде бы все в порядке, где это можно посмотреть и отредактировать?

И после возобновления поддержки ничего не сбивается в конфигурации она остается такой же как и до редактирования? Единственное что это вносятся новые изменения которые я пропишу?

Ответить

Кирилл написал:511 дней назад0

Всегда пожалуйста!) Обращайтесь :)

По “сумме прописью”: смотрите, в конфигураторе есть макет, откуда вырисовывается печатная форма. В вашем случае это ОбщийМакет.ПФ_MXL_КО2.

Суть ошибки в чем: в программном коде указан параметр печатной формы, которого нет на шаблоне. Посмотрите вот в этой статье как формируется простенькая печатная форма.

Если в кратце - у вас на макете должно быть поле, в котором написано “СуммаПрописьюПродолжение” и если посмотреть в свойства этого поля там должно стоят в свойстве “Заполнение” значение “Параметр” или “Шаблон”.

По поддержке: В принципе да… НО! При обновлении теперь будет выскакивать окно где нужно будет сравнить и объединить вашу конфигурацию (измененной) с новой конфигурацией поставщика :)

Надеюсь поймете мою корявую письменную речь)))

Ответить

Евгений написал:486 дней назад0

Спасибо еще раз! Разобрались в чем было дело. Скорее всего дело было в скрытом программном коде который недоступен простому пользователю. Решение оказалось до безобразия простым, просто скопировали форму КО_2 и поменяли в в синтаксисе печать кассового ордера КО_2 на КО_3, пропала съехавшая надпись “прописью” и теперь все замечательно печатается)

Теперь возник следующий вопрос. У нас имеется USB ключ HASP4 с лицензией на 5 ПК, необходимо поменять системный блок у Зам. гл. буха. Как это все делается? Ставлю 1С, ищу базу на сервере, а затем как на него установить лицензию? или она установится автоматом при подключении к базе. Буду благодарен за подробную инструкцию к действию.

Ответить

Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Поле объекта не обнаружено в 1С

Люди, помогите, плиз! Я совсем новичок в 1С. Пишу печатную форму, пытаюсь заполн...

Ошибка при отправке интернет-писем

Конфигурация пустая. Требуется прописать модуль получения и отправки писем. Все ...

Не выводится внешний отчёт с управляемой формой.

Всем доброго дня! Подскажите, пожалуйста, пытаюсь добавить в Розницу 2.1 внешний...

Вывод печатной формы в 1С 8.3

Добрый день сделал ВПФ для ПКО в БГУ2.0 но есть одна проблема ни пойму как сдела...

1С 8.2: Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"

Всем привет. Помогите пожалуйста!!!!!!!!!!!!!!! Выдает ошибку. Была пропущена т...

Новое

1С: Бухгалтерию 8.2 дёшево

Программа 1С: Бухгалетрия 8.2 По поводу приобретения программы обращайтесь на по...

Курсы

Добрый день! Осталось 2 ключа для активации курса “Профессиональный учёт в 1С:З...

"Наряд на хозтранспорт и спецтехнику" Путевые листы

Здравствуйте, Форумчане, прошу вашего совета. В организации такая ситуация: ест...

Создание обработки

Помогите с задачей. Суть такова - нужно создать внешнею обработку которая будет ...

Заполнение раздела 3 Расчет налоговой базы Книги доходов и расходов

Добрый день! Меня зовут Наталья. Про заполнение Кудир в КА очень все хорошо пишу...