0

Ошибка при записи записи регистра сведений

#Регистр сведений

Доброго времени суток! Установлена ЗУП 3.0. Уважаемые, подскажите, суть проблемы такова, делаю загрузку из Ексель (выгружен с другой программы) данных о местах работы (регистр сведений - ТрудоваяДеятельностьФизическихЛиц). Пробовал и СоздатьМенеджерЗаписи() и СоздатьНаборЗаписей(), не получается… Выдает ошибку - Запись не верна! Значение поля не соответствует установленному отбору……. Поле:НомерПоПорядку. Вот код:

&НаСервере Процедура КомандаЗагрузитьМестаРаботыНаСервере()

ТаблицаПоиска = Объект.ТаблицаСотрудников1С.Выгрузить();

БылСотрудник = ""; Номер = 0;
Для Каждого ДанныеСотрудника Из Объект.ТаблицаСотрудниковФайл Цикл

    Сотрудник = ДанныеСотрудника.Сотрудник;
    Начало    = ДанныеСотрудника.Начало;
    Окончание = ДанныеСотрудника.Окончание;
    Организация = ДанныеСотрудника.Организация;
    Должность = ДанныеСотрудника.Должность;

    Результат = ТаблицаПоиска.Найти(Сотрудник,"Сокращенно");

    Если Результат = Неопределено Тогда
        Сообщить("Сотрудник: "+Сотрудник+" не найден в базе 1С!!!");
        Продолжить;
    КонецЕсли;

    Если БылСотрудник <> Сотрудник Тогда
        Номер = 0;
        БылСотрудник = Сотрудник;
    КонецЕсли;

    Номер = Номер + 1;

    НоваяЗапись = РегистрыСведений.ТрудоваяДеятельностьФизическихЛиц.СоздатьМенеджерЗаписи();

    НоваяЗапись.ФизическоеЛицо = Результат.Сотрудник.ФизическоеЛицо;
    НоваяЗапись.ДатаНачала     = Начало;
    НоваяЗапись.НомерПоПорядку = Номер;
    НоваяЗапись.ДатаОкончания  = Окончание;
    НоваяЗапись.Организация    = Организация;
    НоваяЗапись.Должность      = Должность;

    НоваяЗапись.Записать(Истина);

КонецЦикла;

КонецПроцедуры

 1741 1
ДобавленоAdoney495 дней назад
Последняя активность494 дня назад


Добавить комментарий

Кирилл написал:494 дня назад0

Здравствуйте!

В данном примере такой ошибки быть не может, или я что то не догоняю…

А что бы этот пример заработал, по идее нужно убрать “Истина” в методе “Записать”

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Ошибка при отправке интернет-писем

Конфигурация пустая. Требуется прописать модуль получения и отправки писем. Все ...

Не могу программно сформировать типовой отчет

Пытаюсь из внешней обработки программно сформировать типовой отчет и вывести рез...

Не присваивается номер документу в 1С 8.2

Здравствуйте! Сделала отчет комитенту о закупках, он был первый и единственный в...

Регистр сведений

Добрый день! Подскажите, пожалуйста, программа 8.3 выдает при закрытии месяца сл...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

Внешний отчет

здравствуйте, подскажите, как создать внешний отчет, для того чтобы вывести инфо...

ручные проводки в НУ

Добрый день, Организация на ОСНО с 2016 года в январе 2016 года поступили на р/с...

Главное меню

Подскажите пожалуйста, у меня в главном меню куда исчезло меню Отчеты ( не значк...

Ищем программиста 1С в штат г.Москва

Доработка конфигурации 1С 8 Континент страхование на базе Бухгалтерии КОРП Созда...

Остатки товаров: настройка отчета

Добрый день! Подскажите пожалуйста по настройкам отчета: когда-то давно работала...