0

Ошибка при записи записи регистра сведений

#Регистр сведений

Доброго времени суток! Установлена ЗУП 3.0. Уважаемые, подскажите, суть проблемы такова, делаю загрузку из Ексель (выгружен с другой программы) данных о местах работы (регистр сведений - ТрудоваяДеятельностьФизическихЛиц). Пробовал и СоздатьМенеджерЗаписи() и СоздатьНаборЗаписей(), не получается… Выдает ошибку - Запись не верна! Значение поля не соответствует установленному отбору……. Поле:НомерПоПорядку. Вот код:

&НаСервере Процедура КомандаЗагрузитьМестаРаботыНаСервере()

ТаблицаПоиска = Объект.ТаблицаСотрудников1С.Выгрузить();

БылСотрудник = ""; Номер = 0;
Для Каждого ДанныеСотрудника Из Объект.ТаблицаСотрудниковФайл Цикл

    Сотрудник = ДанныеСотрудника.Сотрудник;
    Начало    = ДанныеСотрудника.Начало;
    Окончание = ДанныеСотрудника.Окончание;
    Организация = ДанныеСотрудника.Организация;
    Должность = ДанныеСотрудника.Должность;

    Результат = ТаблицаПоиска.Найти(Сотрудник,"Сокращенно");

    Если Результат = Неопределено Тогда
        Сообщить("Сотрудник: "+Сотрудник+" не найден в базе 1С!!!");
        Продолжить;
    КонецЕсли;

    Если БылСотрудник <> Сотрудник Тогда
        Номер = 0;
        БылСотрудник = Сотрудник;
    КонецЕсли;

    Номер = Номер + 1;

    НоваяЗапись = РегистрыСведений.ТрудоваяДеятельностьФизическихЛиц.СоздатьМенеджерЗаписи();

    НоваяЗапись.ФизическоеЛицо = Результат.Сотрудник.ФизическоеЛицо;
    НоваяЗапись.ДатаНачала     = Начало;
    НоваяЗапись.НомерПоПорядку = Номер;
    НоваяЗапись.ДатаОкончания  = Окончание;
    НоваяЗапись.Организация    = Организация;
    НоваяЗапись.Должность      = Должность;

    НоваяЗапись.Записать(Истина);

КонецЦикла;

КонецПроцедуры

 1561 1
ДобавленоAdoney450 дней назад
Последняя активность449 дней назад


Добавить комментарий

Кирилл написал:449 дней назад0

Здравствуйте!

В данном примере такой ошибки быть не может, или я что то не догоняю…

А что бы этот пример заработал, по идее нужно убрать “Истина” в методе “Записать”

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Ошибка при отправке интернет-писем

Конфигурация пустая. Требуется прописать модуль получения и отправки писем. Все ...

Не могу программно сформировать типовой отчет

Пытаюсь из внешней обработки программно сформировать типовой отчет и вывести рез...

Не присваивается номер документу в 1С 8.2

Здравствуйте! Сделала отчет комитенту о закупках, он был первый и единственный в...

Регистр сведений

Добрый день! Подскажите, пожалуйста, программа 8.3 выдает при закрытии месяца сл...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

бисер

пандораПандора прелестиПандора браслет [b]пандора[/b][b][url=http://www.pandorab...

Réplicas de relojes

[b][url=http://es.brandnamewatches.co/]réplica de relojes de alta calidad para l...

Поддельный Lady-Datejust Ролекс

Rolexчасы Rolexподдельный Rolex часы [b][url=http://www.rolexmens.top/ru/]Rolex[...

High Quality Replica Watches,Fake Watches Sale At Lowest Price

Омега реплика Омега реплика [b][url=http://www.bugtalk.us/ru/]высокое качество р...

Серия Hublot Big Bang

Hublot женские часы Hublot часы продажа [b][url=http://www.hublotmenswatches.top...