0

Ошибка при отправке интернет-писем

#1С 8.3

Конфигурация пустая. Требуется прописать модуль получения и отправки писем. Все параметры профиля верны, проверка была на ящиках mail.ru и yandex.ru. На обоих приём нормальный, а вот отправка выдаёт ошибку: Ошибка времени выполнения: Ошибка при вызове метода контекста (Послать). Не могу никак найти, в чём причина. Может, какие-то параметры не указаны или тайм-аут маленький (хотя при установке 120 та же проблема)? Уже не знаю, что и делать с этим. Заранее благодарю.

Функция ПодключитьПрофиль() Экспорт

    Профиль = Новый ИнтернетПочтовыйПрофиль;

    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    ПочтовыйПрофиль.АдресСервераPOP3 как АдресСервераPOP3,
                   |    ПочтовыйПрофиль.ПортPOP3 как ПортPOP3,
                   |    ПочтовыйПрофиль.АдресСервераSMTP как АдресСервераSMTP,
                   |    ПочтовыйПрофиль.ПортSMTP как ПортSMTP,
                   |    ПочтовыйПрофиль.Пароль как Пароль,
                   |    ПочтовыйПрофиль.Пользователь как Пользователь
                   |ИЗ
                   |    Справочник.ПочтовыйПрофиль КАК ПочтовыйПрофиль";

    Результат = Запрос.Выполнить().Выгрузить();

    Профиль.АдресСервераPOP3    = "pop.mail.ru";
    Профиль.ПортPOP3             = 995;
    Профиль.ИспользоватьSSLPOP3 = Истина;

    Профиль.Пароль              = "pass";
    Профиль.Пользователь      = "address";

    Профиль.АдресСервераSMTP     = "smtp.mail.ru";
    Профиль.ПортSMTP             = 465;
    Профиль.ИспользоватьSSLSMTP = Истина;

    Профиль.ПарольSMTP          = "pass";
    Профиль.ПользовательSMTP = "address";

    Профиль.ТолькоЗащищеннаяАутентификацияSMTP = Ложь;
    Профиль.АутентификацияSMTP  = СпособSMTPАутентификации.Login;

    Профиль.Таймаут = 60;

    Возврат Профиль;

КонецФункции

Процедура ПолучениеПочты() Экспорт

    ИнтернетПочта  = Новый ИнтернетПочта;

    Попытка
        ИнтернетПочта.Подключиться(ПодключитьПрофиль());
    Исключение
        Сообщить(ОписаниеОшибки());
        Возврат;
    КонецПопытки;

    Далее    = Новый Массив;
    Сообщения = ИнтернетПочта.Выбрать(Ложь);

    ИнтернетПочта.Отключиться();

// проверка на повторяемость писем, запись в справочник и формирование из писем массива для последующей обработки

Для каждого Письмо из Далее Цикл

              Для каждого Строка из ТЗ Цикл

                Если Найти(Письмо.Тексты.Получить(0).Текст, Строка.Наименование + ":") > 0 Тогда
                    НН           = Найти(Письмо.Тексты.Получить(0).Текст, Строка.Наименование) + СтрДлина(Строка.Наименование) + 2;
                    СтрЧ       = Сред(Письмо.Тексты.Получить(0).Текст,НН);
                    НК           = Найти(СтрЧ,Символ(13));
                    КодЗапроса = Лев(СтрЧ,НК);
                    ТФ.ДобавитьСтроку(Строка.Наименование + ": " + КодЗапроса);
                    ТФ.Записать("C:\Обмен Сообщениями\Запрос" + Справочники.Письма.Код + ".txt");

                    Если Строка.КодЗапуска = "File" Тогда

                        Если Найти(КодЗапроса, "<ВнутреннийСчетчик>") > 0 Тогда
                            Результат = СтрЗаменить(КодЗапроса, "<ВнутреннийСчетчик>", Справочники.Письма.Код);
                            ТФ1.ДобавитьСтроку(Результат);
                            ТФ1.Записать("C:\Обмен Сообщениями\" + Результат + ".txt");
                        КонецЕсли;
                    КонецЕсли;

                Иначе

                    Сообщение = Новый ИнтернетПочтовоеСообщение;

                    ПочтовыеАдреса = Сообщение.Получатели;
                    ПочтовыйАдрес = ПочтовыеАдреса.Добавить();
                    ПочтовыйАдрес.Адрес = Письмо.Отправитель.Адрес;

                    Сообщение.Тема = "Ошибка в запросе номера счёта";

                    Текст = Сообщение.Тексты.Добавить(Строка.Наименование + " указан неверно.");
                    ИнтернетПочта.Подключиться(ПодключитьПрофиль());

                    Попытка
                        ИнтернетПочта.Послать(Сообщение); //на этом моменте вылетает ошибка
                    Исключение
                        Сообщить(ОписаниеОшибки());
                    Возврат;
                    КонецПопытки;

                    ИнтернетПочта.Отключиться();

                КонецЕсли;

                Объект = Справочники.Письма.НайтиПоРеквизиту("Идентиф", Письмо.ИдентификаторСообщения).ПолучитьОбъект();
                Объект.Получено = Истина;
                Объект.Записать();

            КонецЦикла;

        КонецЦикла;

    КонецПроцедуры
 1114 2
Добавленоgamograff511 дней назад
Последняя активность489 дней назад


Добавить комментарий

Кирилл написал:511 дней назад0

Добрый день!

А угостите, пожалуйста, расшифровкой ошибки :) Там обычно есть кнопка “подробнее”. Если такой кнопки нет - запустите в режиме толстого клиента.

Ответить

gamograff написал:489 дней назад0

При любом варианте запуска отладки вылетает лишь ошибка, которая на скане. Кнопки “Подробнее” нет.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Ошибка при вызове метода ПодключитьОбработчикОжидания

В Общем модуле находится процедура считывания и записи почты. Эта процедура долж...

Почтовый менеджер, заполнение текста письма по шаблону

Используем 1С CRM 2.0. В почтовом менеджере при создании (ответе и пересылке) пи...

Ошибка при записи записи регистра сведений

Доброго времени суток! Установлена ЗУП 3.0. Уважаемые, подскажите, суть проблемы...

1С 8.2: Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"

Всем привет. Помогите пожалуйста!!!!!!!!!!!!!!! Выдает ошибку. Была пропущена т...

Новое

Prada Сумки 1786 Абрикос [2614] [Prada Totes-648] - $366.00 : Spyder куртки , pradamen.top

PradaPrada сумкиPrada сумки[b][url=http://www.pradamen.top/ru/]Prada[/url][/b] [...

Серия Hublot Big Bang

Hublot женские часы Hublot часы продажа [b][url=http://www.hublotmenswatches.top...

Spyder лыжные очки

Spyder свитер куртка Spyder куртка для женщин [b][url=http://www.spydersale.top/...

Pandora Happy Holidays

пандораПандора прелестиПандора браслет [b][url=http://www.pandoraclips.top/ru/]п...

Nike Air Max 2014 Древесный уголь Серый Зеленый - $121.00 : Найк магазины выходные, nikerunning.top

Выход Найк Air Max 1 Найк [b][url=http://www.nikerunning.top/ru/]макс воздуха 90...