0

Округление суммы

#1С 8.3#Все конфигурации

Есть проблема. в 1с 8.3 УТ1.1 необходимо сделать округление итоговой суммы со скидкой. Само округление я сделал, но оно работает только с проведенным документом. не могу понять где нужно поправить в конфигураторе чтобы при оформлении заказа покупателя со скидкой работало округление до целого числа (т.е. без копеек). вот то что я сделал

Процедура РассчитатьСуммуТабЧасти(СтрокаТабличнойЧасти, ДокументОбъект, СпособРасчета = Неопределено) Экспорт

ИмяТабличнойЧасти = ОбщегоНазначения.ПолучитьИмяТабличнойЧастиПоСсылкеНаСтроку(СтрокаТабличнойЧасти);

МетаданныеДокумента = ДокументОбъект.Метаданные();

Сумма = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Количество; СуммаСкидки = 0;

Если (СпособРасчета = Неопределено) Или (СпособРасчета = Перечисления.СпособРасчетаСуммыДокумента.СУчетомВсехСкидок) Или (СпособРасчета = Перечисления.СпособРасчетаСуммыДокумента.БезУчетаРучнойСкидки) Тогда Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента(“ПроцентАвтоматическихСкидок”, МетаданныеДокумента, ИмяТабличнойЧасти) Тогда СуммаСкидки = Сумма * СтрокаТабличнойЧасти.ПроцентАвтоматическихСкидок / 100; КонецЕсли;

  Если (СпособРасчета <> Перечисления.СпособРасчетаСуммыДокумента.БезУчетаРучнойСкидки)Тогда

Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента(“ПроцентСкидкиНаценки”, МетаданныеДокумента, ИмяТабличнойЧасти) Тогда СуммаСкидки = СуммаСкидки + (Сумма * СтрокаТабличнойЧасти.ПроцентСкидкиНаценки / 100); КонецЕсли; КонецЕсли; КонецЕсли;

СтрокаТабличнойЧасти.Сумма = Сумма - СуммаСкидки; СтрокаТабличнойЧасти.Сумма = Окр(СтрокаТабличнойЧасти.Сумма, 0); КонецПроцедуры // РассчитатьСуммуТабЧасти()

 578 1
ДобавленоIlich188 дней назад
Последняя активность185 дней назад


Добавить комментарий

Кирилл написал:185 дней назад0

Не понимаю из вашего кода куда вы попадаете в зависимости от условия,

Но в общем виде так:

Сумма = Окр(Сумма,0)

Можно прописать в последней строке такую заплатку и всё будет работать.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Метод объекта не обнаружен (Заполнить ЗначенияСвойствАвтозаполнения)

Собственно проблема в том что обновились до УТ 11.1 И данная Обработка выдает та...

Вывод печатной формы в 1С 8.3

Добрый день сделал ВПФ для ПКО в БГУ2.0 но есть одна проблема ни пойму как сдела...

Закрытие месяца - округление в 1С 8.2 99.09 - 68.02

Добрый день! Если кто-то знает, объясните, пожалуйста, по какому принципу при за...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

Работа с регистром накопления и документами

Друзья! Прошу помощи! Есть документ ПередачаОбъектаВПрокат, который выполняет дв...

Компановщик макета неуправляемых форм

Добрый вечер! Проблема состоит в следующем: происходит динамическое формирование...

как убрать Партионный учет с одного счета?

Имеется 1 с 8.2 в настройках управления МПЗ выставлено “ведется учет по партиям...

Погашение стоимости спецодежды

Добрый день. Столкнулась вот с какой проблемой: при проведении документа в 1С 8...

Привязка контрагента к менеджеру

Добрый день! Подскажите, пожалуйста, есть ли возможность в 1С 8.3 Предприятие сд...