0

Округление суммы

#1С 8.3#Все конфигурации

Есть проблема. в 1с 8.3 УТ1.1 необходимо сделать округление итоговой суммы со скидкой. Само округление я сделал, но оно работает только с проведенным документом. не могу понять где нужно поправить в конфигураторе чтобы при оформлении заказа покупателя со скидкой работало округление до целого числа (т.е. без копеек). вот то что я сделал

Процедура РассчитатьСуммуТабЧасти(СтрокаТабличнойЧасти, ДокументОбъект, СпособРасчета = Неопределено) Экспорт

ИмяТабличнойЧасти = ОбщегоНазначения.ПолучитьИмяТабличнойЧастиПоСсылкеНаСтроку(СтрокаТабличнойЧасти);

МетаданныеДокумента = ДокументОбъект.Метаданные();

Сумма = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Количество; СуммаСкидки = 0;

Если (СпособРасчета = Неопределено) Или (СпособРасчета = Перечисления.СпособРасчетаСуммыДокумента.СУчетомВсехСкидок) Или (СпособРасчета = Перечисления.СпособРасчетаСуммыДокумента.БезУчетаРучнойСкидки) Тогда Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента(“ПроцентАвтоматическихСкидок”, МетаданныеДокумента, ИмяТабличнойЧасти) Тогда СуммаСкидки = Сумма * СтрокаТабличнойЧасти.ПроцентАвтоматическихСкидок / 100; КонецЕсли;

  Если (СпособРасчета <> Перечисления.СпособРасчетаСуммыДокумента.БезУчетаРучнойСкидки)Тогда

Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента(“ПроцентСкидкиНаценки”, МетаданныеДокумента, ИмяТабличнойЧасти) Тогда СуммаСкидки = СуммаСкидки + (Сумма * СтрокаТабличнойЧасти.ПроцентСкидкиНаценки / 100); КонецЕсли; КонецЕсли; КонецЕсли;

СтрокаТабличнойЧасти.Сумма = Сумма - СуммаСкидки; СтрокаТабличнойЧасти.Сумма = Окр(СтрокаТабличнойЧасти.Сумма, 0); КонецПроцедуры // РассчитатьСуммуТабЧасти()

 688 1
ДобавленоIlich224 дня назад
Последняя активность221 день назад


Добавить комментарий

Кирилл написал:221 день назад0

Не понимаю из вашего кода куда вы попадаете в зависимости от условия,

Но в общем виде так:

Сумма = Окр(Сумма,0)

Можно прописать в последней строке такую заплатку и всё будет работать.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Метод объекта не обнаружен (Заполнить ЗначенияСвойствАвтозаполнения)

Собственно проблема в том что обновились до УТ 11.1 И данная Обработка выдает та...

Вывод печатной формы в 1С 8.3

Добрый день сделал ВПФ для ПКО в БГУ2.0 но есть одна проблема ни пойму как сдела...

Закрытие месяца - округление в 1С 8.2 99.09 - 68.02

Добрый день! Если кто-то знает, объясните, пожалуйста, по какому принципу при за...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

2 НДФЛ и 6 НДФЛ

Добрый день! Получили процентный займ от учредителя, который не является работни...

Слияние двух баз 1 С8.3

Уважаемые партнеры, коллеги. У меня возникла необходимость в слиянии двух баз, в...

Ищем разработчика 1С на ЗУП 3.0 (Москва)

За подробностями Вы можете писать на почту alina.stogina@hays.ru!...

Перенос БГУ 1.0->БГУ 2.0 Счет 303 учет по ИФО

Всем привет! После переноса данных из 1.0 в 2.0 формирую общие оборотки и вижу, ...

Помогите сделать внешнюю печатную форму ТОРГ-13

Пытаюсь программировать в 1с недавно, опыта нет. По полученным из интернета инс...