0

Обработка формы списка регистра сведений и заполнение значений в документ

#1С 8.3

Здравствуйте! Столкнулась с такой проблемой: имеется документ “Запись на занятия” с реквизитами: дата, время, клиент, стиль, тренер. При нажатии кнопки открывается форма списка с отбором регистра сведений “Расписание занятий” с аналогичными реквизитами. При выборе строки из регистра необходимо заполнение ее значения в документ. Однако у меня не работает, в обработку выбора не заходит. Реализовываю следующим образом.

В форме документа

&НаКлиенте Процедура ВыбратьРасписание(Команда) Отбор = Новый Структура(“Дата”, Объект.ДатаЗанятия); ПараметрыФормы = Новый Структура; ПараметрыФормы.Вставить(“РежимВыбора”, Истина); ПараметрыФормы.Вставить(“Отбор”, Отбор); ОткрытьФормуМодально(“РегистрСведений.РасписаниеЗанятий.ФормаСписка”, ПараметрыФормы, ЭтаФорма);

КонецПроцедуры

&НаКлиенте Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)

ДанныеСтроки=Новый Структура("Тренер, Стиль, Время");
ЗаполнитьЗначенияСвойств(ДанныеСтроки, ВыбранноеЗначение);
ЗаполнитьЗначенияСвойств(Объект, ДанныеСтроки);
Модифицированность=Истина;

КонецПроцедуры

В форме списка регистра сведений

&НаКлиенте Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)

Стр=Элементы.Список.ТекущиеДанные;

СтандартнаяОбработка = Ложь;
СтруктураРезультат=Новый Структура;
СтруктураРезультат.Вставить("Тренер", Стр.Тренер);
СтруктураРезультат.Вставить("Стиль", Стр.Стиль);
СтруктураРезультат.Вставить("ВремяНачала", Стр.ВремяНачала);
ЗаполнитьЗначенияСвойств(СтруктураРезультат, ЭтаФорма);
ОповеститьОВыборе(СтруктураРезультат);

КонецПроцедуры

 908 0
Добавленоonlyko215 дней назад
Отредактировано215 дней назад


Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Отбор строк в управляемой форме списка документа 1С

Всем доброго времени суток! Требуется сделать отбор строк в управляемой форме сп...

Ошибка при записи записи регистра сведений

Доброго времени суток! Установлена ЗУП 3.0. Уважаемые, подскажите, суть проблемы...

Новый регистр сведений 1С 8.2 или добавить в существующий

Всем добрый день! Нужна помощь, совет, в общем все! Появилась необходимость со...

Групповое заполнение строк табличной части.

обрый день. Уважаемые форумчане помогите с кодом не могу доделать редактирование...

Заполнение табличной части на тонком клиенте

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом ...

Новое

бисер

пандораПандора прелестиПандора браслет [b]пандора[/b][b][url=http://www.pandorab...

Réplicas de relojes

[b][url=http://es.brandnamewatches.co/]réplica de relojes de alta calidad para l...

Поддельный Lady-Datejust Ролекс

Rolexчасы Rolexподдельный Rolex часы [b][url=http://www.rolexmens.top/ru/]Rolex[...

High Quality Replica Watches,Fake Watches Sale At Lowest Price

Омега реплика Омега реплика [b][url=http://www.bugtalk.us/ru/]высокое качество р...

Серия Hublot Big Bang

Hublot женские часы Hublot часы продажа [b][url=http://www.hublotmenswatches.top...