0

Обработка формы списка регистра сведений и заполнение значений в документ

#1С 8.3

Здравствуйте! Столкнулась с такой проблемой: имеется документ “Запись на занятия” с реквизитами: дата, время, клиент, стиль, тренер. При нажатии кнопки открывается форма списка с отбором регистра сведений “Расписание занятий” с аналогичными реквизитами. При выборе строки из регистра необходимо заполнение ее значения в документ. Однако у меня не работает, в обработку выбора не заходит. Реализовываю следующим образом.

В форме документа

&НаКлиенте Процедура ВыбратьРасписание(Команда) Отбор = Новый Структура(“Дата”, Объект.ДатаЗанятия); ПараметрыФормы = Новый Структура; ПараметрыФормы.Вставить(“РежимВыбора”, Истина); ПараметрыФормы.Вставить(“Отбор”, Отбор); ОткрытьФормуМодально(“РегистрСведений.РасписаниеЗанятий.ФормаСписка”, ПараметрыФормы, ЭтаФорма);

КонецПроцедуры

&НаКлиенте Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)

ДанныеСтроки=Новый Структура("Тренер, Стиль, Время");
ЗаполнитьЗначенияСвойств(ДанныеСтроки, ВыбранноеЗначение);
ЗаполнитьЗначенияСвойств(Объект, ДанныеСтроки);
Модифицированность=Истина;

КонецПроцедуры

В форме списка регистра сведений

&НаКлиенте Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)

Стр=Элементы.Список.ТекущиеДанные;

СтандартнаяОбработка = Ложь;
СтруктураРезультат=Новый Структура;
СтруктураРезультат.Вставить("Тренер", Стр.Тренер);
СтруктураРезультат.Вставить("Стиль", Стр.Стиль);
СтруктураРезультат.Вставить("ВремяНачала", Стр.ВремяНачала);
ЗаполнитьЗначенияСвойств(СтруктураРезультат, ЭтаФорма);
ОповеститьОВыборе(СтруктураРезультат);

КонецПроцедуры

 1327 0
Добавленоonlyko323 дня назад
Отредактировано323 дня назад


Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Отбор строк в управляемой форме списка документа 1С

Всем доброго времени суток! Требуется сделать отбор строк в управляемой форме сп...

Ошибка при записи записи регистра сведений

Доброго времени суток! Установлена ЗУП 3.0. Уважаемые, подскажите, суть проблемы...

Новый регистр сведений 1С 8.2 или добавить в существующий

Всем добрый день! Нужна помощь, совет, в общем все! Появилась необходимость со...

Групповое заполнение строк табличной части.

обрый день. Уважаемые форумчане помогите с кодом не могу доделать редактирование...

Заполнение табличной части на тонком клиенте

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом ...

Новое

Справочник

Здравствуйте, подскажите пожалуйста, хочу сделать, чтобы при выборе в справочник...

Заполнение значений свойств по выбранному свойству.

Как сделать автозаполнение значений свойств по выбранному свойству номенклатуры....

счет-фактура на возврат денег поставщиком

по оплате от поставщика мы приняли к зачету ндс по сч-фактуре. теперь деньги нам...

Расчет районного коэффициента в больничном листе

Добрый день! Очень нужна помощь! При расчете б/л не верно считает положительную ...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...