0

Обход дерева значений 1С

#Все конфигурации#Дерево значений

Привет! Мне нужно написать процедуру для обхода дерева значений, вся проблема в том, что я не знаю количество уровней дерева, подскажите как реализовать обход дерева значений с неизвестным количеством уровней

 4178 1
Добавлено_Наталья_803 дня назад
Отредактировано652 дня назад


Добавить комментарий

Виталий написал:803 дня назад0

Тут нужно воспользоваться рекурсией, т.е. необходимо что бы процедура обхода вызывала сама себя на каждом уровне дерева значений.

Вот примеры такой процедуры:

Для обычного приложения:

Процедура ОбойтиДеревоЗначений(Элемент)
    ПодчиненныйЭлемент=Элемент.Строки;
    Для Каждого Строка из ПодчиненныйЭлемент Цикл
        //Твой код по обработке строки дерева
        ОбойтиДеревоЗначений(Строка);
    КонецЦикла;
КонецПроцедуры

Для управляемого приложения:

&НаКлиенте
Процедура ОбойтиДеревоЗначений(Элемент)
    ПодчиненныйЭлемент=Элемент.ПолучитьЭлементы();
    Для Каждого Строка из ПодчиненныйЭлемент Цикл
        //Твой код по обработке строки дерева;
        ОбойтиДеревоЗначений(Строка);
    КонецЦикла;
КонецПроцедуры

Для начала обхода дерева необходимо вызвать процедуру ОбойтиДеревоЗначений и передать туда верхний уровень дерева. Ну а если верхних уровней несколько, то нужно в цикле обойти их все:

Для Каждого Стр из ДанныеДерева Цикл
    ОбходДерева(Стр);
КонецЦикла;

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Передать в запрос 1с таблицу значений

Привет, народ. Вопрос есть, можно ли в запрос в 1с-ке передать параметром таблиц...

Итог по столбцу в таблице значений 1С

Ребят, подскажите можно ли без обхода циклом посчитать итог по числовому полю в ...

Преобразовать массив в список значений

Народ, подскажите как в 1С 8 из массива сделать список значений, без использован...

Скопировать или создать колонки таблицы значений 1С

Народ, у меня такой вопрос: у меня есть таблица значений, мне нужно создать точн...

Перенаправления значений

1С:Предприятие 8.2 (8.2.19.130) Зарплата и Управление Персоналом, редакция 2.5 (...

Новое

Prada Сумки 1786 Абрикос [2614] [Prada Totes-648] - $366.00 : Spyder куртки , pradamen.top

PradaPrada сумкиPrada сумки[b][url=http://www.pradamen.top/ru/]Prada[/url][/b] [...

Серия Hublot Big Bang

Hublot женские часы Hublot часы продажа [b][url=http://www.hublotmenswatches.top...

Spyder лыжные очки

Spyder свитер куртка Spyder куртка для женщин [b][url=http://www.spydersale.top/...

Pandora Happy Holidays

пандораПандора прелестиПандора браслет [b][url=http://www.pandoraclips.top/ru/]п...

Nike Air Max 2014 Древесный уголь Серый Зеленый - $121.00 : Найк магазины выходные, nikerunning.top

Выход Найк Air Max 1 Найк [b][url=http://www.nikerunning.top/ru/]макс воздуха 90...