0

Не выводится внешний отчёт с управляемой формой.

#1С 8.3#1С Розница#Управляемые формы

Всем доброго дня! Подскажите, пожалуйста, пытаюсь добавить в Розницу 2.1 внешний отчёт с управляемой формой, не понимаю, что нужно написать в модуле формы в выполнить команду. Добилась того, что отчёт отображается в предприятии, но при нажатии на него ничего не происходит. Спасибо заранее! Вот модуль формы:

&НаСервере Функция Команда1НаСервере()

ТекОбъект = РеквизитФормыВЗначение("Отчет");
Макет = ТекОбъект.ПолучитьМакет("Макет1");

ТабДок = Новый ТабличныйДокумент;
ТабДок.Очистить();
ОбластьЗаголовок    = Макет.ПолучитьОбласть("Заголовок");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьСтрокаТаблицы  = Макет.ПолучитьОбласть("СтрокаТаблицы");

ОбластьЗаголовок.Параметры.ДатаНачала = Лев(Отчет.ДатаНачала,10);
ОбластьЗаголовок.Параметры.ДатаОкончания = Лев(Отчет.ДатаОкончания,10);

ВыборкаЗак=Документы.ЗаказПокупателя.Выбрать(НачалоДня(Отчет.ДатаНачала), КонецДня(Отчет.ДатаОкончания));

ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);

пока ВыборкаЗак.Следующий() Цикл

ЗаказПокупателя = ВыборкаЗак;

     Запрос = Новый Запрос;
 Запрос.Текст = "ВЫБРАТЬ
 |  ПриходныйКассовыйОрдер.СуммаДокумента
 |ИЗ
 |  Документ.ПриходныйКассовыйОрдер КАК ПриходныйКассовыйОрдер
 |ГДЕ
 |  ПриходныйКассовыйОрдер.ЗаказПокупателя = &мойзаказ";

 Запрос.УстановитьПараметр("мойзаказ", ВыборкаЗак.Ссылка );

 Результат = Запрос.Выполнить();
 ВыборкаПКО = Результат.Выбрать();
  СумПКО=0;
 Пока ВыборкаПКО.Следующий() Цикл
    СумПКО=СумПКО+ВыборкаПКО.СуммаДокумента;
КонецЦикла;

    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    ЧекККМ.СуммаДокумента
                   |ИЗ
                   |    Документ.ЧекККМ КАК ЧекККМ
                   |ГДЕ
                   |    ЧекККМ.ЗаказПокупателя = &мойзаказ";

    Запрос.УстановитьПараметр("мойзаказ",ВыборкаЗак.Ссылка );
    Результат = Запрос.Выполнить();
    ВыборкаККМ = Результат.Выбрать();
    СумККМ=0;
    Пока ВыборкаККМ.Следующий() Цикл
    СумККМ=СумККМ+ВыборкаККМ.СуммаДокумента;
    КонецЦикла;

    Оплачено = СумПКО+СумККМ;
    ОстСтоимость = ВыборкаЗак.СуммаДокумента - Оплачено;

    ОбластьСтрокаТаблицы.Параметры.ЗаказПокупателя = ЗаказПокупателя;
    ОбластьСтрокаТаблицы.Параметры.Оплачено =  Оплачено;
    ОбластьСтрокаТаблицы.Параметры.ОстСтоимость = ОстСтоимость;
    ТабДок.Вывести(ОбластьСтрокаТаблицы);
    ТабДок.ОтображатьСетку = Ложь;

КонецЦикла;
    Возврат ТабДок;

КонецФункции

&НаКлиенте Процедура Команда1(Команда) табдок=Команда1НаСервере(); табдок.показать(); КонецПроцедуры

&НаКлиенте

Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения) Экспорт

Если ИдентификаторКоманды = "1" Тогда
    ФормаОбработки = ПолучитьФорму("ОтчётПоОстаточнойСтоимости.Форма.ФормаОтчета",);
    ФормаОбработки.Открыть();
КонецЕсли;

КонецПроцедуры

 1442 1
ДобавленоЭльмира611 дней назад
Последняя активность611 дней назад


Добавить комментарий

Кирилл написал:611 дней назад0

С первого взгляда всё более-менее рабочее.

Сделайте лучше по другому. Заведите реквизит формы с типом “ТабличныйДокумент”, выведите его на форму (в элементы).

И вместо “табдок.показать()” присваивайте реквизиту вновь сформированный табличный документ.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Внешние печатные формы.

Здравствуйте! Вопрос состоит в том что я решил создать внешнюю печатную форму по...

Проблема с выводом отчёта в 2 колонки

Добрый день! Необходимо выводить номенклатуру в отчёте в две колонки, столкнулас...

Не могу программно сформировать типовой отчет

Пытаюсь из внешней обработки программно сформировать типовой отчет и вывести рез...

Вывод печатной формы в 1С 8.3

Добрый день сделал ВПФ для ПКО в БГУ2.0 но есть одна проблема ни пойму как сдела...

1С 8.2: Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"

Всем привет. Помогите пожалуйста!!!!!!!!!!!!!!! Выдает ошибку. Была пропущена т...

Новое

Расчет районного коэффициента в больничном листе

Добрый день! Очень нужна помощь! При расчете б/л не верно считает положительную ...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Возврат по картам по зарплате, в случае изменения реквизитов банка

По карте была перечислена зарплата, но платеж вернулся (изменились реквизиты бан...

Составление отчета

Здравствуйте!! Нужна помощь !!! что означает Ошибка получения информации набора ...

Не могу активировать настройку

Добрый день, скачал учебную версию 8.3 Захотел внести изменения в конфигурацию З...