0

Метод объекта не обнаружен (Заполнить ЗначенияСвойствАвтозаполнения)

#1С Управление торговлей 11.1

Собственно проблема в том что обновились до УТ 11.1 И данная Обработка выдает такую ошибку при попытке загрузки скриншот Данная обработка: Заполнение табличной части приходной накладной по данным о продажах, из расходных накладных и списком номенклатуры. Управляемое приложение. Разработчик: команда программистов проекта www.new1c.ru. Бесплатная Нашел процедуру с этим названием однако что поменять тут нужно понять не могу подскажите пожалуйста

&НаСервере

Процедура ЗаполнитьПоЗначениямАвтозаполнения(НовДок, ДанныеЗаполнения = Неопределено)

ЕстьДанныеЗаполнения = (НЕ ДанныеЗаполнения = Неопределено);
ДанныеЗаполненияСтруктура = (ТипЗнч(ДанныеЗаполнения) = Тип("Структура"));

Если Не ЕстьДанныеЗаполнения Или ДанныеЗаполненияСтруктура И НЕ ДанныеЗаполнения.Свойство("ДокументОснование") Тогда
    // Заполним основные свойства
    СвойстваАвтозаполнения = Новый Структура("Организация, Склад, ХозяйственнаяОперация");
    СтрокаКлючиСтруктуры = СокрЛП(ОбменДаннымиСобытия.КлючиСтруктурыВСтроку(СвойстваАвтозаполнения));

    Если ДанныеЗаполненияСтруктура Тогда
        ЗаполнитьЗначенияСвойств(СвойстваАвтозаполнения, ДанныеЗаполнения);
    КонецЕсли;

    ОбщегоНазначенияУТ.ЗаполнитьЗначенияСвойствАвтозаполнения(НовДок.Ссылка, СвойстваАвтозаполнения);

    ЗаполнитьЗначенияСвойств(НовДок, СвойстваАвтозаполнения, СтрокаКлючиСтруктуры);

    // Заполним банковский счет и кассу в зависимости от организации
    СвойстваАвтозаполнения = Новый Структура("Организация, БанковскийСчетОрганизации", НовДок.Организация);
    СтрокаКлючиСтруктуры = СокрЛП(ОбменДаннымиСобытия.КлючиСтруктурыВСтроку(СвойстваАвтозаполнения));

    Если ДанныеЗаполненияСтруктура Тогда
        ЗаполнитьЗначенияСвойств(СвойстваАвтозаполнения, ДанныеЗаполнения);
    КонецЕсли;

    ОбщегоНазначенияУТ.ЗаполнитьЗначенияСвойствАвтозаполнения(НовДок.Ссылка, СвойстваАвтозаполнения);

    ЗаполнитьЗначенияСвойств(НовДок, СвойстваАвтозаполнения, СтрокаКлючиСтруктуры);

КонецЕсли;

КонецПроцедуры

 2547 1
ДобавленоAkcent531 день назад
Последняя активность531 день назад


Добавить комментарий

Кирилл написал:531 день назад0

Просто в последней версии УТ они переименовали или перенесли процедуру “ЗаполнитьЗначенияСвойствАвтозаполнения” в другой модуль.

Попробуйте глобальный поиском по модулям поискать по названию - скорее всего найдете.

P.S не удаляйте свои темы, это скорее всего может пригодится и другим людям. спасибо.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Почтовый менеджер, заполнение текста письма по шаблону

Используем 1С CRM 2.0. В почтовом менеджере при создании (ответе и пересылке) пи...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Заполнение табличной части на тонком клиенте

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом ...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

1С: Бухгалтерию 8.2 дёшево

Программа 1С: Бухгалетрия 8.2 По поводу приобретения программы обращайтесь на по...

Курсы

Добрый день! Осталось 2 ключа для активации курса “Профессиональный учёт в 1С:З...

"Наряд на хозтранспорт и спецтехнику" Путевые листы

Здравствуйте, Форумчане, прошу вашего совета. В организации такая ситуация: ест...

Создание обработки

Помогите с задачей. Суть такова - нужно создать внешнею обработку которая будет ...

Заполнение раздела 3 Расчет налоговой базы Книги доходов и расходов

Добрый день! Меня зовут Наталья. Про заполнение Кудир в КА очень все хорошо пишу...