0

Метод объекта не обнаружен (Заполнить ЗначенияСвойствАвтозаполнения)

#1С Управление торговлей 11.1

Собственно проблема в том что обновились до УТ 11.1 И данная Обработка выдает такую ошибку при попытке загрузки скриншот Данная обработка: Заполнение табличной части приходной накладной по данным о продажах, из расходных накладных и списком номенклатуры. Управляемое приложение. Разработчик: команда программистов проекта www.new1c.ru. Бесплатная Нашел процедуру с этим названием однако что поменять тут нужно понять не могу подскажите пожалуйста

&НаСервере

Процедура ЗаполнитьПоЗначениямАвтозаполнения(НовДок, ДанныеЗаполнения = Неопределено)

ЕстьДанныеЗаполнения = (НЕ ДанныеЗаполнения = Неопределено);
ДанныеЗаполненияСтруктура = (ТипЗнч(ДанныеЗаполнения) = Тип("Структура"));

Если Не ЕстьДанныеЗаполнения Или ДанныеЗаполненияСтруктура И НЕ ДанныеЗаполнения.Свойство("ДокументОснование") Тогда
    // Заполним основные свойства
    СвойстваАвтозаполнения = Новый Структура("Организация, Склад, ХозяйственнаяОперация");
    СтрокаКлючиСтруктуры = СокрЛП(ОбменДаннымиСобытия.КлючиСтруктурыВСтроку(СвойстваАвтозаполнения));

    Если ДанныеЗаполненияСтруктура Тогда
        ЗаполнитьЗначенияСвойств(СвойстваАвтозаполнения, ДанныеЗаполнения);
    КонецЕсли;

    ОбщегоНазначенияУТ.ЗаполнитьЗначенияСвойствАвтозаполнения(НовДок.Ссылка, СвойстваАвтозаполнения);

    ЗаполнитьЗначенияСвойств(НовДок, СвойстваАвтозаполнения, СтрокаКлючиСтруктуры);

    // Заполним банковский счет и кассу в зависимости от организации
    СвойстваАвтозаполнения = Новый Структура("Организация, БанковскийСчетОрганизации", НовДок.Организация);
    СтрокаКлючиСтруктуры = СокрЛП(ОбменДаннымиСобытия.КлючиСтруктурыВСтроку(СвойстваАвтозаполнения));

    Если ДанныеЗаполненияСтруктура Тогда
        ЗаполнитьЗначенияСвойств(СвойстваАвтозаполнения, ДанныеЗаполнения);
    КонецЕсли;

    ОбщегоНазначенияУТ.ЗаполнитьЗначенияСвойствАвтозаполнения(НовДок.Ссылка, СвойстваАвтозаполнения);

    ЗаполнитьЗначенияСвойств(НовДок, СвойстваАвтозаполнения, СтрокаКлючиСтруктуры);

КонецЕсли;

КонецПроцедуры

 3409 1
ДобавленоAkcent672 дня назад
Последняя активность672 дня назад


Добавить комментарий

Кирилл написал:672 дня назад0

Просто в последней версии УТ они переименовали или перенесли процедуру “ЗаполнитьЗначенияСвойствАвтозаполнения” в другой модуль.

Попробуйте глобальный поиском по модулям поискать по названию - скорее всего найдете.

P.S не удаляйте свои темы, это скорее всего может пригодится и другим людям. спасибо.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Почтовый менеджер, заполнение текста письма по шаблону

Используем 1С CRM 2.0. В почтовом менеджере при создании (ответе и пересылке) пи...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Заполнение табличной части на тонком клиенте

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом ...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

не могу обновить 1с 8.2

Здравствуйте! подскажите как можно решить проблему с обновлением 1 с 8.2 базовая...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Справочник

Здравствуйте, подскажите пожалуйста, хочу сделать, чтобы при выборе в справочник...

Большой видеоархив по платформам 1С 8.2 и 8.3. Пользователям и разработчикам

Всем привет! Добротный канал для обучения с регулярным добавлением видеокурсов: ...

Перенос остатков по складам из БП 3.0 в УТ 11.3

Добрый день. Есть заявка о том, что нужно один раз перенести из БП в пустую УТ д...