0

Метод объекта не обнаружен (Заполнить ЗначенияСвойствАвтозаполнения)

#1С Управление торговлей 11.1

Собственно проблема в том что обновились до УТ 11.1 И данная Обработка выдает такую ошибку при попытке загрузки скриншот Данная обработка: Заполнение табличной части приходной накладной по данным о продажах, из расходных накладных и списком номенклатуры. Управляемое приложение. Разработчик: команда программистов проекта www.new1c.ru. Бесплатная Нашел процедуру с этим названием однако что поменять тут нужно понять не могу подскажите пожалуйста

&НаСервере

Процедура ЗаполнитьПоЗначениямАвтозаполнения(НовДок, ДанныеЗаполнения = Неопределено)

ЕстьДанныеЗаполнения = (НЕ ДанныеЗаполнения = Неопределено);
ДанныеЗаполненияСтруктура = (ТипЗнч(ДанныеЗаполнения) = Тип("Структура"));

Если Не ЕстьДанныеЗаполнения Или ДанныеЗаполненияСтруктура И НЕ ДанныеЗаполнения.Свойство("ДокументОснование") Тогда
    // Заполним основные свойства
    СвойстваАвтозаполнения = Новый Структура("Организация, Склад, ХозяйственнаяОперация");
    СтрокаКлючиСтруктуры = СокрЛП(ОбменДаннымиСобытия.КлючиСтруктурыВСтроку(СвойстваАвтозаполнения));

    Если ДанныеЗаполненияСтруктура Тогда
        ЗаполнитьЗначенияСвойств(СвойстваАвтозаполнения, ДанныеЗаполнения);
    КонецЕсли;

    ОбщегоНазначенияУТ.ЗаполнитьЗначенияСвойствАвтозаполнения(НовДок.Ссылка, СвойстваАвтозаполнения);

    ЗаполнитьЗначенияСвойств(НовДок, СвойстваАвтозаполнения, СтрокаКлючиСтруктуры);

    // Заполним банковский счет и кассу в зависимости от организации
    СвойстваАвтозаполнения = Новый Структура("Организация, БанковскийСчетОрганизации", НовДок.Организация);
    СтрокаКлючиСтруктуры = СокрЛП(ОбменДаннымиСобытия.КлючиСтруктурыВСтроку(СвойстваАвтозаполнения));

    Если ДанныеЗаполненияСтруктура Тогда
        ЗаполнитьЗначенияСвойств(СвойстваАвтозаполнения, ДанныеЗаполнения);
    КонецЕсли;

    ОбщегоНазначенияУТ.ЗаполнитьЗначенияСвойствАвтозаполнения(НовДок.Ссылка, СвойстваАвтозаполнения);

    ЗаполнитьЗначенияСвойств(НовДок, СвойстваАвтозаполнения, СтрокаКлючиСтруктуры);

КонецЕсли;

КонецПроцедуры

 3045 1
ДобавленоAkcent615 дней назад
Последняя активность614 дней назад


Добавить комментарий

Кирилл написал:614 дней назад0

Просто в последней версии УТ они переименовали или перенесли процедуру “ЗаполнитьЗначенияСвойствАвтозаполнения” в другой модуль.

Попробуйте глобальный поиском по модулям поискать по названию - скорее всего найдете.

P.S не удаляйте свои темы, это скорее всего может пригодится и другим людям. спасибо.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Почтовый менеджер, заполнение текста письма по шаблону

Используем 1С CRM 2.0. В почтовом менеджере при создании (ответе и пересылке) пи...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Заполнение табличной части на тонком клиенте

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом ...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

2 НДФЛ и 6 НДФЛ

Добрый день! Получили процентный займ от учредителя, который не является работни...

Слияние двух баз 1 С8.3

Уважаемые партнеры, коллеги. У меня возникла необходимость в слиянии двух баз, в...

Ищем разработчика 1С на ЗУП 3.0 (Москва)

За подробностями Вы можете писать на почту alina.stogina@hays.ru!...

Перенос БГУ 1.0->БГУ 2.0 Счет 303 учет по ИФО

Всем привет! После переноса данных из 1.0 в 2.0 формирую общие оборотки и вижу, ...

Помогите сделать внешнюю печатную форму ТОРГ-13

Пытаюсь программировать в 1с недавно, опыта нет. По полученным из интернета инс...