0

Метод объекта не обнаружен (Заполнить ЗначенияСвойствАвтозаполнения)

#1С Управление торговлей 11.1

Собственно проблема в том что обновились до УТ 11.1 И данная Обработка выдает такую ошибку при попытке загрузки скриншот Данная обработка: Заполнение табличной части приходной накладной по данным о продажах, из расходных накладных и списком номенклатуры. Управляемое приложение. Разработчик: команда программистов проекта www.new1c.ru. Бесплатная Нашел процедуру с этим названием однако что поменять тут нужно понять не могу подскажите пожалуйста

&НаСервере

Процедура ЗаполнитьПоЗначениямАвтозаполнения(НовДок, ДанныеЗаполнения = Неопределено)

ЕстьДанныеЗаполнения = (НЕ ДанныеЗаполнения = Неопределено);
ДанныеЗаполненияСтруктура = (ТипЗнч(ДанныеЗаполнения) = Тип("Структура"));

Если Не ЕстьДанныеЗаполнения Или ДанныеЗаполненияСтруктура И НЕ ДанныеЗаполнения.Свойство("ДокументОснование") Тогда
    // Заполним основные свойства
    СвойстваАвтозаполнения = Новый Структура("Организация, Склад, ХозяйственнаяОперация");
    СтрокаКлючиСтруктуры = СокрЛП(ОбменДаннымиСобытия.КлючиСтруктурыВСтроку(СвойстваАвтозаполнения));

    Если ДанныеЗаполненияСтруктура Тогда
        ЗаполнитьЗначенияСвойств(СвойстваАвтозаполнения, ДанныеЗаполнения);
    КонецЕсли;

    ОбщегоНазначенияУТ.ЗаполнитьЗначенияСвойствАвтозаполнения(НовДок.Ссылка, СвойстваАвтозаполнения);

    ЗаполнитьЗначенияСвойств(НовДок, СвойстваАвтозаполнения, СтрокаКлючиСтруктуры);

    // Заполним банковский счет и кассу в зависимости от организации
    СвойстваАвтозаполнения = Новый Структура("Организация, БанковскийСчетОрганизации", НовДок.Организация);
    СтрокаКлючиСтруктуры = СокрЛП(ОбменДаннымиСобытия.КлючиСтруктурыВСтроку(СвойстваАвтозаполнения));

    Если ДанныеЗаполненияСтруктура Тогда
        ЗаполнитьЗначенияСвойств(СвойстваАвтозаполнения, ДанныеЗаполнения);
    КонецЕсли;

    ОбщегоНазначенияУТ.ЗаполнитьЗначенияСвойствАвтозаполнения(НовДок.Ссылка, СвойстваАвтозаполнения);

    ЗаполнитьЗначенияСвойств(НовДок, СвойстваАвтозаполнения, СтрокаКлючиСтруктуры);

КонецЕсли;

КонецПроцедуры

 3571 1
ДобавленоAkcent702 дня назад
Последняя активность702 дня назад


Добавить комментарий

Кирилл написал:702 дня назад0

Просто в последней версии УТ они переименовали или перенесли процедуру “ЗаполнитьЗначенияСвойствАвтозаполнения” в другой модуль.

Попробуйте глобальный поиском по модулям поискать по названию - скорее всего найдете.

P.S не удаляйте свои темы, это скорее всего может пригодится и другим людям. спасибо.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Почтовый менеджер, заполнение текста письма по шаблону

Используем 1С CRM 2.0. В почтовом менеджере при создании (ответе и пересылке) пи...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Заполнение табличной части на тонком клиенте

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом ...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

Бюджетирование - статьи бюджета по произвольным данным

Помогите, пожалуйста! Создаю статью бюджета с произвольными данными. Загружаю с...

егаис

Добрый вечер. Прошу Вас помочь. Для получения накладных от производителя делаю з...

Концептуальная модель (инфологическая) распределенной БД

Очень нужна ваша помощь. Создала распределенную 1С БД( хоть она и не распределен...

Где находится анткетирование клиентов в УТ 11?

Подскажите где почитать про анкетирование в УТ. Нужно изучить как оно устроено....

беда :(

Добрый день, Помогите разобраться, пжл. По неизвестным причинам с помощью моих в...