0

Метод объекта не обнаружен (Заполнить ЗначенияСвойствАвтозаполнения)

#1С Управление торговлей 11.1

Собственно проблема в том что обновились до УТ 11.1 И данная Обработка выдает такую ошибку при попытке загрузки скриншот Данная обработка: Заполнение табличной части приходной накладной по данным о продажах, из расходных накладных и списком номенклатуры. Управляемое приложение. Разработчик: команда программистов проекта www.new1c.ru. Бесплатная Нашел процедуру с этим названием однако что поменять тут нужно понять не могу подскажите пожалуйста

&НаСервере

Процедура ЗаполнитьПоЗначениямАвтозаполнения(НовДок, ДанныеЗаполнения = Неопределено)

ЕстьДанныеЗаполнения = (НЕ ДанныеЗаполнения = Неопределено);
ДанныеЗаполненияСтруктура = (ТипЗнч(ДанныеЗаполнения) = Тип("Структура"));

Если Не ЕстьДанныеЗаполнения Или ДанныеЗаполненияСтруктура И НЕ ДанныеЗаполнения.Свойство("ДокументОснование") Тогда
    // Заполним основные свойства
    СвойстваАвтозаполнения = Новый Структура("Организация, Склад, ХозяйственнаяОперация");
    СтрокаКлючиСтруктуры = СокрЛП(ОбменДаннымиСобытия.КлючиСтруктурыВСтроку(СвойстваАвтозаполнения));

    Если ДанныеЗаполненияСтруктура Тогда
        ЗаполнитьЗначенияСвойств(СвойстваАвтозаполнения, ДанныеЗаполнения);
    КонецЕсли;

    ОбщегоНазначенияУТ.ЗаполнитьЗначенияСвойствАвтозаполнения(НовДок.Ссылка, СвойстваАвтозаполнения);

    ЗаполнитьЗначенияСвойств(НовДок, СвойстваАвтозаполнения, СтрокаКлючиСтруктуры);

    // Заполним банковский счет и кассу в зависимости от организации
    СвойстваАвтозаполнения = Новый Структура("Организация, БанковскийСчетОрганизации", НовДок.Организация);
    СтрокаКлючиСтруктуры = СокрЛП(ОбменДаннымиСобытия.КлючиСтруктурыВСтроку(СвойстваАвтозаполнения));

    Если ДанныеЗаполненияСтруктура Тогда
        ЗаполнитьЗначенияСвойств(СвойстваАвтозаполнения, ДанныеЗаполнения);
    КонецЕсли;

    ОбщегоНазначенияУТ.ЗаполнитьЗначенияСвойствАвтозаполнения(НовДок.Ссылка, СвойстваАвтозаполнения);

    ЗаполнитьЗначенияСвойств(НовДок, СвойстваАвтозаполнения, СтрокаКлючиСтруктуры);

КонецЕсли;

КонецПроцедуры

 2847 1
ДобавленоAkcent581 день назад
Последняя активность581 день назад


Добавить комментарий

Кирилл написал:581 день назад0

Просто в последней версии УТ они переименовали или перенесли процедуру “ЗаполнитьЗначенияСвойствАвтозаполнения” в другой модуль.

Попробуйте глобальный поиском по модулям поискать по названию - скорее всего найдете.

P.S не удаляйте свои темы, это скорее всего может пригодится и другим людям. спасибо.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Почтовый менеджер, заполнение текста письма по шаблону

Используем 1С CRM 2.0. В почтовом менеджере при создании (ответе и пересылке) пи...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Заполнение табличной части на тонком клиенте

Добрый день. Мне нужно в табличной части выбрать документ определенный, а потом ...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

ручные проводки в НУ

Добрый день, Организация на ОСНО с 2016 года в январе 2016 года поступили на р/с...

Главное меню

Подскажите пожалуйста, у меня в главном меню куда исчезло меню Отчеты ( не значк...

Ищем программиста 1С в штат г.Москва

Доработка конфигурации 1С 8 Континент страхование на базе Бухгалтерии КОРП Созда...

Остатки товаров: настройка отчета

Добрый день! Подскажите пожалуйста по настройкам отчета: когда-то давно работала...

Ищем программиста 1С 8.2 в штат ( г. Киев)

Доброе утро, форумчане! Очень нужен грамотный программист 1С в штат, будем серье...