0

Как зарегистрировать внешнюю печатную форму в 1С 8.3?

#1С 8.3#1С Управление торговлей 11.1#Управляемые формы

Народ, я не очень знаком с программой 1С 8.3 и с программированием на управляемых формах тоже. Подскажите, как зарегистрировать и подключить к документу печатную форму?

 3115 2
ДобавленоПетр870 дней назад
Последняя активность584 дня назад


Добавить комментарий

user140928750315 написал:869 дней назад0

Для регистрации печатной формы в конфигурациях 1С на управляемых формах(в частности УТ 11, ЗУП 3.0, Бухгалтерия 3.0) в модуле печатной формы должна находится специальная функция СведенияОВнешнейОбработке(). Ее название говорит само за себя. Выглядеть это должно примерно так( примечание: Документ - реквизит внешней печатной формы, тип ссылка на документ для которого предназначена впф):

Функция СведенияОВнешнейОбработке() Экспорт

    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;

    Наименование = УказатьНаименованиеВнешнейПечатнойФормы();

    МассивНазначений.Добавить(ПолучитьМетаданныеДокументаПечати());
    //может быть - ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов... 
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); 
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
    ПараметрыРегистрации.Вставить("Наименование", Наименование);
    ПараметрыРегистрации.Вставить("Версия", "1.1");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
    //так будет выглядеть описание печ.формы для пользователя
    ПараметрыРегистрации.Вставить("Информация", УказатьНаименованиеВнешнейПечатнойФормыДляПользователя());

    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    //ДобавитьКоманду(ТаблицаКоманд, Наименование, УказатьНаименованиеКомандыПечати(), "ОткрытиеФормы", Истина, "форма1");
    ДобавитьКоманду(ТаблицаКоманд, Наименование, УказатьНаименованиеКомандыПечати(), "ВызовКлиентскогоМетода", Истина, "ПечатьMXL");

    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

    Возврат ПараметрыРегистрации;

КонецФункции

Функция УказатьНаименованиеВнешнейПечатнойФормы() Экспорт
    Наименование = "Печатная форма к документу " + Документ.Метаданные().Синоним;
    Возврат Наименование;
КонецФункции

Функция ПолучитьМетаданныеДокументаПечати()
    ПолноеИмя = Документ.Метаданные().ПолноеИмя();
    Возврат ПолноеИмя;
КонецФункции

Функция УказатьНаименованиеВнешнейПечатнойФормыДляПользователя()
    Наименование = "Дополнительная печатная форма к документу " + ПолучитьМетаданныеДокументаПечати();
    Возврат Наименование;
КонецФункции

Функция УказатьНаименованиеКомандыПечати() Экспорт
    Наименование = "Печать" + "Документа" + Документ.Метаданные().Имя;
    Возврат Наименование;
КонецФункции

Ну а потом просто добавляешь печатную форму в справочник ДополнительныеОтчетыИОбработки

Ответить

Кирилл написал:584 дня назад0

Спасибо! Кратко и лаконично)

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Как подключить печатную форму 1С к документу

Помогите пожалуйста. Конфигурация 1С Бухгалтерия 2.0, как можно подключить к док...

Как вывести печатную форму, из другого документа ?!

Доброе утро ! Есть Документ ЗарплатаКВыплате кнопка [Печать] -> Форма Т-53 Юзер...

Выводить разные данные в печатную форму

Всем добрый день! Возникла задача создавать приложения к договорам ()в форме эл...

v8.3: Как программно сформировать внешнюю печатную форму документа

Имеется обработка в которой есть реквизит Объект.ПрихНакл, в которой хранится сс...

Вывод изображения из справочника номенклатуры во внешнюю печатную форму

Добрый день! Шеф поставил задачу сделать форму Коммерческого предложение с карти...

Новое

Внешний отчет

здравствуйте, подскажите, как создать внешний отчет, для того чтобы вывести инфо...

ручные проводки в НУ

Добрый день, Организация на ОСНО с 2016 года в январе 2016 года поступили на р/с...

Главное меню

Подскажите пожалуйста, у меня в главном меню куда исчезло меню Отчеты ( не значк...

Ищем программиста 1С в штат г.Москва

Доработка конфигурации 1С 8 Континент страхование на базе Бухгалтерии КОРП Созда...

Остатки товаров: настройка отчета

Добрый день! Подскажите пожалуйста по настройкам отчета: когда-то давно работала...