0

Как зарегистрировать внешнюю печатную форму в 1С 8.3?

#1С 8.3#1С Управление торговлей 11.1#Управляемые формы

Народ, я не очень знаком с программой 1С 8.3 и с программированием на управляемых формах тоже. Подскажите, как зарегистрировать и подключить к документу печатную форму?

 3535 2
ДобавленоПетр991 день назад
Последняя активность705 дней назад


Добавить комментарий

user140928750315 написал:990 дней назад0

Для регистрации печатной формы в конфигурациях 1С на управляемых формах(в частности УТ 11, ЗУП 3.0, Бухгалтерия 3.0) в модуле печатной формы должна находится специальная функция СведенияОВнешнейОбработке(). Ее название говорит само за себя. Выглядеть это должно примерно так( примечание: Документ - реквизит внешней печатной формы, тип ссылка на документ для которого предназначена впф):

Функция СведенияОВнешнейОбработке() Экспорт

    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;

    Наименование = УказатьНаименованиеВнешнейПечатнойФормы();

    МассивНазначений.Добавить(ПолучитьМетаданныеДокументаПечати());
    //может быть - ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов... 
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); 
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
    ПараметрыРегистрации.Вставить("Наименование", Наименование);
    ПараметрыРегистрации.Вставить("Версия", "1.1");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
    //так будет выглядеть описание печ.формы для пользователя
    ПараметрыРегистрации.Вставить("Информация", УказатьНаименованиеВнешнейПечатнойФормыДляПользователя());

    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    //ДобавитьКоманду(ТаблицаКоманд, Наименование, УказатьНаименованиеКомандыПечати(), "ОткрытиеФормы", Истина, "форма1");
    ДобавитьКоманду(ТаблицаКоманд, Наименование, УказатьНаименованиеКомандыПечати(), "ВызовКлиентскогоМетода", Истина, "ПечатьMXL");

    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

    Возврат ПараметрыРегистрации;

КонецФункции

Функция УказатьНаименованиеВнешнейПечатнойФормы() Экспорт
    Наименование = "Печатная форма к документу " + Документ.Метаданные().Синоним;
    Возврат Наименование;
КонецФункции

Функция ПолучитьМетаданныеДокументаПечати()
    ПолноеИмя = Документ.Метаданные().ПолноеИмя();
    Возврат ПолноеИмя;
КонецФункции

Функция УказатьНаименованиеВнешнейПечатнойФормыДляПользователя()
    Наименование = "Дополнительная печатная форма к документу " + ПолучитьМетаданныеДокументаПечати();
    Возврат Наименование;
КонецФункции

Функция УказатьНаименованиеКомандыПечати() Экспорт
    Наименование = "Печать" + "Документа" + Документ.Метаданные().Имя;
    Возврат Наименование;
КонецФункции

Ну а потом просто добавляешь печатную форму в справочник ДополнительныеОтчетыИОбработки

Ответить

Кирилл написал:705 дней назад0

Спасибо! Кратко и лаконично)

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Как подключить печатную форму 1С к документу

Помогите пожалуйста. Конфигурация 1С Бухгалтерия 2.0, как можно подключить к док...

Как вывести печатную форму, из другого документа ?!

Доброе утро ! Есть Документ ЗарплатаКВыплате кнопка [Печать] -> Форма Т-53 Юзер...

v8.3: Как программно сформировать внешнюю печатную форму документа

Имеется обработка в которой есть реквизит Объект.ПрихНакл, в которой хранится сс...

Вывод изображения из справочника номенклатуры во внешнюю печатную форму

Добрый день! Шеф поставил задачу сделать форму Коммерческого предложение с карти...

Помогите сделать внешнюю печатную форму ТОРГ-13

Пытаюсь программировать в 1с недавно, опыта нет. По полученным из интернета инс...

Новое

Срочно! Нижний Новгород! Нужен опытный программист 1С

Крупная и развивающаяся кампания находится в поисках Программиста 1С (Финансовы...

Бюджетирование - статьи бюджета по произвольным данным

Помогите, пожалуйста! Создаю статью бюджета с произвольными данными. Загружаю с...

егаис

Добрый вечер. Прошу Вас помочь. Для получения накладных от производителя делаю з...

Концептуальная модель (инфологическая) распределенной БД

Очень нужна ваша помощь. Создала распределенную 1С БД( хоть она и не распределен...

Где находится анткетирование клиентов в УТ 11?

Подскажите где почитать про анкетирование в УТ. Нужно изучить как оно устроено....