1

Как вызвать программно команду расположенную на Форме?

#Управляемые формы

Есть расположенная на форме новая команда ,как её вызвать программно из модуля формы? Перерыл интернет,не нашел четкого объяснения или кода .

 3097 1
ДобавленоAlexGaren318 дней назад
Последняя активность315 дней назад


Добавить комментарий

Аноним написал:315 дней назад0

Просто вызови процедуру команды, подставив в параметры команду или кнопку.

Для управляемой формы:

Процедура ВызватьКоманду() ИмяНужнойКоманды = “ИмяКомандыФормы”; // Тут просто имя команды как в конфигураторе. НужнаяКоманда = ЭтаФорма.Команды.Найти(ИмяНужнойКоманды); // Находим команду на форме КакаяТоКоманда(НужнаяКоманда); // Вызываем нужную команду, подставив ее в параметры КонецПроцедуры

Процедура КакаяТоКоманда(Команда) // Тут код твоей команды. КонецПроцедуры

Для обычной формы Процедура ВызватьКоманду() ИмяНужнойКнопки = “ИмяКнопкиФормы”; // Тут просто имя команды как в конфигураторе. НужнаяКнопка = ЭтаФорма.ЭлементыФормы.ОсновныеДействияФормы.Кнопки[ИмяНужнойКнопки]; КакаяТоКоманда(НужнаяКнопка); // Вызываем нужную команду, подставив ее в параметры КонецПроцедуры

Процедура КакаяТоКоманда(Кнопка) // Тут код твоей команды. КонецПроцедуры

В принципе, можешь и не заморачиваться с кнопками и командами, если они не обрабатываются в коде. Хотя что мешает вообще вынести код команды в процедуру и вызывать ее сколько влезет? :)

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Получить макет в управляемой форме 1С

Ребята, такой вопрос мне из формы обработки необходимо получить макет, но не пол...

Создание реквизита в управляемой форме 1С

Подскажите, как в 1С можно программно создать реквизит и элемент управляемой фор...

Отбор по значению в форме списка справочника 1с

Есть Справочник с реквизитом Пользователь, как при открытии формы сделать отбор ...

логотип в печатной форме

Ребята помогите пожалуйста, я сделал логотип для печатной формы, дела в том что ...

v8.3: Как программно сформировать внешнюю печатную форму документа

Имеется обработка в которой есть реквизит Объект.ПрихНакл, в которой хранится сс...

Новое

Расчет районного коэффициента в больничном листе

Добрый день! Очень нужна помощь! При расчете б/л не верно считает положительную ...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Возврат по картам по зарплате, в случае изменения реквизитов банка

По карте была перечислена зарплата, но платеж вернулся (изменились реквизиты бан...

Составление отчета

Здравствуйте!! Нужна помощь !!! что означает Ошибка получения информации набора ...

Не могу активировать настройку

Добрый день, скачал учебную версию 8.3 Захотел внести изменения в конфигурацию З...