1

Как вызвать программно команду расположенную на Форме?

#Управляемые формы

Есть расположенная на форме новая команда ,как её вызвать программно из модуля формы? Перерыл интернет,не нашел четкого объяснения или кода .

 1650 1
ДобавленоAlexGaren216 дней назад
Последняя активность212 дней назад


Добавить комментарий

Аноним написал:212 дней назад0

Просто вызови процедуру команды, подставив в параметры команду или кнопку.

Для управляемой формы:

Процедура ВызватьКоманду() ИмяНужнойКоманды = “ИмяКомандыФормы”; // Тут просто имя команды как в конфигураторе. НужнаяКоманда = ЭтаФорма.Команды.Найти(ИмяНужнойКоманды); // Находим команду на форме КакаяТоКоманда(НужнаяКоманда); // Вызываем нужную команду, подставив ее в параметры КонецПроцедуры

Процедура КакаяТоКоманда(Команда) // Тут код твоей команды. КонецПроцедуры

Для обычной формы Процедура ВызватьКоманду() ИмяНужнойКнопки = “ИмяКнопкиФормы”; // Тут просто имя команды как в конфигураторе. НужнаяКнопка = ЭтаФорма.ЭлементыФормы.ОсновныеДействияФормы.Кнопки[ИмяНужнойКнопки]; КакаяТоКоманда(НужнаяКнопка); // Вызываем нужную команду, подставив ее в параметры КонецПроцедуры

Процедура КакаяТоКоманда(Кнопка) // Тут код твоей команды. КонецПроцедуры

В принципе, можешь и не заморачиваться с кнопками и командами, если они не обрабатываются в коде. Хотя что мешает вообще вынести код команды в процедуру и вызывать ее сколько влезет? :)

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Получить макет в управляемой форме 1С

Ребята, такой вопрос мне из формы обработки необходимо получить макет, но не пол...

Создание реквизита в управляемой форме 1С

Подскажите, как в 1С можно программно создать реквизит и элемент управляемой фор...

Отбор по значению в форме списка справочника 1с

Есть Справочник с реквизитом Пользователь, как при открытии формы сделать отбор ...

логотип в печатной форме

Ребята помогите пожалуйста, я сделал логотип для печатной формы, дела в том что ...

v8.3: Как программно сформировать внешнюю печатную форму документа

Имеется обработка в которой есть реквизит Объект.ПрихНакл, в которой хранится сс...

Новое

бисер

пандораПандора прелестиПандора браслет [b]пандора[/b][b][url=http://www.pandorab...

Réplicas de relojes

[b][url=http://es.brandnamewatches.co/]réplica de relojes de alta calidad para l...

Поддельный Lady-Datejust Ролекс

Rolexчасы Rolexподдельный Rolex часы [b][url=http://www.rolexmens.top/ru/]Rolex[...

High Quality Replica Watches,Fake Watches Sale At Lowest Price

Омега реплика Омега реплика [b][url=http://www.bugtalk.us/ru/]высокое качество р...

Серия Hublot Big Bang

Hublot женские часы Hublot часы продажа [b][url=http://www.hublotmenswatches.top...