1

Как вызвать программно команду расположенную на Форме?

#Управляемые формы

Есть расположенная на форме новая команда ,как её вызвать программно из модуля формы? Перерыл интернет,не нашел четкого объяснения или кода .

 2722 1
ДобавленоAlexGaren293 дня назад
Последняя активность290 дней назад


Добавить комментарий

Аноним написал:290 дней назад0

Просто вызови процедуру команды, подставив в параметры команду или кнопку.

Для управляемой формы:

Процедура ВызватьКоманду() ИмяНужнойКоманды = “ИмяКомандыФормы”; // Тут просто имя команды как в конфигураторе. НужнаяКоманда = ЭтаФорма.Команды.Найти(ИмяНужнойКоманды); // Находим команду на форме КакаяТоКоманда(НужнаяКоманда); // Вызываем нужную команду, подставив ее в параметры КонецПроцедуры

Процедура КакаяТоКоманда(Команда) // Тут код твоей команды. КонецПроцедуры

Для обычной формы Процедура ВызватьКоманду() ИмяНужнойКнопки = “ИмяКнопкиФормы”; // Тут просто имя команды как в конфигураторе. НужнаяКнопка = ЭтаФорма.ЭлементыФормы.ОсновныеДействияФормы.Кнопки[ИмяНужнойКнопки]; КакаяТоКоманда(НужнаяКнопка); // Вызываем нужную команду, подставив ее в параметры КонецПроцедуры

Процедура КакаяТоКоманда(Кнопка) // Тут код твоей команды. КонецПроцедуры

В принципе, можешь и не заморачиваться с кнопками и командами, если они не обрабатываются в коде. Хотя что мешает вообще вынести код команды в процедуру и вызывать ее сколько влезет? :)

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Получить макет в управляемой форме 1С

Ребята, такой вопрос мне из формы обработки необходимо получить макет, но не пол...

Создание реквизита в управляемой форме 1С

Подскажите, как в 1С можно программно создать реквизит и элемент управляемой фор...

Отбор по значению в форме списка справочника 1с

Есть Справочник с реквизитом Пользователь, как при открытии формы сделать отбор ...

логотип в печатной форме

Ребята помогите пожалуйста, я сделал логотип для печатной формы, дела в том что ...

v8.3: Как программно сформировать внешнюю печатную форму документа

Имеется обработка в которой есть реквизит Объект.ПрихНакл, в которой хранится сс...

Новое

2 НДФЛ и 6 НДФЛ

Добрый день! Получили процентный займ от учредителя, который не является работни...

Слияние двух баз 1 С8.3

Уважаемые партнеры, коллеги. У меня возникла необходимость в слиянии двух баз, в...

Ищем разработчика 1С на ЗУП 3.0 (Москва)

За подробностями Вы можете писать на почту alina.stogina@hays.ru!...

Перенос БГУ 1.0->БГУ 2.0 Счет 303 учет по ИФО

Всем привет! После переноса данных из 1.0 в 2.0 формирую общие оборотки и вижу, ...

Помогите сделать внешнюю печатную форму ТОРГ-13

Пытаюсь программировать в 1с недавно, опыта нет. По полученным из интернета инс...