1

Как получить результат запроса

#1С 8.3

Функция не выводит результат. Мне нужно получить код (1 значение), но у меня не выходит. Я новичок в 1С направьте меня. Делаю так:

    &НаСервере
    Функция ПоискНомера (ИмяУслуги,ОбъектУчета)
            Запрос = Новый Запрос;
            Запрос.Текст = " ВЫБРАТЬ
                 | икИндивидуальныеПриборыУчета.Код ИЗ Справочник.икИндивидуальныеПриборыУчета КАК икИндивидуальныеПриборыУчета
                 | ГДЕ икИндивидуальныеПриборыУчета.Владелец=&ОбъектУчета и икИндивидуальныеПриборыУчета.Наименование=&Имя";
            Запрос.УстановитьПараметр("ОбъектУчета",ОбъектУчета);
            Запрос.УстановитьПараметр("Имя",ИмяУслуги);
            Результат = Запрос.Выполнить().Выбрать(); //.Выгрузить();
            Справочники.икИндивидуальныеПриборыУчета.ПолучитьДанныеВыбора(Результат.Выбрать());
            Возврат Результат();

        КонецФункции

    &НаСервере
        Процедура ПоискНомераНаСервере()
            Номер = ПоискНомера(ИмяУслуги,ОбъектУчета);
            Сообщить(Номер);
        КонецПроцедуры

    &НаКлиенте
        Процедура ПоискНомера1(Команда)
            ПоискНомераНаСервере();
        КонецПроцедуры
 1904 1
Добавленоmaestro479 дней назад
Отредактировано479 дней назад


Добавить комментарий

Кирилл написал:479 дней назад0

Если в запросе с условиями не напутали, то так:

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий() Тогда
Возврат Результат.Код;
Иначе 
Возврат "";
КонецЕсли;

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Как получить значение реквизита формы и передать его в запрос 1С

Задача: при открытии элемента справочника нужно получить значение поля Код этого...

Результат запроса

Здравствуйте, я начинающий программист 1с, из опыта толлько делфи7 больше 10 лет...

Не выводится внешний отчёт с управляемой формой.

Всем доброго дня! Подскажите, пожалуйста, пытаюсь добавить в Розницу 2.1 внешний...

Помогите найти косяк

&НаСервере Функция ПолучитьФиоДанные(Фио) запрос = новый Запрос; Запрос....

Достать значение с табличного поля

Доброго дня! Платформа 8.3 Толстый клиент. УТ 10.3 Подскажите в каком направлени...

Новое

Tiffany -Sets: Tiffany Outlet

Tiffany Steckdose online Tiffany Steckdose online [b][url=http://www.jewelries-s...

Replica Watches Taghuer

[b]beste Replik Schweizer Uhren[/b] [b][url=http://www.menwatches.com.cn/de/]bes...

Top-Qualität Replik Schweizer Breguet-Uhren online.

[b][url=http://de.watchreplicaonline.me/]qualitativ hochwertigen Uhren Replika[/...

Hublot-Uhren, Big Bang-Serie

hublot uhren outlet store hublot uhren outlet store [b][url=http://de.hublotwatc...

1С: Бухгалтерию 8.2 дёшево

Программа 1С: Бухгалетрия 8.2 По поводу приобретения программы обращайтесь на по...