1

Как получить результат запроса

#1С 8.3

Функция не выводит результат. Мне нужно получить код (1 значение), но у меня не выходит. Я новичок в 1С направьте меня. Делаю так:

    &НаСервере
    Функция ПоискНомера (ИмяУслуги,ОбъектУчета)
            Запрос = Новый Запрос;
            Запрос.Текст = " ВЫБРАТЬ
                 | икИндивидуальныеПриборыУчета.Код ИЗ Справочник.икИндивидуальныеПриборыУчета КАК икИндивидуальныеПриборыУчета
                 | ГДЕ икИндивидуальныеПриборыУчета.Владелец=&ОбъектУчета и икИндивидуальныеПриборыУчета.Наименование=&Имя";
            Запрос.УстановитьПараметр("ОбъектУчета",ОбъектУчета);
            Запрос.УстановитьПараметр("Имя",ИмяУслуги);
            Результат = Запрос.Выполнить().Выбрать(); //.Выгрузить();
            Справочники.икИндивидуальныеПриборыУчета.ПолучитьДанныеВыбора(Результат.Выбрать());
            Возврат Результат();

        КонецФункции

    &НаСервере
        Процедура ПоискНомераНаСервере()
            Номер = ПоискНомера(ИмяУслуги,ОбъектУчета);
            Сообщить(Номер);
        КонецПроцедуры

    &НаКлиенте
        Процедура ПоискНомера1(Команда)
            ПоискНомераНаСервере();
        КонецПроцедуры
 2776 1
Добавленоmaestro620 дней назад
Отредактировано620 дней назад


Добавить комментарий

Кирилл написал:620 дней назад0

Если в запросе с условиями не напутали, то так:

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий() Тогда
Возврат Результат.Код;
Иначе 
Возврат "";
КонецЕсли;

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Как получить значение реквизита формы и передать его в запрос 1С

Задача: при открытии элемента справочника нужно получить значение поля Код этого...

Результат запроса

Здравствуйте, я начинающий программист 1с, из опыта толлько делфи7 больше 10 лет...

Не выводится внешний отчёт с управляемой формой.

Всем доброго дня! Подскажите, пожалуйста, пытаюсь добавить в Розницу 2.1 внешний...

Помогите найти косяк

&НаСервере Функция ПолучитьФиоДанные(Фио) запрос = новый Запрос; Запрос....

Достать значение с табличного поля

Доброго дня! Платформа 8.3 Толстый клиент. УТ 10.3 Подскажите в каком направлени...

Новое

реплики Longines часы, longinesladieswatchesuk.top

[b][url=http://www.longinesladieswatchesuk.top/ru/]часы Longines в великобритани...

не могу обновить 1с 8.2

Здравствуйте! подскажите как можно решить проблему с обновлением 1 с 8.2 базовая...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Справочник

Здравствуйте, подскажите пожалуйста, хочу сделать, чтобы при выборе в справочник...

Большой видеоархив по платформам 1С 8.2 и 8.3. Пользователям и разработчикам

Всем привет! Добротный канал для обучения с регулярным добавлением видеокурсов: ...