1

Как получить результат запроса

#1С 8.3

Функция не выводит результат. Мне нужно получить код (1 значение), но у меня не выходит. Я новичок в 1С направьте меня. Делаю так:

    &НаСервере
    Функция ПоискНомера (ИмяУслуги,ОбъектУчета)
            Запрос = Новый Запрос;
            Запрос.Текст = " ВЫБРАТЬ
                 | икИндивидуальныеПриборыУчета.Код ИЗ Справочник.икИндивидуальныеПриборыУчета КАК икИндивидуальныеПриборыУчета
                 | ГДЕ икИндивидуальныеПриборыУчета.Владелец=&ОбъектУчета и икИндивидуальныеПриборыУчета.Наименование=&Имя";
            Запрос.УстановитьПараметр("ОбъектУчета",ОбъектУчета);
            Запрос.УстановитьПараметр("Имя",ИмяУслуги);
            Результат = Запрос.Выполнить().Выбрать(); //.Выгрузить();
            Справочники.икИндивидуальныеПриборыУчета.ПолучитьДанныеВыбора(Результат.Выбрать());
            Возврат Результат();

        КонецФункции

    &НаСервере
        Процедура ПоискНомераНаСервере()
            Номер = ПоискНомера(ИмяУслуги,ОбъектУчета);
            Сообщить(Номер);
        КонецПроцедуры

    &НаКлиенте
        Процедура ПоискНомера1(Команда)
            ПоискНомераНаСервере();
        КонецПроцедуры
 2466 1
Добавленоmaestro565 дней назад
Отредактировано565 дней назад


Добавить комментарий

Кирилл написал:565 дней назад0

Если в запросе с условиями не напутали, то так:

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий() Тогда
Возврат Результат.Код;
Иначе 
Возврат "";
КонецЕсли;

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Как получить значение реквизита формы и передать его в запрос 1С

Задача: при открытии элемента справочника нужно получить значение поля Код этого...

Результат запроса

Здравствуйте, я начинающий программист 1с, из опыта толлько делфи7 больше 10 лет...

Не выводится внешний отчёт с управляемой формой.

Всем доброго дня! Подскажите, пожалуйста, пытаюсь добавить в Розницу 2.1 внешний...

Помогите найти косяк

&НаСервере Функция ПолучитьФиоДанные(Фио) запрос = новый Запрос; Запрос....

Достать значение с табличного поля

Доброго дня! Платформа 8.3 Толстый клиент. УТ 10.3 Подскажите в каком направлени...

Новое

Справочник статьи движения денежных средств

Добрый день. Подскажите, пожалуйста, почему у меня маленький справочник ДДС? Все...

Помогите сделать внешнюю печатную форму ТОРГ-13

Пытаюсь программировать в 1с недавно, опыта нет. По полученным из интернета инс...

2 НДФЛ и 6 НДФЛ

Добрый день! Получили процентный займ от учредителя, который не является работни...

Слияние двух баз 1 С8.3

Уважаемые партнеры, коллеги. У меня возникла необходимость в слиянии двух баз, в...

Перенос БГУ 1.0->БГУ 2.0 Счет 303 учет по ИФО

Всем привет! После переноса данных из 1.0 в 2.0 формирую общие оборотки и вижу, ...