0

Как получить кпс счета в 1С 8.3?

#1С 8.3

Делаю ВПФ для РКО мне нужно получить кпс кредита по счету 201.4(касса) , реквизита такого в документе нет, там сделано все через типовую операцию а от туда программно ни как не подтянешь, но есть функция кпссчета но через нее что то не получается вот функция Функция КПССчета(Организация, Знач ИФО = Неопределено, КФО, Период, Счет, ВидПоказателя = Неопределено) Экспорт

Если НЕ ПолучитьФункциональнуюОпцию("ИспользоватьУчетПоИФО") Тогда
    ИФО = Справочники.ИсточникиФинансовогоОбеспечения.ПустаяСсылка();
КонецЕсли;

Запрос = Новый Запрос( "ВЫБРАТЬ ПЕРВЫЕ 1
                        |   РабочиеСчетаСрезПоследних.КПС
                        |ИЗ
                        |   РегистрСведений.РабочиеСчета.СрезПоследних(
                        |           &Период,
                        |           Актуален = ИСТИНА
                        |               И Организация = &Организация
                        |               И КФО = &КФО
                        |               И Счет = &Счет
                        |               <ВидПоказателя>
                        |               И &УсловиеИФО) КАК РабочиеСчетаСрезПоследних");

Запрос.УстановитьПараметр("Период",       Период);
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("КФО",             КФО);
Запрос.УстановитьПараметр("Счет",           Счет);

Если ЗначениеЗаполнено(ИФО) Тогда

    Запрос.Текст = СтрЗаменить(Запрос.Текст, "&УсловиеИФО", "ИФО = &ИФО");

    Запрос.УстановитьПараметр("ИФО",         ИФО);

Иначе

    Запрос.УстановитьПараметр("УсловиеИФО", Истина);

КонецЕсли;

Если ВидПоказателя = Неопределено Тогда
    ВидПоказателяТекст = "";
Иначе
    ВидПоказателяТекст = "И КПС.ВидПоказателя В (&ВидПоказателя)";
    Если ТипЗнч(ВидПоказателя) = Тип("ПеречислениеСсылка.ВидыКБК") Тогда
        // Указано одно значение.
        ЗначениеПараметраВидПоказателя = ВидПоказателя;

    ИначеЕсли ТипЗнч(ВидПоказателя) = Тип("Структура") Тогда
        // Указано несколько значений.
        ЗначениеПараметраВидПоказателя = Новый Массив();
        Для Каждого Элем Из ВидПоказателя Цикл
            ЗначениеПараметраВидПоказателя.Добавить(Элем.Значение);
        КонецЦикла;

    Иначе
        ЗначениеПараметраВидПоказателя = Неопределено;
    КонецЕсли;
    Запрос.УстановитьПараметр("ВидПоказателя", ЗначениеПараметраВидПоказателя);

КонецЕсли;
Запрос.Текст = СтрЗаменить(Запрос.Текст, "<ВидПоказателя>", ВидПоказателяТекст);

Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Следующий() Тогда

    Возврат Выборка.КПС;

Иначе

    Возврат Справочники.КлассификационныеПризнакиСчетов.ПустаяСсылка();

КонецЕсли;

КонецФункции

если кто знает как можно получить это значение?

 1319 2
ДобавленоАлександр1906596 дней назад
Отредактировано549 дней назад


Добавить комментарий

Кирилл написал:596 дней назад0

Привет!

Там же написано из какого регистра получается этот КПС:

Запрос = Новый Запрос( "ВЫБРАТЬ ПЕРВЫЕ 1
                        |   РабочиеСчетаСрезПоследних.КПС
                        |ИЗ
                        |   РегистрСведений.РабочиеСчета.СрезПоследних(
                        |           &Период,
                        |           Актуален = ИСТИНА
                        |               И Организация = &Организация
                        |               И КФО = &КФО
                        |               И Счет = &Счет
                        |               <ВидПоказателя>
                        |               И &УсловиеИФО) КАК РабочиеСчетаСрезПоследних");

Запрос.УстановитьПараметр("Период",       Период);
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("КФО",             КФО);
Запрос.УстановитьПараметр("Счет",           Счет);

Какие есть параметры на входе?

Ответить

Александр1906 написал:595 дней назад0

все разобрался уже спасибо за ответ))

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Ошибка при отправке интернет-писем

Конфигурация пустая. Требуется прописать модуль получения и отправки писем. Все ...

Проблема с выводом отчёта в 2 колонки

Добрый день! Необходимо выводить номенклатуру в отчёте в две колонки, столкнулас...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Достать значение с табличного поля

Доброго дня! Платформа 8.3 Толстый клиент. УТ 10.3 Подскажите в каком направлени...

Запрос, возрат поиск документа

Добрый день ребята. Такой вопрос, мне нужно написать запрос. Который бы брал из ...

Новое

Помогите

Надо создать в 1С выдачу пенсий помогите. Мне надо сделать до 17.05.2017г скайп ...

Выгрузка из 1С ЗУП

Всем привет! у меня такой вопрос: в феврале 2017г сотруднице было начислено посо...

Требуется Программист 1С (Нижний Новгород)

Крупная и развивающаяся кампания находится в поисках Программиста 1С (Финансовы...

Требуется программист 1С

Добрый день, Ищу программиста 1С с опытом разработки программных продуктов для с...

Бюджетирование - статьи бюджета по произвольным данным

Помогите, пожалуйста! Создаю статью бюджета с произвольными данными. Загружаю с...