1

Как добавить в обработку выгрузки остатков еще и цену?

#1С 8.2#1С Комплексная автоматизация#Таблица значений#Общий модуль#Конфигуратор

Здравствуйте. Помогите с корректностью обработки формирования остатков. Сейчас есть обработка (кад ниже). Она выгружает Код, Артикул, Наименование и Остаток товара. Вот кусок из обработки:

Процедура СформироватьФайлОстатков()

    ОбновитьОтбор();

    Выборка = ПостроительОтчета.ПолучитьЗапрос().Выполнить().Выбрать();

    Текст = Новый ЗаписьТекста(ИмяФайла);

    Строка = "Код;Артикул;Наименование;Остаток";
    Текст.ЗаписатьСтроку(Строка);

    Пока Выборка.Следующий() Цикл

        Если Не ВыгружатьТоварыСНулевымОстатком И Выборка.Остаток = 0 Тогда
        Продолжить;
        КонецЕсли;


        Строка = Выборка.Код + ";" + СокрЛП(Выборка.Артикул) + ";" + Выборка.Наименование + ";" + Выборка.Остаток;
        Текст.ЗаписатьСтроку(Строка);

    КонецЦикла;

    Текст.Закрыть();
    Предупреждение("Файл остатков сформирован!" );

КонецПроцедуры

Я не программист 1С. Не пинайте, плиз. Появилась необходимость выгружать цены товаров, тоже. Чисто интуитивно попробовал добавить Выборка.Цена вот так: Строка = Выборка.Код + ";" + СокрЛП(Выборка.Артикул) + ";" + Выборка.Наименование + ";" + Выборка.Остаток + ";" Выборка.Цена; При выгрузке пишет, что Поле Цена не обнаружено. ТипЦен=Магазин (если это где-то необходимо прописывать). Заранее, благодарю. P.S. В приложеннии сам файл обработки.

 1766 1
Добавленоvlados196 дней назад
Последняя активность179 дней назад


Добавить комментарий

Кирилл написал:179 дней назад0

Нет, тут так просто не прокатит, к сожалению…

Нужно добавить в текст построителя отчета соединение с таблицей цен на нужную дату и добавить поле “цена”. А там уже можно будет сделать как вы написали - Выборка.Цена.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Ошибка при отправке интернет-писем

Конфигурация пустая. Требуется прописать модуль получения и отправки писем. Все ...

Не могу программно сформировать типовой отчет

Пытаюсь из внешней обработки программно сформировать типовой отчет и вывести рез...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Ссылка на документ в форму обработки внешней печатной формы.

Добрый день. Помогите новичку. Была задача написать для ERP внешнюю печатную фор...

Новое

Концептуальная модель (инфологическая) распределенной БД

Очень нужна ваша помощь. Создала распределенную 1С БД( хоть она и не распределен...

Где находится анткетирование клиентов в УТ 11?

Подскажите где почитать про анкетирование в УТ. Нужно изучить как оно устроено....

беда :(

Добрый день, Помогите разобраться, пжл. По неизвестным причинам с помощью моих в...

постоянное изменение макета

Добрый день! Подскажите по такой ситуации: есть небольшой макет этикетки, в нем,...

НДФЛ при выплате аванса

Добрый день! Подскажите пожалуйста, как сделать чтобы в зуп 3.0 как при выплате ...