1

Как добавить в обработку выгрузки остатков еще и цену?

#1С 8.2#1С Комплексная автоматизация#Таблица значений#Общий модуль#Конфигуратор

Здравствуйте. Помогите с корректностью обработки формирования остатков. Сейчас есть обработка (кад ниже). Она выгружает Код, Артикул, Наименование и Остаток товара. Вот кусок из обработки:

Процедура СформироватьФайлОстатков()

    ОбновитьОтбор();

    Выборка = ПостроительОтчета.ПолучитьЗапрос().Выполнить().Выбрать();

    Текст = Новый ЗаписьТекста(ИмяФайла);

    Строка = "Код;Артикул;Наименование;Остаток";
    Текст.ЗаписатьСтроку(Строка);

    Пока Выборка.Следующий() Цикл

        Если Не ВыгружатьТоварыСНулевымОстатком И Выборка.Остаток = 0 Тогда
        Продолжить;
        КонецЕсли;


        Строка = Выборка.Код + ";" + СокрЛП(Выборка.Артикул) + ";" + Выборка.Наименование + ";" + Выборка.Остаток;
        Текст.ЗаписатьСтроку(Строка);

    КонецЦикла;

    Текст.Закрыть();
    Предупреждение("Файл остатков сформирован!" );

КонецПроцедуры

Я не программист 1С. Не пинайте, плиз. Появилась необходимость выгружать цены товаров, тоже. Чисто интуитивно попробовал добавить Выборка.Цена вот так: Строка = Выборка.Код + ";" + СокрЛП(Выборка.Артикул) + ";" + Выборка.Наименование + ";" + Выборка.Остаток + ";" Выборка.Цена; При выгрузке пишет, что Поле Цена не обнаружено. ТипЦен=Магазин (если это где-то необходимо прописывать). Заранее, благодарю. P.S. В приложеннии сам файл обработки.

 1699 1
Добавленоvlados135 дней назад
Последняя активность119 дней назад


Добавить комментарий

Кирилл написал:119 дней назад0

Нет, тут так просто не прокатит, к сожалению…

Нужно добавить в текст построителя отчета соединение с таблицей цен на нужную дату и добавить поле “цена”. А там уже можно будет сделать как вы написали - Выборка.Цена.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Ошибка при отправке интернет-писем

Конфигурация пустая. Требуется прописать модуль получения и отправки писем. Все ...

Не могу программно сформировать типовой отчет

Пытаюсь из внешней обработки программно сформировать типовой отчет и вывести рез...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Ссылка на документ в форму обработки внешней печатной формы.

Добрый день. Помогите новичку. Была задача написать для ERP внешнюю печатную фор...

Новое

Расчет районного коэффициента в больничном листе

Добрый день! Очень нужна помощь! При расчете б/л не верно считает положительную ...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Возврат по картам по зарплате, в случае изменения реквизитов банка

По карте была перечислена зарплата, но платеж вернулся (изменились реквизиты бан...

Составление отчета

Здравствуйте!! Нужна помощь !!! что означает Ошибка получения информации набора ...

Не могу активировать настройку

Добрый день, скачал учебную версию 8.3 Захотел внести изменения в конфигурацию З...