1

Как добавить в обработку выгрузки остатков еще и цену?

#1С 8.2#1С Комплексная автоматизация#Таблица значений#Общий модуль#Конфигуратор

Здравствуйте. Помогите с корректностью обработки формирования остатков. Сейчас есть обработка (кад ниже). Она выгружает Код, Артикул, Наименование и Остаток товара. Вот кусок из обработки:

Процедура СформироватьФайлОстатков()

    ОбновитьОтбор();

    Выборка = ПостроительОтчета.ПолучитьЗапрос().Выполнить().Выбрать();

    Текст = Новый ЗаписьТекста(ИмяФайла);

    Строка = "Код;Артикул;Наименование;Остаток";
    Текст.ЗаписатьСтроку(Строка);

    Пока Выборка.Следующий() Цикл

        Если Не ВыгружатьТоварыСНулевымОстатком И Выборка.Остаток = 0 Тогда
        Продолжить;
        КонецЕсли;


        Строка = Выборка.Код + ";" + СокрЛП(Выборка.Артикул) + ";" + Выборка.Наименование + ";" + Выборка.Остаток;
        Текст.ЗаписатьСтроку(Строка);

    КонецЦикла;

    Текст.Закрыть();
    Предупреждение("Файл остатков сформирован!" );

КонецПроцедуры

Я не программист 1С. Не пинайте, плиз. Появилась необходимость выгружать цены товаров, тоже. Чисто интуитивно попробовал добавить Выборка.Цена вот так: Строка = Выборка.Код + ";" + СокрЛП(Выборка.Артикул) + ";" + Выборка.Наименование + ";" + Выборка.Остаток + ";" Выборка.Цена; При выгрузке пишет, что Поле Цена не обнаружено. ТипЦен=Магазин (если это где-то необходимо прописывать). Заранее, благодарю. P.S. В приложеннии сам файл обработки.

 1026 1
Добавленоvlados30 дней назад
Последняя активность13 дней назад


Добавить комментарий

Кирилл написал:13 дней назад0

Нет, тут так просто не прокатит, к сожалению…

Нужно добавить в текст построителя отчета соединение с таблицей цен на нужную дату и добавить поле “цена”. А там уже можно будет сделать как вы написали - Выборка.Цена.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Ошибка при отправке интернет-писем

Конфигурация пустая. Требуется прописать модуль получения и отправки писем. Все ...

Не могу программно сформировать типовой отчет

Пытаюсь из внешней обработки программно сформировать типовой отчет и вывести рез...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Ссылка на документ в форму обработки внешней печатной формы.

Добрый день. Помогите новичку. Была задача написать для ERP внешнюю печатную фор...

Новое

Ошибка при выгрузке информационной базы

При выгрузке ИБ в конфигураторе возникает ошибка (Запись дампа и “Программа "1cv...

Vendita UGG, Ugg economici Pantofole Stivali Online

ugg boots per le donne ugg boots. [b][url=http://www.uggsmen.top/it/]ugg vendita...

Gioielli Pandora Uscita, Pandora gioielli a buon mercato a Pandora Jewelly deposito

Pandora Bracciali e collane per le donne Bracciali Pandora fai da te con charms ...

Donna Canada Goose Goose Parka Dawson Summit Rosa - €295.74 : orologi replica Omega, canadagooseonsale.top

canada - 2016il canada goosecanada - vest [b][url=http://www.canadagooseonsale.t...