1

Как добавить в обработку выгрузки остатков еще и цену?

#1С 8.2#1С Комплексная автоматизация#Таблица значений#Общий модуль#Конфигуратор

Здравствуйте. Помогите с корректностью обработки формирования остатков. Сейчас есть обработка (кад ниже). Она выгружает Код, Артикул, Наименование и Остаток товара. Вот кусок из обработки:

Процедура СформироватьФайлОстатков()

    ОбновитьОтбор();

    Выборка = ПостроительОтчета.ПолучитьЗапрос().Выполнить().Выбрать();

    Текст = Новый ЗаписьТекста(ИмяФайла);

    Строка = "Код;Артикул;Наименование;Остаток";
    Текст.ЗаписатьСтроку(Строка);

    Пока Выборка.Следующий() Цикл

        Если Не ВыгружатьТоварыСНулевымОстатком И Выборка.Остаток = 0 Тогда
        Продолжить;
        КонецЕсли;


        Строка = Выборка.Код + ";" + СокрЛП(Выборка.Артикул) + ";" + Выборка.Наименование + ";" + Выборка.Остаток;
        Текст.ЗаписатьСтроку(Строка);

    КонецЦикла;

    Текст.Закрыть();
    Предупреждение("Файл остатков сформирован!" );

КонецПроцедуры

Я не программист 1С. Не пинайте, плиз. Появилась необходимость выгружать цены товаров, тоже. Чисто интуитивно попробовал добавить Выборка.Цена вот так: Строка = Выборка.Код + ";" + СокрЛП(Выборка.Артикул) + ";" + Выборка.Наименование + ";" + Выборка.Остаток + ";" Выборка.Цена; При выгрузке пишет, что Поле Цена не обнаружено. ТипЦен=Магазин (если это где-то необходимо прописывать). Заранее, благодарю. P.S. В приложеннии сам файл обработки.

 1745 1
Добавленоvlados173 дня назад
Последняя активность157 дней назад


Добавить комментарий

Кирилл написал:157 дней назад0

Нет, тут так просто не прокатит, к сожалению…

Нужно добавить в текст построителя отчета соединение с таблицей цен на нужную дату и добавить поле “цена”. А там уже можно будет сделать как вы написали - Выборка.Цена.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Ошибка при отправке интернет-писем

Конфигурация пустая. Требуется прописать модуль получения и отправки писем. Все ...

Не могу программно сформировать типовой отчет

Пытаюсь из внешней обработки программно сформировать типовой отчет и вывести рез...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Ссылка на документ в форму обработки внешней печатной формы.

Добрый день. Помогите новичку. Была задача написать для ERP внешнюю печатную фор...

Новое

Как добавить услугу в 1С Розница 2.2

В магазине одежды, помимо товара, есть услуга по подшивке одежды. Можно ли как т...

настройка печатной формы отчета Расчет по страховым взносам

Добрый день, подскажите пожалуйста , из-за чего на титульном листе отчета не печ...

не могу обновить 1с 8.2

Здравствуйте! подскажите как можно решить проблему с обновлением 1 с 8.2 базовая...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Справочник

Здравствуйте, подскажите пожалуйста, хочу сделать, чтобы при выборе в справочник...