1

Как добавить в обработку выгрузки остатков еще и цену?

#1С 8.2#1С Комплексная автоматизация#Таблица значений#Общий модуль#Конфигуратор

Здравствуйте. Помогите с корректностью обработки формирования остатков. Сейчас есть обработка (кад ниже). Она выгружает Код, Артикул, Наименование и Остаток товара. Вот кусок из обработки:

Процедура СформироватьФайлОстатков()

    ОбновитьОтбор();

    Выборка = ПостроительОтчета.ПолучитьЗапрос().Выполнить().Выбрать();

    Текст = Новый ЗаписьТекста(ИмяФайла);

    Строка = "Код;Артикул;Наименование;Остаток";
    Текст.ЗаписатьСтроку(Строка);

    Пока Выборка.Следующий() Цикл

        Если Не ВыгружатьТоварыСНулевымОстатком И Выборка.Остаток = 0 Тогда
        Продолжить;
        КонецЕсли;


        Строка = Выборка.Код + ";" + СокрЛП(Выборка.Артикул) + ";" + Выборка.Наименование + ";" + Выборка.Остаток;
        Текст.ЗаписатьСтроку(Строка);

    КонецЦикла;

    Текст.Закрыть();
    Предупреждение("Файл остатков сформирован!" );

КонецПроцедуры

Я не программист 1С. Не пинайте, плиз. Появилась необходимость выгружать цены товаров, тоже. Чисто интуитивно попробовал добавить Выборка.Цена вот так: Строка = Выборка.Код + ";" + СокрЛП(Выборка.Артикул) + ";" + Выборка.Наименование + ";" + Выборка.Остаток + ";" Выборка.Цена; При выгрузке пишет, что Поле Цена не обнаружено. ТипЦен=Магазин (если это где-то необходимо прописывать). Заранее, благодарю. P.S. В приложеннии сам файл обработки.

 1484 1
Добавленоvlados75 дней назад
Последняя активность59 дней назад


Добавить комментарий

Кирилл написал:59 дней назад0

Нет, тут так просто не прокатит, к сожалению…

Нужно добавить в текст построителя отчета соединение с таблицей цен на нужную дату и добавить поле “цена”. А там уже можно будет сделать как вы написали - Выборка.Цена.

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Ошибка при отправке интернет-писем

Конфигурация пустая. Требуется прописать модуль получения и отправки писем. Все ...

Не могу программно сформировать типовой отчет

Пытаюсь из внешней обработки программно сформировать типовой отчет и вывести рез...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Ссылка на документ в форму обработки внешней печатной формы.

Добрый день. Помогите новичку. Была задача написать для ERP внешнюю печатную фор...

Новое

ручные проводки в НУ

Добрый день, Организация на ОСНО с 2016 года в январе 2016 года поступили на р/с...

Главное меню

Подскажите пожалуйста, у меня в главном меню куда исчезло меню Отчеты ( не значк...

Ищем программиста 1С в штат г.Москва

Доработка конфигурации 1С 8 Континент страхование на базе Бухгалтерии КОРП Созда...

Остатки товаров: настройка отчета

Добрый день! Подскажите пожалуйста по настройкам отчета: когда-то давно работала...

Ищем программиста 1С 8.2 в штат ( г. Киев)

Доброе утро, форумчане! Очень нужен грамотный программист 1С в штат, будем серье...