1

ЭтотОбъект у Регистра сведений 1С

#1С 8.2#Управляемые формы#Регистр сведений

Скажите пожалуйста, как обратиться к объекту регистра сведений? Задача: по значению измерения задать тип ресурса. Пример: если значение измерения “Арендатор”, то из составного типа Значение выбрать только СправочниСсылка.Контрагент Пример, как хотел написать: Если ЭтотОбъект.РеквизитДоговора = “Арендатор” Тогда ТипЗнч(ЭтотОбъект.Значение) = Тип(“СправочникСсылка.Контрагент”); КонецЕсли;

 1878 3
ДобавленоГригорий642 дня назад
Отредактировано640 дней назад


Добавить комментарий

Кирилл написал:642 дня назад0

Это форма записи регистра?

Управляемая форма - надо обращаться как “Запись.Реквизит”.

Ответить

Григорий написал:641 день назад0

да, это форма записи. но запихнуть туда нужный тип по моему примеру выше не получилось. в итоге вышел из ситуации следующим образом:

&НаКлиенте
Процедура РеквизитПриИзменении(Элемент)
    УстановитьТипЗаписи(ЭтаФорма.Запись.Реквизит);
КонецПроцедуры

&НаСервере
Процедура УстановитьТипЗаписи(ВыбранныйТип)
    ТипСтр = ВыбранныйТип.Тип;
    Если ТипСтр = "Строка" Тогда
        ЭтаФорма.Запись.Значение = "";
    ИначеЕсли ТипСтр = "Число" Тогда
        ЭтаФорма.Запись.Значение = 0;
    ИначеЕсли ТипСтр = "Дата" Тогда
        ЭтаФорма.Запись.Значение = Дата('00010101');
    ИначеЕсли Найти(ТипСтр,"СправочникСсылка.") > 0 Тогда
        ТипСтр = СтрЗаменить(ТипСтр,"СправочникСсылка.","");
        ЭтаФорма.Запись.Значение = Справочники[ТипСтр].ПустаяСсылка();
    Иначе
        ЭтаФорма.Запись.Значение = Неопределено;
    КонецЕсли;
КонецПроцедуры

это корректный способ?

Ответить

Кирилл написал:641 день назад0

Если работает, то в виде заглушки пойдет :)

А так бы я посоветовал юзать Элементы.<ИмяЭлементаФормы>.ОграничениеТипа.

Например:

МассивТипов = Новый Массив;
                МассивТипов.Добавить(Тип(<ИмяТипа>));
                Элементы.<ИмяЭлементаФормы>.ОграничениеТипа = Новый ОписаниеТипов(МассивТипов);

Ответить

Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Регистратор у непериодического независимого регистра сведений

Обратил внимание, что у непериодического независимого регистра сведений при созд...

Значение не является значением объектного типа (Количественный)

День Добрый Форумчане! Подскажите плиз такой вопрос у пользователя при открытии ...

Ошибка при записи записи регистра сведений

Доброго времени суток! Установлена ЗУП 3.0. Уважаемые, подскажите, суть проблемы...

Обработка формы списка регистра сведений и заполнение значений в документ

Здравствуйте! Столкнулась с такой проблемой: имеется документ “Запись на занятия...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

"Наряд на хозтранспорт и спецтехнику" Путевые листы

Здравствуйте, Форумчане, прошу вашего совета. В организации такая ситуация: ест...

Создание обработки

Помогите с задачей. Суть такова - нужно создать внешнею обработку которая будет ...

Заполнение раздела 3 Расчет налоговой базы Книги доходов и расходов

Добрый день! Меня зовут Наталья. Про заполнение Кудир в КА очень все хорошо пишу...

Розница 2.2.4 пропал "отчёт ДС по платёжным картам"?

Здравствуйте, возникла проблема после обновления конфигурации до 2.2.4.33 пропал...

Перенаправления значений

1С:Предприятие 8.2 (8.2.19.130) Зарплата и Управление Персоналом, редакция 2.5 (...