1

ЭтотОбъект у Регистра сведений 1С

#1С 8.2#Управляемые формы#Регистр сведений

Скажите пожалуйста, как обратиться к объекту регистра сведений? Задача: по значению измерения задать тип ресурса. Пример: если значение измерения “Арендатор”, то из составного типа Значение выбрать только СправочниСсылка.Контрагент Пример, как хотел написать: Если ЭтотОбъект.РеквизитДоговора = “Арендатор” Тогда ТипЗнч(ЭтотОбъект.Значение) = Тип(“СправочникСсылка.Контрагент”); КонецЕсли;

 2151 3
ДобавленоГригорий749 дней назад
Отредактировано748 дней назад


Добавить комментарий

Кирилл написал:749 дней назад0

Это форма записи регистра?

Управляемая форма - надо обращаться как “Запись.Реквизит”.

Ответить

Григорий написал:748 дней назад0

да, это форма записи. но запихнуть туда нужный тип по моему примеру выше не получилось. в итоге вышел из ситуации следующим образом:

&НаКлиенте
Процедура РеквизитПриИзменении(Элемент)
    УстановитьТипЗаписи(ЭтаФорма.Запись.Реквизит);
КонецПроцедуры

&НаСервере
Процедура УстановитьТипЗаписи(ВыбранныйТип)
    ТипСтр = ВыбранныйТип.Тип;
    Если ТипСтр = "Строка" Тогда
        ЭтаФорма.Запись.Значение = "";
    ИначеЕсли ТипСтр = "Число" Тогда
        ЭтаФорма.Запись.Значение = 0;
    ИначеЕсли ТипСтр = "Дата" Тогда
        ЭтаФорма.Запись.Значение = Дата('00010101');
    ИначеЕсли Найти(ТипСтр,"СправочникСсылка.") > 0 Тогда
        ТипСтр = СтрЗаменить(ТипСтр,"СправочникСсылка.","");
        ЭтаФорма.Запись.Значение = Справочники[ТипСтр].ПустаяСсылка();
    Иначе
        ЭтаФорма.Запись.Значение = Неопределено;
    КонецЕсли;
КонецПроцедуры

это корректный способ?

Ответить

Кирилл написал:748 дней назад0

Если работает, то в виде заглушки пойдет :)

А так бы я посоветовал юзать Элементы.<ИмяЭлементаФормы>.ОграничениеТипа.

Например:

МассивТипов = Новый Массив;
                МассивТипов.Добавить(Тип(<ИмяТипа>));
                Элементы.<ИмяЭлементаФормы>.ОграничениеТипа = Новый ОписаниеТипов(МассивТипов);

Ответить

Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Регистратор у непериодического независимого регистра сведений

Обратил внимание, что у непериодического независимого регистра сведений при созд...

Значение не является значением объектного типа (Количественный)

День Добрый Форумчане! Подскажите плиз такой вопрос у пользователя при открытии ...

Ошибка при записи записи регистра сведений

Доброго времени суток! Установлена ЗУП 3.0. Уважаемые, подскажите, суть проблемы...

Обработка формы списка регистра сведений и заполнение значений в документ

Здравствуйте! Столкнулась с такой проблемой: имеется документ “Запись на занятия...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

Расчет районного коэффициента в больничном листе

Добрый день! Очень нужна помощь! При расчете б/л не верно считает положительную ...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Возврат по картам по зарплате, в случае изменения реквизитов банка

По карте была перечислена зарплата, но платеж вернулся (изменились реквизиты бан...

Составление отчета

Здравствуйте!! Нужна помощь !!! что означает Ошибка получения информации набора ...

Не могу активировать настройку

Добрый день, скачал учебную версию 8.3 Захотел внести изменения в конфигурацию З...