1

Достать значение с табличного поля

#1С Управление торговлей

Доброго дня! Платформа 8.3 Толстый клиент. УТ 10.3 Подскажите в каком направлении копать. Есть номенклатура в ней табличное поле “МестаХранения” в нём есть колонка ячейка, каким образом мне в другом документе “ПриходныйОрдерНаТовары” вывести в новой колонке эту ячейку?

Как то выводит но не правильно, одна и та же ячейка по всем строкам и док. начинает немного тормозить: Вся структура:

Функция МестоХранения(Номенклатура) Экспорт Текст = “ВЫБРАТЬ | ПриходныйОрдерНаТовары.Товары.( | Номенклатура | ), | МестаХраненияНоменклатуры.МестоХранения, | ПриходныйОрдерНаТовары.Склад |ИЗ | Документ.ПриходныйОрдерНаТовары КАК ПриходныйОрдерНаТовары | ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.МестаХраненияНоменклатуры КАК МестаХраненияНоменклатуры | ПО ПриходныйОрдерНаТовары.Склад = МестаХраненияНоменклатуры.Склад | И ПриходныйОрдерНаТовары.Товары.Номенклатура = МестаХраненияНоменклатуры.Номенклатура”;

   Запрос = Новый Запрос;
   Запрос.Текст = Текст;
   Результат = Запрос.Выполнить();

Выборка = Результат.Выбрать(); МестоХранения = ?(Выборка.Следующий(),Выборка.МестоХранения,0); Возврат МестоХранения;

КонецФункции

Процедура ПоказатьМестоХранения(КолонкиТабПоля, ЯчейкиСтрокиТабПоля, Номенклатура) Экспорт Если КолонкиТабПоля.МестоХранения.Видимость Тогда МестоХранения = МестоХранения(Номенклатура); ЯчейкиСтрокиТабПоля.МестоХранения.УстановитьТекст(МестоХранения); Иначе ЯчейкиСтрокиТабПоля.МестоХранения.УстановитьТекст(“”); КонецЕсли; КонецПроцедуры

Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

ПоказатьМестоХранения(мКолонкиТовары, ОформлениеСтроки.Ячейки, ДанныеСтроки.Номенклатура);

КонецПроцедуры

 308 0
ДобавленоПавел55555138 дней назад
Отредактировано73 дня назад


Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Не выводится внешний отчёт с управляемой формой.

Всем доброго дня! Подскажите, пожалуйста, пытаюсь добавить в Розницу 2.1 внешний...

Как получить кпс счета в 1С 8.3?

Делаю ВПФ для РКО мне нужно получить кпс кредита по счету 201.4(касса) , реквизи...

1С 8.2: Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"

Всем привет. Помогите пожалуйста!!!!!!!!!!!!!!! Выдает ошибку. Была пропущена т...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

Расчет районного коэффициента в больничном листе

Добрый день! Очень нужна помощь! При расчете б/л не верно считает положительную ...

Отражение зарплаты в регламентирован ним учете

Использую Зуп 2.5 Потребовался отчёт для выборки данных по сотрудникам из докуме...

Возврат по картам по зарплате, в случае изменения реквизитов банка

По карте была перечислена зарплата, но платеж вернулся (изменились реквизиты бан...

Составление отчета

Здравствуйте!! Нужна помощь !!! что означает Ошибка получения информации набора ...

Не могу активировать настройку

Добрый день, скачал учебную версию 8.3 Захотел внести изменения в конфигурацию З...