1

Достать значение с табличного поля

#1С Управление торговлей

Доброго дня! Платформа 8.3 Толстый клиент. УТ 10.3 Подскажите в каком направлении копать. Есть номенклатура в ней табличное поле “МестаХранения” в нём есть колонка ячейка, каким образом мне в другом документе “ПриходныйОрдерНаТовары” вывести в новой колонке эту ячейку?

Как то выводит но не правильно, одна и та же ячейка по всем строкам и док. начинает немного тормозить: Вся структура:

Функция МестоХранения(Номенклатура) Экспорт Текст = “ВЫБРАТЬ | ПриходныйОрдерНаТовары.Товары.( | Номенклатура | ), | МестаХраненияНоменклатуры.МестоХранения, | ПриходныйОрдерНаТовары.Склад |ИЗ | Документ.ПриходныйОрдерНаТовары КАК ПриходныйОрдерНаТовары | ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.МестаХраненияНоменклатуры КАК МестаХраненияНоменклатуры | ПО ПриходныйОрдерНаТовары.Склад = МестаХраненияНоменклатуры.Склад | И ПриходныйОрдерНаТовары.Товары.Номенклатура = МестаХраненияНоменклатуры.Номенклатура”;

   Запрос = Новый Запрос;
   Запрос.Текст = Текст;
   Результат = Запрос.Выполнить();

Выборка = Результат.Выбрать(); МестоХранения = ?(Выборка.Следующий(),Выборка.МестоХранения,0); Возврат МестоХранения;

КонецФункции

Процедура ПоказатьМестоХранения(КолонкиТабПоля, ЯчейкиСтрокиТабПоля, Номенклатура) Экспорт Если КолонкиТабПоля.МестоХранения.Видимость Тогда МестоХранения = МестоХранения(Номенклатура); ЯчейкиСтрокиТабПоля.МестоХранения.УстановитьТекст(МестоХранения); Иначе ЯчейкиСтрокиТабПоля.МестоХранения.УстановитьТекст(“”); КонецЕсли; КонецПроцедуры

Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

ПоказатьМестоХранения(мКолонкиТовары, ОформлениеСтроки.Ячейки, ДанныеСтроки.Номенклатура);

КонецПроцедуры

 89 0
ДобавленоПавел5555533 дня назад
Отредактировано16 дней назад


Добавить комментарий

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Не выводится внешний отчёт с управляемой формой.

Всем доброго дня! Подскажите, пожалуйста, пытаюсь добавить в Розницу 2.1 внешний...

Как получить кпс счета в 1С 8.3?

Делаю ВПФ для РКО мне нужно получить кпс кредита по счету 201.4(касса) , реквизи...

1С 8.2: Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"

Всем привет. Помогите пожалуйста!!!!!!!!!!!!!!! Выдает ошибку. Была пропущена т...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Новое

Ошибка при выгрузке информационной базы

При выгрузке ИБ в конфигураторе возникает ошибка (Запись дампа и “Программа "1cv...

Vendita UGG, Ugg economici Pantofole Stivali Online

ugg boots per le donne ugg boots. [b][url=http://www.uggsmen.top/it/]ugg vendita...

Gioielli Pandora Uscita, Pandora gioielli a buon mercato a Pandora Jewelly deposito

Pandora Bracciali e collane per le donne Bracciali Pandora fai da te con charms ...

Donna Canada Goose Goose Parka Dawson Summit Rosa - €295.74 : orologi replica Omega, canadagooseonsale.top

canada - 2016il canada goosecanada - vest [b][url=http://www.canadagooseonsale.t...