0

Диалог выбора файла в 1С 8

#1С 8.2

Народ расскажите как вызвать диалог выбора файла в 1С8, что б у меня в поле ввода попал полный путь к выбранному файлу.

 14813 2
Добавленоuser140928750233863 дня назад
Последняя активность359 дней назад


Добавить комментарий

Dzen написал:863 дня назад0

В своей обработке создаешь строковый реквизит ПутьКФайлу, на форму кидаешь поле ввода с данными этого реквизита. На событие поля ввода Начало выбора создаешь такую процедуру:

Процедура ПутьКФайлуНачалоВыбора(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка= Ложь;
    если Не ВыбратьФайл(ПутьКФайлу, РежимДиалогаВыбораФайла.Открытие, "Выбор файла данных", "*.dbf") тогда
        Сообщить("Не удалось выбрать файл!");
    КонецЕсли;
КонецПроцедуры

Функция ВыбратьФайл(ПолноеИмяФайла, Режим, Заголовок, Фильтр)

    Диалог = Новый ДиалогВыбораФайла(Режим);
    Диалог.Заголовок                 = Заголовок;
    Диалог.ПредварительныйПросмотр     = Ложь;
    Диалог.Фильтр                   = Фильтр;

    Если ЗначениеЗаполнено(ПолноеИмяФайла) Тогда
        Диалог.ПолноеИмяФайла= ПолноеИмяФайла;
    КонецЕсли;

    Если Диалог.Выбрать() Тогда
        ПолноеИмяФайла= Диалог.ПолноеИмяФайла;
        Возврат Истина;
    Иначе
        Возврат Ложь;
    КонецЕсли;

КонецФункции

Вот и все, после выбора файла в реквизите ПутьКФайлу у тебя будет полный путь к нему

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Загрузка адресов для ФизЛиц из Excel файла

Есть ли какие-нибудь наработки для загрузки адресов ФизЛиц из Excel файла в базу...

1С 8.3 неверный формат файла выгрузки данных

Создаю заявку на кассовый расход (сокращённая) Затем Сервис - Обмен с казначейс...

Загрузка из внешнего файла

Добрый день! Подскажите, пожалуйста, в след.ситуации: Пытаюсь загрузить номенкла...

Ошибка 0300200000: Синтаксис файла не соответствует требованиям формата

Здравствуйте! При сдаче Заявления о ввозе товаров и уплате косвенных налогов чер...

Чтение файла .xls из Интернета

Добрый день! подскажите, пожалуйста, в моей ситуации. ФайлНаВебСервере = “htt...

Новое

Работа с регистром накопления и документами

Друзья! Прошу помощи! Есть документ ПередачаОбъектаВПрокат, который выполняет дв...

Компановщик макета неуправляемых форм

Добрый вечер! Проблема состоит в следующем: происходит динамическое формирование...

как убрать Партионный учет с одного счета?

Имеется 1 с 8.2 в настройках управления МПЗ выставлено “ведется учет по партиям...

Погашение стоимости спецодежды

Добрый день. Столкнулась вот с какой проблемой: при проведении документа в 1С 8...

Привязка контрагента к менеджеру

Добрый день! Подскажите, пожалуйста, есть ли возможность в 1С 8.3 Предприятие сд...