0

Диалог выбора файла в 1С 8

#1С 8.2

Народ расскажите как вызвать диалог выбора файла в 1С8, что б у меня в поле ввода попал полный путь к выбранному файлу.

 17424 2
Добавленоuser140928750233994 дня назад
Последняя активность489 дней назад


Добавить комментарий

Dzen написал:994 дня назад0

В своей обработке создаешь строковый реквизит ПутьКФайлу, на форму кидаешь поле ввода с данными этого реквизита. На событие поля ввода Начало выбора создаешь такую процедуру:

Процедура ПутьКФайлуНачалоВыбора(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка= Ложь;
    если Не ВыбратьФайл(ПутьКФайлу, РежимДиалогаВыбораФайла.Открытие, "Выбор файла данных", "*.dbf") тогда
        Сообщить("Не удалось выбрать файл!");
    КонецЕсли;
КонецПроцедуры

Функция ВыбратьФайл(ПолноеИмяФайла, Режим, Заголовок, Фильтр)

    Диалог = Новый ДиалогВыбораФайла(Режим);
    Диалог.Заголовок                 = Заголовок;
    Диалог.ПредварительныйПросмотр     = Ложь;
    Диалог.Фильтр                   = Фильтр;

    Если ЗначениеЗаполнено(ПолноеИмяФайла) Тогда
        Диалог.ПолноеИмяФайла= ПолноеИмяФайла;
    КонецЕсли;

    Если Диалог.Выбрать() Тогда
        ПолноеИмяФайла= Диалог.ПолноеИмяФайла;
        Возврат Истина;
    Иначе
        Возврат Ложь;
    КонецЕсли;

КонецФункции

Вот и все, после выбора файла в реквизите ПутьКФайлу у тебя будет полный путь к нему

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Загрузка адресов для ФизЛиц из Excel файла

Есть ли какие-нибудь наработки для загрузки адресов ФизЛиц из Excel файла в базу...

1С 8.3 неверный формат файла выгрузки данных

Создаю заявку на кассовый расход (сокращённая) Затем Сервис - Обмен с казначейс...

Загрузка из внешнего файла

Добрый день! Подскажите, пожалуйста, в след.ситуации: Пытаюсь загрузить номенкла...

Ошибка 0300200000: Синтаксис файла не соответствует требованиям формата

Здравствуйте! При сдаче Заявления о ввозе товаров и уплате косвенных налогов чер...

Чтение файла .xls из Интернета

Добрый день! подскажите, пожалуйста, в моей ситуации. ФайлНаВебСервере = “htt...

Новое

Управление организацией (УпрО)

Управление организацией– обеспечивает базовый функционал автоматизации учёта пре...

Исключение выходных в командировке из оплаты по среднему

Приветствую! 1С ЗУП 8.2.5 (2.5.112.1) Минфин издал письмо 4-1/В-608 от 13 август...

Работа с ККТ (2 системы налогооблажения) через 1с розница

Добрый день, помогите/подскажите нубу. Ситуация следующая: есть ИП, у которого м...

Внешняя печатная форма сдельного наряда

Создала Внешнюю печатную форму сдельного наряда в ЗУП 3.1 Печатает выполненные ...

Требуется Ведущий программист 1С (г. Хабаровск)

В крупный лесопромышленный холдинг требуется Ведущий программист 1С. Пятидневная...