0

1С 8.2: Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"

#1С 8.2#1С Бухгалтерия

Всем привет. Помогите пожалуйста!!!!!!!!!!!!!!!

Выдает ошибку. Была пропущена точка. Исправила. Выдавал другую ошибку теперь опять эту.

{Документ.ОказаниеУслуги.МодульОбъекта(59)}: Ошибка при вызове метода контекста (Выполнить) ВыборкаРезультатаЗапроса = Запрос.Выполнить().Выбрать(); по причине: {(1, 1)}: Ожидается выражение “ВЫБРАТЬ”

Процедура ОбработкаПроведения(Отказ, Режим)

Запрос = Новый Запрос; Если Режим = РежимПроведенияДокумента.Оперативный Тогда ЗапросТекст = “ВЫБРАТЬ | ОказаниеУслугиПереченьНоменклатуры.Номенклатура, | ОказаниеУслугиПереченьНоменклатуры.Количество, | ОказаниеУслугиПереченьНоменклатуры.Номенклатура.ВидНоменклатуры КАК ВидНоменклатуры, | ОказаниеУслугиПереченьНоменклатуры.Сумма, | ОстаткиМатериаловОстатки.КоличествоОстаток КАК КоличествоОстаток, | СтоимостьМатериаловОстатки.СтоимостьОстаток, | ОстаткиМатериаловОстаткиНаСкладе.КоличествоОстаток КАК КоличествоНаСкладе |ИЗ | Документ.ОказаниеУслуги.ПереченьНоменклатуры КАК ОказаниеУслугиПереченьНоменклатуры | ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.СтоимостьМатериалов.Остатки(&МоментВремени, Материал В (&СписокНоменклатурыДокумента)) КАК СтоимостьМатериаловОстатки | ПО ОказаниеУслугиПереченьНоменклатуры.Номенклатура = СтоимостьМатериаловОстатки.Материал | ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиМатериалов.Остатки(&МоментВремени, Материал В (&СписокНоменклатурыДокумента)) КАК ОстаткиМатериаловОстатки | ПО ОказаниеУслугиПереченьНоменклатуры.Номенклатура = ОстаткиМатериаловОстатки.Материал | ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиМатериалов.Остатки( | &МоментВремени, | Материал В (&СписокНоменклатурыДокумента) | И Склад = &СкладВДокументе) КАК ОстаткиМатериаловОстаткиНаСкладе | ПО ОказаниеУслугиПереченьНоменклатуры.Номенклатура = ОстаткиМатериаловОстаткиНаСкладе.Материал |ГДЕ | ОказаниеУслугиПереченьНоменклатуры.Ссылка = &Ссылка | |ДЛЯ ИЗМЕНЕНИЯ | РегистрНакопления.ОстаткиМатериалов.Остатки, | РегистрНакопления.СтоимостьМатериалов.Остатки”; Запрос.УстановитьПараметр(“СкладВДокументе”, Склад); Иначе Запрос.Текст = “ВЫБРАТЬ | ОказаниеУслугиПереченьНоменклатуры.Номенклатура, | ОказаниеУслугиПереченьНоменклатуры.Количество, | ОказаниеУслугиПереченьНоменклатуры.Номенклатура.ВидНоменклатуры КАК ВидНоменклатуры, | ОказаниеУслугиПереченьНоменклатуры.Сумма, | ОстаткиМатериаловОстатки.КоличествоОстаток КАК КоличествоОстаток, | СтоимостьМатериаловОстатки.СтоимостьОстаток |ИЗ | Документ.ОказаниеУслуги.ПереченьНоменклатуры КАК ОказаниеУслугиПереченьНоменклатуры | ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.СтоимостьМатериалов.Остатки(&МоментВремени, Материал В (&СписокНоменклатурыДокумента)) КАК СтоимостьМатериаловОстатки | ПО ОказаниеУслугиПереченьНоменклатуры.Номенклатура = СтоимостьМатериаловОстатки.Материал | ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиМатериалов.Остатки(&МоментВремени, Материал В (&СписокНоменклатурыДокумента)) КАК ОстаткиМатериаловОстатки | ПО ОказаниеУслугиПереченьНоменклатуры.Номенклатура = ОстаткиМатериаловОстатки.Материал |ГДЕ | ОказаниеУслугиПереченьНоменклатуры.Ссылка = &Ссылка | |ДЛЯ ИЗМЕНЕНИЯ | РегистрНакопления.ОстаткиМатериалов.Остатки, | РегистрНакопления.СтоимостьМатериалов.Остатки” ; КонецЕсли; Запрос.УстановитьПараметр(“МоментВремени”, МоментВремени()); Запрос.УстановитьПараметр(“СписокНоменклатурыДокумента”, ПереченьНоменклатуры.ВыгрузитьКолонку(“Номенклатура”)); Запрос.УстановитьПараметр(“Ссылка”, Ссылка); ВыборкаРезультатаЗапроса = Запрос.Выполнить().Выбрать(); НА ЭТУ СТРОЧКУ РУГАЕТСЯ Пока ВыборкаРезультатаЗапроса.Следующий() Цикл //Проверить остаток при оперативном проведении. Если Режим = РежимПроведенияДокумента.Оперативный Тогда Если ВыборкаРезультатаЗапроса.ВидНоменклатуры = Перечисления.ВидыНоменклатуры.Материал Тогда Остаток = ?(ВыборкаРезультатаЗапроса.КоличествоОстатокНаСкладе = Null, 0, ВыборкаРезультатаЗапроса.КоличествоОстатокНаСкладе); Если Остаток < ВыборкаРезультатаЗапроса.Количество Тогда Сообщить(“Материал” + СокрЛП(ВыборкаРезультатаЗапроса.Номенклатура) + “имеется только” + Остаток); Отказ = Истина; Возврат; КонецЕсли; КонецЕсли; КонецЕсли; //Сформировать движения Если ВыборкаРезультатаЗапроса.ВидНоменклатуры = Перечисления.ВидыНоменклатуры.Материал Тогда

  //Регистр Остатки Материалов Расход
  Движение = Движения.ОстаткиМатериалов.Добавить();
  Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
  Движение.Период = Дата;
  Движение.Материал = ВыборкаРезультатаЗапроса.Номенклатура;
  Движение.Склад = Склад;
  Движение.Количество = ВыборкаРезультатаЗапроса.Количество;
  //Регистр стоимость материалов расход
  Движение = Движения.СтоимостьМатериалов.Добавить();
  Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
    Движение.Период = Дата;
  Движение.Материал = ВыборкаРезультатаЗапроса.Номенклатура;
  //Рассчитать стоимость материалов
  СтоимостьМатериала = ?(ВыборкаРезультатаЗапроса.КоличествоОстаток=Null,0,ВыборкаРезультатаЗапроса.СтоимостьОстаток / ВыборкаРезультатаЗапроса.КоличествоОстаток);
  Движение.Стоимость = СтоимостьМатериала * ВыборкаРезультатаЗапроса.Количество;

КонецЕсли;

//Регистр Продажи Движение = Движения.Продажи.Добавить(); Движение.Период = Дата; Движение.Номенклатура = ВыборкаРезультатаЗапроса.Номенклатура; Движение.Клиент = Клиент; Движение.Мастер = Мастер; Движение.Количество = ВыборкаРезультатаЗапроса.Количество; Движение.Выручка = ВыборкаРезультатаЗапроса.Сумма; Если ВыборкаРезультатаЗапроса.ВидНоменклатуры = Перечисления.ВидыНоменклатуры.Материал Тогда Движение.Стоимость = СтоимостьМатериала * ВыборкаРезультатаЗапроса.Количество; Иначе Движение.Стоимость = 0; КонецЕсли; КонецЦикла; //Записать движения регистров Движения.ОстаткиМатериалов.Записать(); Движения.СтоимостьМатериалов.Записать(); Движения.Продажи.Записать(); КонецПроцедуры

Надежда только на Вас!!

 2803 1
ДобавленоMaks54562 дня назад
Отредактировано546 дней назад


Добавить комментарий

Кирилл написал:562 дня назад0

Добрый день!)

Попробуйте угадать сами:

Запрос = Новый Запрос;

Если Режим = РежимПроведенияДокумента.Оперативный Тогда

   ЗапросТекст =

   "ВЫБРАТЬ

Если не получилось, говорю - к “запросу” не прикреплен текст запроса. Он почему то болтается в переменной “ЗапросТекст ” сам по себе :)

Ответить

Задать вопрос!

Наш канал на Youtube

Изучаете 1С? Скачайте 200 видео по 1С бесплатно:

Похожее

Ошибка при отправке интернет-писем

Конфигурация пустая. Требуется прописать модуль получения и отправки писем. Все ...

Проблема с расчетом себестоимости в УТ 11.1.10.131

Добрый день, помогите пожалуйста разобраться с проблемой. При закрытии месяца вы...

Если нет разницы!!Зачем тогда Условие В ВТ? Или все таки разница ЕСТЬ!!!!!

Привет. Пожалуйста подскажите! И ТАК ВОПРОС: В параметрах виртуальной таблицы ...

Достать значение с табличного поля

Доброго дня! Платформа 8.3 Толстый клиент. УТ 10.3 Подскажите в каком направлени...

Новое

Бюджетирование - статьи бюджета по произвольным данным

Помогите, пожалуйста! Создаю статью бюджета с произвольными данными. Загружаю с...

егаис

Добрый вечер. Прошу Вас помочь. Для получения накладных от производителя делаю з...

Концептуальная модель (инфологическая) распределенной БД

Очень нужна ваша помощь. Создала распределенную 1С БД( хоть она и не распределен...

Где находится анткетирование клиентов в УТ 11?

Подскажите где почитать про анкетирование в УТ. Нужно изучить как оно устроено....

беда :(

Добрый день, Помогите разобраться, пжл. По неизвестным причинам с помощью моих в...